F4 ground handling after update

  • The F4 Corsair has become nasty on the ground after a recent update. Firstly, it rolls on flat ground at idle power. Secondly, the wheel brakes have gone nuts. They are very severe even on light application, and the whole airframe bounces up and down like a yoyo when the brakes are touched, even at low speed. I really don't think the oleo legs would be that bouncy in RL.

  • These are two separate issues, first the high sensitivity of the brakes with the button or key input and secondly the high ground idle as mentioned.

    Both should be fixed "automatically" when we adjust the brake input and engine physics. So this should be fixed in the not too far future, give us a bit of time.

  • LOL

    Devons rig

    Intel Core i7 8700K @ 5.0GHz / 32.0GB G.SKILL TridentZ Series Dual-Channel Ram / ZOTAC GAMING GeForce® RTX 2080 Ti Triple Fan / Sound Blaster Z / Oculus Rift VR Headset / Klipsch® Promedia 2.1 Computer Speakers / ASUS ROG SWIFT PG279Q ‑ 27" IPS LED Monitor ‑ QHD / 2x Samsung SSD 850 EVO 500GB / Windows 10 Pro 64-bit /Gigabyte Z370 AORUS Gaming 5 Motherboard

  • Even after updates, the F4U is still dancing like a funky chicken when the wheel brakes are applied.

    Have you tried using it with rudder pedals?

    With the button currently almost all aircraft tend to bounce up and down with the nose gear.

    For now I think we just have spam the brake button in moderate speed.

  • Using standard Saitek pedals I found that, with the Corsair, Pitts and Extra, backing off 'rudder sensitivity' to 1/4 inch right of LOW and the 'deadzone' between the 'O' and second 'N' of NONE helps a lot. This makes the less touchy models feel like they're on rails. Normal ops, not in VR.

  • Hi guys,

    I tried the F4U with my rudder pedals and did not have any issues. Apart from the brakes being quite strong for moderate inputs. But with small inputs I was able to stop the F4U without problems. Please check your toe brake calibration. In the last version you had to move the pedal to about 50% when asked to center the controls. Otherwise a tiny input would result in 50% command, which is probably what you are experiencing.

  • I've looked in the cockpit and couldn't find a lever so I never added a parking brake. Not the only aircraft where there might not be a parking brake.

    I could add them but then you'd never know what the state is until you advance throttle...

  • I downloaded the old school pilot manual for the corsair (reprinted in 1977). They don't mention a parking brake in there either. Weird. I guess it only used chocks as a parking brake?

    Sounds like we are waiting for the next update when hopefully brakes and engines will be addressed.

  • Hi guys,

    I tried the F4U with my rudder pedals and did not have any issues. Apart from the brakes being quite strong for moderate inputs. But with small inputs I was able to stop the F4U without problems. Please check your toe brake calibration. In the last version you had to move the pedal to about 50% when asked to center the controls. Otherwise a tiny input would result in 50% command, which is probably what you are experiencing.

    Yes, the problem is something to do with this. When I go to settings, I see that a very small application of toe brakes makes the slider jump to 50%. Note that this is something in Aerofly - in windows "game controllers" panel, the toe brakes go up smoothly from zero as you would expect.


    I think the problem is that the pedals are treated as if they have both negative and positive displacement ranges. Their default is negative maximum when not depressed. As soon as they are touched, they jump to zero, which the game regards as 50%.


    I've looked at recalibrating inside Aerofly, but there isn't an option to center the controls. There is only the instruction to move them to their fullest extent.

  • Yes, the problem is something to do with this. When I go to settings, I see that a very small application of toe brakes makes the slider jump to 50%. Note that this is something in Aerofly - in windows "game controllers" panel, the toe brakes go up smoothly from zero as you would expect.


    I think the problem is that the pedals are treated as if they have both negative and positive displacement ranges. Their default is negative maximum when not depressed. As soon as they are touched, they jump to zero, which the game regards as 50%.


    I've looked at recalibrating inside Aerofly, but there isn't an option to center the controls. There is only the instruction to move them to their fullest extent.

    You need to recalibrate your controls. Right after you are asked to move the controls to their full deflection you get to center them. When you depress your pedals half way when you click ok they should work correctly.