Cultivation (trees, buildings, lights, etc. ) not displayed in the game

  • Hello everyone,

    I created a simple .tsc file for an airport with a corresponding entry for the cultivation file (cultivation is located inside a .toc file which is referenced inside the .tsc file).

    The cultivation file has been auto-generated from the OpenStreetMap data using scengen. I tried placing pragma which loads cultivation from .toc file in various location inside the .tsc file, but the cultivation is simply not loaded / displayed in the game. Instead of using auto-generated data, I also tried using a very simple example .toc file with lights placed at the location of the tower and runway threshold, but that didn't work either. In addition to that, I tried another area which is more flat, because this area is hilly and I thought it has something to do with automatic height inference, but it also didn't work.

    I believe .tsc file format is correct because if I place cultivation pragma in a different location, .tsc file doesn't load and airport is not visible inside the game.

    Any idea what could be going on? I attached a zip file with the corresponding airport directory (there are a bunch of .toc files inside the directory because I tried various options, but none worked). If it makes it easier, I can also gist the corresponding .tsc and .toc files although the auto-generated .toc file is quite large.

    Is there a developer console or similar where I could see some debug messages (e.g. which .tsc and .toc files are loaded, etc.) which would make it easier to troubleshoot why the cultivation objects are not displayed?


  • Hi Kami,

    the TSC file needs to have the list of cultivation files. Look at some TSC files that use cultivation files, to see the syntax.

  • admin Thank you - I did try this (and many variations of that) before posting (you can check the attached zip file above for an example).

    Here is an example of .tsc file for another airport which also doesn't work. As you can see, it contains "list_tmsimulator_scenery_cultivation][cultivation_files]" pragma.

    As mentioned above, I tried many variations of that (putting this pragma in different locations in the .tsc file, tried different file names, different content in .toc file, etc.).

    I know it must be something simple / stupid, but I simply haven't been able to figure it out yet. I also tried an example from kdwh and it doesn't show up. I'm running the latest version available on Steam.

    I'm also using scenery files generated by geoconvert - could this something to do it with it (e.g. scenery files are placed on top of the cultivation instead of vice-versa or similar)?

  • I put it in the same directory where the .tsc file is (see the attached zip above). I also tried using full absolute path, partial relative path, etc. nothing works.

    Without a developer console / debug build / similar it's sadly really had to troubleshoot this.

    To confirm it has nothing to do with the geoconvert scenery data causing issues, I just emptied "images/" directory and left "places/" and everything else in place and it still doesn't work - no trees, no buildings, no lights aka totally flat.

    Edit: I also tried using example directly from kdwh. I just changed the coordinates to match the local ones, but nothing shows up.

  • admin I do, that's for a different airport which I didn't include in the zip file. I have a file called ljlj.toc in "scenery/places/ljlj" directory (please see the screenshot above).

    For some reason, kdwb example works fine, but if I just copy that example, change the coordinates to match a local location it doesn't work (cultivation is not displayed). Could it have something to do with the coordinate system since the airport is located in Europe? I noticed Swiss airports use "swiss" coordinate system, but I'm using lonlat. Having said that, runway and runway threshold placement works just fine, so it seems lonlat is working just fine.

    My original guess was something with the elevation model, but then I tried another location which is mostly flat and cultivation is also not displayed. I also checked "tm.log" file and I don't see any errors or similar.

    Is there a way to make logging more verbose / enable debug logging so I could see messages when cultivation file is loaded and parsed or similar?

    Edit: I found some developer / debug related settings in "main.mcf", but enabling those doesn't seem to make debug log any more verbose and useful.

  • Hi,

    I'll send you the corrected files in a few minutes.

    I modified your airport coordinate, which was 1 degree off the rest of your values.

    I added a dummy runway to show up airport lights.

    I added the building_textures folder for the buildings.

    The cultivationTOC was correct.

    Please check these modifications and you will be able to do more interesting sceneries.



    The building_textures folder is too big fro upload. Please use it from the airport design package I published.

    Just make sure, to take the folder with the ttx files, not the bmp files.

    Place this folder into your zagorje folder.

  • Rodeo thanks a lot.

    In case it helps, I'm also attaching a zip file of both of the airports where I tried to get cultivation to work (there are a bunch of test .toc files inside one of the airport folders which you can ignore).

    Edit: I could only attach zip for a single airport, because the generated TOC file for LJLJ airport is too big.

  • Rodeo Awesome, thanks a lot - I can confirm it works with the changes you have made. It looks like a great start, indeed :)

    As far as the actual root cause goes - it looks like cultivation didn't load because .tsc file was missing an object for the runway?

    I basically copied "runway.tmb" to the directory and copied object pragma for dummy runway and it started working:

                    <[vector3_float64][position][14.999933 46.142947 -4]> //Dummy Runway

    If that's the case, it would be great to document that to save others some time :)