Low Frame Rates

    • Official Post

    Your limiting factor is the refresh rate of your monitor. If you want higher FPS you have two choices here, either buy a monitor that has a higher refresh rate or turn VSync off in Aerofly. VSync is doing its job here.

  • Your limiting factor is the refresh rate of your monitor. If you want higher FPS you have two choices here, either buy a monitor that has a higher refresh rate or turn VSync off in Aerofly. VSync is doing its job here.

    Exactly, you have to choose between 60 FPS (vsync on) and image tearing (vsync off).

    I'm using a Track IR and must say 60 FPS with vsync in AFS2 results in chopped image movements when turning head (this isn't the case in other simulators where 40 FPS can be very smooth).


    I ended up preferring the slight image tearing but smooth, natural movements using vsync off.

    I found the chopped image with vsync on much more "immersion killing" than image tearing, but it's eventually a question of taste...


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • Using an external framelimeter, like rivatuner, at 60 fps solved choppy images for me.

    I also externally let my graphic card driver do the vsync, but probably using the ingames vsync with an external framelimiter will allready solve the choppyness for you.


    (Vsync and framelimit may seem like double measures, but it defenitly worked for me)


    Maybe you can give that a try.

  • Just curious, does Vsync have any affect in VR? What is the recommended setting when using an HMD, on or off?


    Thanks

    Redtail

    KFRG, KTEB, KEWR, KLGA

    ~Straighten up and fly right~


    DESKTOP: i7-7700k @5GHz (water cooled), Nvidia GTX 1080Ti FTW3, 32GB DDR4, 500GB SSD, Oculus Rift CV1, Windows 10 Home 64 bit,

    TM HOTAS Warthog (large spring removed), Saitek PRO Flight Combat Rudder Pedals, YOKO yoke!

    Laptop (gaming): Acer Predator Helios 500- Intel Core i7-8750H @4.1GHz, Nvidia GTX 1070, 32GB DDR4, 256GB SSD/1TB HDD.

    Gametrix JetSeat FSE (Flight Sim Edition)-USB Vibrating pad. Nextlevel V3 Motion Platform / Sim cockpit.

    • Official Post

    Just curious, does Vsync have any affect in VR? What is the recommended setting when using an HMD, on or off?


    Thanks

    We recommend that you turn VSync to OFF for any VR. Using VSync in VR will only muddy the waters with no effect.

  • Ok, thanks Jeff.

    Redtail

    KFRG, KTEB, KEWR, KLGA

    ~Straighten up and fly right~


    DESKTOP: i7-7700k @5GHz (water cooled), Nvidia GTX 1080Ti FTW3, 32GB DDR4, 500GB SSD, Oculus Rift CV1, Windows 10 Home 64 bit,

    TM HOTAS Warthog (large spring removed), Saitek PRO Flight Combat Rudder Pedals, YOKO yoke!

    Laptop (gaming): Acer Predator Helios 500- Intel Core i7-8750H @4.1GHz, Nvidia GTX 1070, 32GB DDR4, 256GB SSD/1TB HDD.

    Gametrix JetSeat FSE (Flight Sim Edition)-USB Vibrating pad. Nextlevel V3 Motion Platform / Sim cockpit.

    • Official Post

    For VR VSync should be set to OFF.

    Since VR runs at 90FPS setting VSync to 120 will have no effect except possibly a negative affect.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Aerofly's VSync doesn't work for me at all. I've recently posted on Steam about this. In order to keep things simple, here's my post:


    Are you sure the VSync option is working correctly?


    While all of my other games are correctly capped at 60 FPS (as my screen uses 60 Hz) when enabling the VSync option, Aerofly's values happily jump somewhere between 90 and 200 FPS.

    The only difference between VSync disabled/enabled is a slightly lower FPS range when enabling it (at least that's what it looks like). Changing the VSync settings of the Radeon driver doesn't have any effect. I'm also still getting screen tearing while Aerofly's VSync option is enabled, which is the very thing VSync is designed to prevent. I would say VSync isn't active, although it says so.

    Edit: Not to mention roughly 2000 FPS while displaying Aerofly's menus that make my graphic card's coils whine (seriously).


    Here's a more detailed example:

    Aerofly's main menu right after launching it: 3430 FPS with no framerate limitation, 2180 FPS with VSync activated.


    I'm using a Radeon RX 580 with 8 GB, but I'm aware that most people here seem to use Nvidia GPUs. Are there any Radeon users here who have Aerofly's VSync option working as intended?


    Edit: While enabling VSync in the app-specific settings of the Radeon software has no effect on Aerofly, I've just noticed that setting it to "Always On" (and Always On only - nothing else) in Radeon's global settings has. So that's the only way to make VSync work in Aerofly I've found so far. But this is sort of work-aroundish, as it affects not only Aerofly, and Aerofly's own VSync option still doesn't work on my system.