Today's Update

  • I hate to have to say this, but since today's mini update the problem with graphic distortions and stutters in urban areas got worse for me. A lot worse. Even lowering the rendering to 1.6 did not help this time. And New York was practically as bad as Chicago.

    This was true both before and after updating to Nvidia's new driver that was released this afternoon.

  • Would you please explain what you refer to as 'graphical distortions and stutters' in the best way that you can?

    I'm pretty sure that no graphical changes have been made in the last update. The update was simply to just fix an error with Aerofly crashing for users using SteamVR mode (basically an internal build found a way into the public build by accident).

    We are currently looking into this shimmering problem as I have detected it as well and confirmed there was something going on.

    Please keep in mind that we are aware of the shimmering problem and trying to find the source and also trying to resolve it.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.



  • I was reluctant to report the problem because I was sure that no real change had been made to the program aside from what you mention, but I really am seeing an increase in the issues. All of the following descriptions are based on observations in VR only.

    By distortion I mean a "swimming" or "boiling" effect in the graphics which seems especially likely to occur within objects that feature right angles in the graphics. Hence it is very prominent on the facades of large buildings with lots of windows or horizontal and vertical "stripes". It frequently does not affect the entire building facade, but only a section, although the anomaly can spread to different sections of the facade as you watch it. The anomalous areas stop showing as rows of vertical and horizontal windows or stripes and appear as fluidly moving distorted rows and columns. It can also appear on the cockpits of planes that have square buttons. It can sometimes be seen in the external flyby mode. The plane will occasionally be seen briefly as two planes superimposed on one another.

    The stutter is a classic dropped frame which keeps the action from moving smoothly. It isn't a FPS problem, which is constant, but an occasional jarringly skipped frame in the animation. These were very rare in the past, but now they are common for me. Lowering the supersampling no longer cures this problem.

    I have also seen the increase in shimmering, but that is another issue.

    If no one else is reporting this then perhaps my Oculus is out of trim (if such a thing is possible). I did the setup procedure again with no improvement. I appreciate your attention to this and I understand that you will do whatever you can, if anything, to address the problem.



  • Bill, no changes in our code in the past updates can explain your observation here.

    We don't intend to push the problem aside here, but we carefully checked our code and the last updates we made did no changes to our graphics engine, that could explain your observations.

    So to make a real test. Set graphic settings to HIGH for now, reduce render scale factor to 1.0 and fly in a non populated area. Then report back if you still see this swimming or boiling effect and try to capture a screenshot and indicate where in the screenshot you observe issues.

    We seem to have two competing effects here: Aliasing effects due to the low resolution of all headsets as well as rendering artefacts if ASW ( asynchronous space warp ) is active and kicks in, if FPS goes below 90.

    So please do the tests as mention, otherwise its hard to help.

  • Similar stuttering for me. All fine except in the past 24 hours I've got stuttering in VR. when turning my head around it drops frames. I might have had the odd one in the past. Though so rare I've not really noticed. Now I get quite a few. Could it have anything to do with the fact that there's a problem now with my monitor will only show twin screen mode now. The setting to make it a single view now doesn't work. Also this has happened in the past 24hrs.

    Edited once, last by Testchamber (December 1, 2017 at 4:23 PM).

  • I will do another thorough test run this afternoon. The stuttering is in fact the worse problem. The graphics anomalies are easier to ignore than the jarring frame drops. My experience with them is exactly like Testchamber's, and it is worst when turning my head to enjoy the draw-dropping views the sim provides in VR.

  • The anomalies do NOT show up in screenshots. They also vanish when you pause the sim and return as soon as you unpause it. That should provide some clue as to what might be happening. The anomaly is only present when things are in motion.

    The anomalies seem to vanish at the 1.0 setting, but interestingly the stuttering is still present.

    Any suggestions as to what settings I might check on my end?

  • I had stuttering after the last update. I did what I always do, deleted main.mcf and reset exactly the same graphics settings, and just like the past two or three times, no more stutters. I don't know what that does, it might even defy logic, but it works.

  • I did follow your suggestions, exactly. You said increase settings to HIGH, and set SS to one. Did that, got no anomalies but still had stutters. Tried to take a screenshot of the anomalies at the higher ss setting, as you asked, and it didn't show up on the screenshot.

    Ah well. If it is only me, there is nothing for it anyway. If it isn't only me you will find a solution.

    I hope that my observations have been helpful.

  • In order to find out the cause for what you observe in the Rift, I wanted to first achieve a consistent setting inside Aerofly.

    If you have set the parameters as described, enabled the display of FPS in Aerofly by pressing CONTROL + F1.

    You can't see that in the Oculus itself, you have to take of the Rift for that. But you can observe the FPS by
    taking off the Rift and moving it around. Does the FPS stay at 90 or does it occasionally drop? For the Rift
    to still 'work' you might have to hold a finder between the two lenses ( there is a small sensor ) so the Rift
    things its being used.

    I know a little difficult to follow, but once you have done the test, we can say what the cause is. I pretty much
    assume its ASW kicking in and ASW is bad if your FPS vary a lot.

  • Here is what I found. Just as you suspected, with the ss set to 1.0, the framerate stayed at 90fps. With the ss set to 2.0, the fps dropped to 45.

    Why this is happening now is a mystery. I have been running the program on the same machine with over 280 hours logged and I never saw this problem until this week. And my machine is plenty powerful: 6700k at 4.7, 1080ti overclocked.

  • I am also observing significantly worse performance after this latest update. I am a Rift user, and until a few days ago, things were fantastic. However, I now observe a lot of dropped frames, most noticeably when turning my head. The effect is exacerbated when landing at scenery-rich airports like Van Nuys. My specs:

    i7 4770k (4.4 GHz)

    EVGA GeForce GTX 1080 Ti SC2

    32 GB DDR3 1886 MHz RAM

    Samsung 840 EVO SSD 750 GB

    Windows 10 Pro 64-bit

    Nvidia 388.13 graphics drivers

    Thanks for looking into this.


  • Something seems to have messed up ASW in Oculus. Like you I was also experiencing near perfection until this last week. I also see that like me you have a 1080 Ti. It's very frustrating to have that heavy iron and suddenly be seeing stutters!

  • Please understand that this is all being looked at. You have to give us some time to see what's going on before we can see how to resolve it. We can almost be certain that this is NOT from something that was changed in Aerofly.

    I have said this a few times already but I want you all to know that it's not just being ignored.

    We also have a strong suspicion that ASW is the culprit for a couple of things recently. Has anyone tried to run Aerofly with ASW disabled (from the Oculus tool)?

    If so, please report your results.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.



  • I ran it with ASW off via pressing ctrl 1. The graphics problem disappeared, but it was like running a slideshow with supersampling set to 2.0 in city scenery.

    My conclusion is that ASW has always been running with no problems for me until recently. Whatever you did in that update to increase frame rate has been semi-disastrous for me. I could run the sim with everything at highest level except for shadows, with ss set to 2.0, and get a butter smooth experience. That is no longer the case.

    I really think you need to examine whatever it was that you did in the update where you announced that we would get better performance in high density areas.

  • To be honest, only code clean up was performed, and in the latest update a fix that took out an error for SteamVR users that snuck into the public version by accident. None of this had anything at all to do with graphics. Hang in there, extensive testing is being done to figure out why the problems now, but I can be pretty sure that we aren't fixing a bug but rather finding a fix to a recent change either by Oculus or NVidia.

    In testing I have personally noticed the shimmering problems but not the performance issues. In fact on my 1080ti machine I'm getting solid 90FPS even when testing with ASF off in VR (Oculus).

    Running non-VR (standard) this is not seen and FPS is well over 150 (VSync off)

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.