Still won't start in Oculus mode

  • This problem was resolved through an update. Please make sure that you have the latest Aerofly version running. Also verify the Steam file integrity to make sure something didn't get corrupt during an update.


    I closed the thread because it pertained to a problem with OculusVR not running. This was detected and resolved therefore your problem might not be related a new thread is needed here.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Yes, I have ensured that I have all the latest updates, and it won't start in Oculus VR mode. It does't exactly what the OP on the previous thread described. I don't think that whatever he thoughts was his problem, supposedly resolved by the update, was the problem, or else I have a different problem. (Ps. I'm not criticizing closing the other thread. I'm just saying that the reason I started a new thread was that the old one was closed, just to head off people telling me: This was already resolved in this other thread. Yeah, been there, seen that. Still have the problem.)

  • No problem, you still have a problem. Let's see if we can fix it for you now.


    At this stage, please post your tm log, it's located in your documents\Aerofly FS 2 folder

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • I'm trying to get the log (network connectivity issues) but in reading the log, it looks like it's trying to use SteamVR instead of the Oculus. (It gets a SteamVR Error 308 key component missing!) But why is it trying to use SteamVR? I've ensured multiple times that I'm telling it to use the Oculus, not SteamVR, so wtf?!

  • Make sure that you haven't added a special running parameter in Steam, or the shortcut if running from your desktop.

    Also, you can try to uninstall only SteamVR and re-install it.


    Just copy/paste the tm log

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • No switches as far as I can tell on either steam or fs2 (checked via properties > ... both at the w10 level and fs2 level inside steam). Here's my tm.log ( says "failed to initialize ovr", which is the only thing I can see and vaguely understand. Just FYI, my oculus was up at the time and working fine!)


    0.00-tmmodule: (tmsystimer,1) (tmsteam,1) (tmrandom,5) (tmsysinputdevicejoystick,10) (tmatmosphere,10) (tm_magnetic_field,11) (tm_time_zones,11) (tmsyssound,20)

    0.00-tmmodule: init modules=(tmsystimer=ok) (tmsteam=ok) (tmrandom=2002730243) (magnetic field=(257 198147)) (time zones=(1024 1048576)) (tmsyssound=(default=Generic Software) (0:Generic Software) (version=1.1) (1.1)) done

    0.47-tmmodule: Program version 2.0.7.39

    0.48-tmmodule: Copyright (C) 1998-2017 IPACS

    0.48-tmsyswin: memory=(physical=16286MB, avail=11733MB) (virtual=19230MB, avail=134217727MB) (27 in use)

    0.48-tmsyswin: operating system (10.0)= Microsoft Windows 10 or newer

    0.49-tmsyswin: monitor size = 519 324

    0.49-tmmodule: fullscreen modes=(1024x768x32x60) (1024x768x32x75) (1152x864x32x75) (1280x768x32x60) (1280x768x32x75) (1280x800x32x60) (1280x800x32x75) (1280x960x32x60) (1280x960x32x75) (1280x1024x32x60) (1280x1024x32x75) (1360x768x32x60) (1366x768x32x60) (1600x1200x32x60) (1680x1050x32x59) (1920x1080x32x59) (1920x1200x32x59)

    2.43-tmimage: preferred ui language = 'en-US'

    2.44-tmimage: preferred language = 'en'

    2.44-tmimage: config folder = 'C:/Users/Moje/Documents/Aerofly FS 2/'

    2.44-tmimage: loading config file 'C:/Users/Moje/Documents/Aerofly FS 2/main.mcf = ok

    3.73-tmmodule: failed to initialize ovr

    3.74-tmxgltext: vr runtime path = 'C:\Program Files (x86)\Steam\steamapps\common\SteamVR\'

    14.78-tmcollision: ERROR: Unable to init VR runtime: Shared IPC Connect Failed After Multiple Attempts (308)checking if running in windows compatibility mode: (reported=10.0) (real=10.0 '10.0.16299')

    14.96-tmmodelmanager: init window: (mdf=59Hz) (window=0x0x1920x1104) (client=1904x1065) (screen=1920x1200) (32bpp) (59Hz) (windowed mode)

    15.66-tmmodule: initializing opengl...init window: (mdf=59Hz) (window=0x0x1920x1104) (client=1904x1065) (screen=1920x1200) (32bpp) (59Hz) (windowed mode)

    46.79-tmmodule: creating opengl context: (createcontextarb) (trying OpenGL Core 4.5= ok) (samplebuffers=0) (colorbits=32) (stencilbits=0) (depthbits=0)

    49.96-tmmodelmanager: gl: (version 4.5) (core profile) (vendor=NVIDIA Corporation) (renderer=GeForce GTX 1070/PCIe/SSE2) (version=4.5.0 NVIDIA 382.66)

    51.44-tmwinogl: gl: (viewport=32768.00x32768.00) (texsize=32768) (texunits=192) (ps-texunits=32) (samples=32) (shading_language=4.50 NVIDIA) (shader_max_vertex=4096) (shader_max_fragment=4096)

    51.46-tmimage: gl: extensions=GL_AMD_multi_draw_indirect GL_AMD_seamless_cubemap_per_texture GL_AMD_vertex_shader_viewport_index GL_AMD_vertex_shader_layer GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_bindless_texture GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_compute_shader GL_ARB_compute_variable_group_size G 51.46-tmimage: gl: wgl extensions=WGL_ARB_buffer_region WGL_ARB_create_context WGL_ARB_create_context_profile WGL_ARB_create_context_robustness WGL_ARB_context_flush_control WGL_ARB_extensions_string WGL_ARB_make_current_read WGL_ARB_multisample WGL_ARB_pbuffer WGL_ARB_pixel_format WGL_ARB_pixel_format_float WGL_ARB_render_texture WGL_ATI_pixel_format_float WGL_EXT_colorspace WGL_EXT_create_context_es_profile WGL_EXT_create_context_es2_profile WGL_EXT_extensions_string WGL_EXT_framebuffe 51.47-tmmodule: gl: extensions used=(anisotropic filter of 16.00) (primitive restart) (vertexarrayobject) (texture array) (gpu shader4) (explicit uniform location) (texture rgtc compression) (texture storage) (buffer storage) (bindless texture) (dsa arb) (dsa ext) (uniform_buffer_object) (drawelementsinstanced) (drawelementsbasevertex) (vertex_type_2_10_10_10_rev) (vertex_attrib_binding) (texturebufferobject) (occlusionquery) (multi_bind) (mdi) (tessellation) (vertexbufferunifiedmemory/shaderbufferload) (invalidatesubdata) (clipcontrol) (polygonoffsetclamp) (viewportindexed) (sync) (timer_query) (debug output) (nv_stereo_view_rendering) (swapcontrol)

    52.19-tmmodelmanager: gl: reducing max texture size from 32768 to 4096

    52.20-tmwinogl: gl: nvidia meminfo: total=8192MB dedicated=8192MB)

    52.75-aerofly: resolution=1904px ss=519.00mm density=3.70 -> csf=1.00 res=1904.000000

    55.83-aerofly: window size=1904x1065 physical display size=519mmx324mm

    56.04-tmimage: loading font 'texture/fontdisplay.tff'=(512x512) (h=37) (nc=8365) ok

    56.25-tmimage: loading font 'texture/hud.tff'=(256x512) (h=48) (nc=123) ok

    56.33-tmimage: loading font 'texture/fonthelp.tff'=(512x512) (h=51) (nc=256) ok

    56.46-tmimage: loading font 'texture/segment.tff'=(256x512) (h=48) (nc=124) ok

    65.54-tmmodule: searching for input devices...

    65.55-tmmodule: searching joysticks...

    66.59-tmsysinputdevicejoystick: joystick 0: 'Logitech Extreme 3D' axes=4 buttons=16 slider=1 pov=1 type=00010214

    66.59-tmmodule: 1 devices found= (Logitech Extreme 3D) (c215046d7dcb4850)

    66.60-tmimage: trackir dll not found (DLL Location key not present)

    66.65-tmmodule: initializing Tobii Eye...

    66.82-tmsystobiieyex: ERROR: (not ready(0) or connected(0))

    67.93-tmmodule: shutting down Tobii Eye... done

    68.01-tmimage: A0 new=6878 del=1582 dmem=5296 memory=15MB

    68.01-tmimage:

    68.01-tmimage: loading model asg29...

    68.20-tmmodelmanager: model: (name='asg29') (directory='aircraft/asg29//')

    68.21-tmimage: loading configfile 'aircraft/asg29///asg29.tmc'

    68.24-tmmodule: contact points 4: (0.153 0.000 -0.581 r=0.170) (-3.877 0.000 -0.255 r=0.123) (-0.183 8.863 0.409 r=0.010) (-0.183 -8.863 0.409 r=0.010)

    71.09-tmscene: shadowmap = 2048x2048 sp=8

    71.10-tmimage: A1 new=10759 del=2399 dmem=8360 memory=23MB

    71.10-tmimage: init terrain 'scenery/'...

    71.11-tmterrain: scenery folder 0: 'C:/Users/Moje/Documents/Aerofly FS 2/scenery/'

    71.17-tmterrain: scenery folder 1: 'scenery/'

    72.38-tmimage: loading dynamics begin 'aircraft/asg29///asg29.tmd'...

    73.46-tmmodelmanager: loading dynamics end: (id=1) (203 dynamics) (176 graphics) (107 sound) (ny=494) (nz=22)

    73.46-tmmodelmanager:

    73.47-tmmodelmanager: mass: 355.640000kg

    73.47-tmmodelmanager: mbs joint 0 <- 1 Stabilizer

    73.48-tmmodelmanager: mbs joint 0 <- 2 Gear

    73.49-tmmodelmanager: 2 multibody joints / 1 components

    111.28-tmmodule: creating mapload thread: ok

    111.29-tmterrain_cmaps: color maps: num=17 ims=1024 levelminmax=0/14

    121.41-tmsimulator: omin=( 64.0, 64.0) bb=( 0.0:65536.0, 0.0:65536.0) numin= 2533 -> nodes= 69 endnodes= 47 endobj= 4992 depth= 7 maxpernode=254 min=( 512.0, 512.0)

    121.44-tmsimulator: omin=( 512.0, 512.0) bb=( 0.0:65536.0, 0.0:65536.0) numin= 3020 -> nodes= 78 endnodes= 58 endobj= 5671 depth= 4 maxpernode=251 min=( 4096.0, 4096.0)

    121.45-tmterrain_hmaps: height maps: num=5553 wgc=4096 ims=64 levelminmax=7/10

    121.46-tmterrain: terrain memory: (colormaps 213 MB) (heightmaps ca. 456 MB)

  • I installed today my brand new oculus rift and aerofly fs2 did not start in vr mode. In the oculus app i found in the settings the top menu point which must be on englisch something like 'allow other sources' and then it worked. I have the menu in german.

    Best regards,

    Thomas

    Best regards,

    Thomas


    i7-6700K @ 4.0 GHz, Geforce GTX 1080, 32MB RAM, 500 GB SSD, 1 TB SSD, 1TB HD, 32" Monitor 4K, Oculus Rift

  • I would recommend uninstalling Oculus software. There seems to be a problem with your Oculus software or how you have something configured on your PC.


    I'm assuming that you are using the Oculus Rift CV1 correct?

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Yes. (And btw, the unknown sources recommended in the support doc is set to allow. And has been from the start. Otherwise probably universe Sandbox wouldn’t have worked.)


    This used to work. Unfortunately I can pinpoint the date it stopped. Sometime in the last month.


    I hate to do an un/reinstall - you know that rarely works - it’s usually the last resort. There’s no oculus side log that might give some idea of why fs2 fails but universe Sandbox works??

  • There is nothing in Aerofly that's causing this unless your files got corrupt somehow when updating. If you perform the Steam file integrity check this would resolve that if it were the case.

    This is also an isolated incident since no one else is having problems, that alone validates that this problem is not something within Aerofly.


    Unfortunately you will have to troubleshoot on the Oculus side.


    Your TM log isn't telling the whole story here.


    Just a rundown of troubleshooting tips:

    > make sure that you have the latest GPU drivers running and have them set to default

    > check the file integrity to make sure your files are correct and not corrupt.

    > make sure that your Aerofly folder has the proper securities

    > unplug ALL USB devices and try to run Aerofly

    > delete the 'main.mcf' file and try to run Aerofly

    > if using Steam VR mode, make sure that your Steam VR is updated and running properly

    > make sure that you don't have any parameters set in your run options

    > try to run Aerofly in 2D mode. Does it run?

    > Make sure that you are not using the Oculus debug tool along with Aerofly

    > Make sure your antivirus application isn't blocking Aerofly

    > verify that you have the latest Aerofly version running. It should be 2.0.7.39

    > verify that Oculus Rift is set up and running properly


    After verifying all of the above steps. There isn't too much more that we could do for you here.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff