Trouble with Cultivation (.toc) Files

  • Hi,


    I'm having trouble with use of cultivation file .toc, I don't understand why it don't work in my scenery... someone have an idea where i'm wrong ?


    for information I try to generate cultivation .toc file containing only tree...


    here are some part of my files:


    end of my .tsc file:


    part of my generated with scenproc .toc file:


    here a snapshot in QGIS of tree to convert.... I try to split the toc files area into 0.25*0.25 or 0.15*0.15 or 0.05*0.05 degree.... with no results into AFS2 :( may be too much tree for the ascii toc file?

    [Blocked Image: http://i66.tinypic.com/dynimu.jpg]

  • Hi vogel69,

    Please confirm you have a folder in: Documents\Aerofly FS 2\addons\scenery\places\yourfolder containing the following:

    1. building_textures folder,

    2. runway.tmb file,

    3. a .tsc file (correctly named)

    4. your .toc file.


    Cheers,

    Paul

    Windows 10 64bit | iCore7-7770K| ASUS STRIX Z270E |KHX2400C15D4 - 32GB | Gigabyte Ge-Force GTX 1080Ti| SSD Intel 520 Series | 40" Philips BDM4065UC/75 4K - Oculus Rift

  • Hi Gooseno1,


    thank you for your help :-)


    So my last tests:

    - first I have tested with "element[0]" for each .toc file declaration in .tsc file => no change (no autogen vegetation / building/etc)

    - I have tested with a new .osm on a smaller area => not best


    about your last question:

    1 - no "building_textures" folder

    2 - no runway.tmb file

    3 - yes: LFLY.tsc

    4 - yes, my .toc files.


    my addon scenery folder look like that:


    -> places/

    -> LFLY/

    -> LFLY.tsc

    -> RA_Zone_Test_N4515_E00430_N4530_E00445.toc

    -> RA_Zone_Test_N4515_E00445_N4530_E00500.toc

    -> RA_Zone_Test_N4530_E00430_N4545_E00445.toc

    ... and all other .toc files


    -> Images/

    -> France/

    -> ... all images files converted with geoconvert from the area



    In game, I can see my airport: LFLY on the map and start from it. I can see aerial photo on the ground. I can't see any autogen on the area :(


    now thinking about create a new .tsc file from scratch, may be there is other mistake in it !?


    many thanks again Gooseno1

  • well with your good advice and help of link upper, I succeed in adding cultivation on my scenery.


    For informations:

    - the "building_textures" was missing I add it and I rewrite my .tsc file with file from AC3D Airport Design Package and Tutorial. As I see, cultivation don't work if there is no object declared in "list_tmsimulator_scenery_object" in ths .tsc file ! So I copy a .tmb file from same source, rename it: "runway_fake.tmb" and update the link in .tsc file.



    Many thanks for your help Paul ! and Rodeo for your Airport design Package ;)


    a quick screenshot... there are only tree at that time :-)

    [Blocked Image: https://tof.cx/images/2018/02/02/e79738251bf153ec598e675213104106.md.jpg]