Diffuse reflecting planar surfaces

  • Dear IPACS team,


    I ask again my question here, since not answered yet.

    The "hack" with "no__shadow" and "no__collision" works well.


    Is there also a "hack" to prevent grass planar surfaces from shining/straight reflecting the sun light? The idea is to get a rather uniformly light grass surface whatever their orientation (diffuse lightning).


    The picture below illustrates how light "straight" reflection underlines the planar surfaces.



    Orbx obviously have their grass planar surfaces uniformly lighted (diffuse), and not directly reflecting the sun (the aircraft shadow doesn't also interact with their grass). Planar surfaces are too sparse in this example to actually foul the eye, but zones with dense intricate planar surfaces really do the trick.


    Thanks in advance

    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • Dear IPACS team, any answer to my question please?

    Thanks in advance


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • More than diffuse, what is actually needed is an uniform, omnidirectional lightning, independent from surface orientation VS sun position. I did some testing with various specular textures, but to no avail, I assume there's something different.


    Looking at Orbx grass panes, they seem to get the same amount of light whatever the planar surface orientation relative to the sun. What is the "hack" in AFS2 to get this ?


    Thanks in advance.

    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • Thanks Larrylynx, I could give it a try...


    Instead of blind trial and error, I wish someone at IPACS replies to the question. Let's ask again...


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • To achieve this, the object type of this geometry inside the TSC file needs to be 'object_transparent_atc'. So export the gras objects to their own TGI file and inside the TSC reference this special geometry and give it the typename 'object_transparent_atc'. Have a look at LOWI TSC for example:


    Code
    <[tmsimulator_scenery_object][element][0]
    <[string8][geometry][innsbruck_vegetation]>
    <[string8][type][YOUR_GRAS_OBJECT_NAME]>
    ...
  • ok, thanks ! I'll give it a try.

    There's no way one could find it out by themselves. I've been struggling for 3 weeks now with this grass.

    Too bad things are not better documented...


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • It works, thank you ! Now I could eventually set patches of 3D grass.

    Not that it looks nice yet, colors must be adapted, but at least it is now technically feasible.


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

    Edited once, last by Trespassers ().

  • Hi,


    sorry for picking up this old thread, but I don't get exactlly this problem solved.


    To achieve this, the object type of this geometry inside the TSC file needs to be 'object_transparent_atc'. So export the gras objects to their own TGI file and inside the TSC reference this special geometry and give it the typename 'object_transparent_atc'. Have a look at LOWI TSC for example:


    Code
    <[tmsimulator_scenery_object][element][0]
    <[string8][geometry][innsbruck_vegetation]>
    <[string8][type][YOUR_GRAS_OBJECT_NAME]>
    ...


    With "object_transparent_atc" I get the drawing order right, but it doesn't have any influence on the brightness. I have tried __noambient, etc., without luck


    From what I understand I have now

    Code
    <[tmsimulator_scenery_object][element][0]
    <[string8][type][object_transparent_atc]>
    <[string8][geometry][mulben_pflanzen]>
    <[tmvector3d][position][9.103917 49.455730 0]>
    >


    Could somebody please tell me how to get rid of the shine/reflection?


    Thanks!


    Cheers,

    Kai

  • Okay, I think, i got it figured out. There is in FSX/P3D an option to tag a material so that it's not influenced by the direct light and it's normally used for vegetation. That's what I was after.


    It's a little project what I converted from P3D. In general the textures need to be darker for FS2. After applying an adjustment mask and playing a bit with the alpha channel, I got what I wanted.



    Cheers,

    Kai