joystick disappeared

  • It happened virtually from one day (yesterday) to the other (today): my joystick devices aren't recognized anymore. Instead of the three icons in settings/controllers I have the message "Bitte einen Joystick anschliessen...". Win10 shows the joysticks as fully working devices, other games (Il-2, War Thunder) function as usual. Tried reboots, of course, changing the USB ports, too...
    I'm a bit reluctant to using the "reset" button on top of the page, but maybe that would help.:/ Can I backup my joystick configuration? (I use it thru Steam)

  • Check power management, 'allow computer to turn off this device to save power' in usb settings.

    Later, I'd selected a power setting in my nvidea control panel. I turned it off and got my joysticks back, it had disabled the usb sockets to save power!

    Edited once, last by Overloaded: i'm fixed now (May 5, 2018 at 4:56 AM).

  • I had a similar problem. For me, it was solved by opening Steam > Settings > Controller > General Controller Settings > Uncheck "Generic Gamepad Configuration Support".

    I have to turn that setting on for other games to work with other controllers, but must turn it off to use my T.16000M in Aerofly FS2. Very annoying. Devs, is there a bug logged for this?

  • I had the same issue yesterday: no joystick recognized, this includes two different Logitech devices.

    The problem arose on 4.5.2018 11:00 UTC.

    It took me more then 2 hours to find a solution.

    It was steam related, but did not affect FSX steam, only AFS2.

    What helped for me was:

    1. Deactivate the steam beta program

    2: Switch to big mode (controller symbol)

    and press

    3. then "switch off Controller"

    - leave Big Picture mode.

    It is also importanat to check if "Generic Gamepad Configuration is unchecked, as jinx099 wrote, but this was not the case in my situation.

    So I think it is a problem which affects the combination of steam and AFS2 (but not other steam games) and IPACS should have a look into the cause.

    Cheers, Thomas

  • Thanks for all the help! In today's Steam update I spotted this fix:


    Fixed Direct Input controllers not appearing to games in the last Steam Client Beta.

    Everything works as before now, I see all controllers with their icon.
    You learn every day. In fact, I hadn't launched neither WT nor IL-2 on Steam.