Mouse pointer gone

  • I have mouse pointer every where on all computer games except in this game active flight screen. No problem in setting screen just disapers when switching to active screen I Have tried all forums to no avail, verified files tried 3 other mice etc: left or right click holds for panning just no pointer! Any help prior to reinstalling game would be appreciated.

    Aerofly FS 2

    Win 10 geforce GTX1070

  • We will need more info to be able to pinpoint this issue.

    What graphics card drivers do you have installed?

    Are you playing on a normal 2D monitor or are you using a virtual reality headset?

    If you use a monitor: what screen resolution did you select in the graphics settings?

  • Hi Jan,

    Thank you for your quick reply, info which I hope is sufficient.


    Driver: Forceware 396.36


    I have 3 monitor setup all same size running 5760x1080 using nvidia surround spanning all 3


    Also have tried just 1 monitor 1920x1080


    Selecting same resolution in your graphics settings on all setup.


    I have played Aerofly with out this problem in the past just dont rembember when!


    Cheers,

  • When you don't use the mouse for 5 seconds it will disappear (this is for users that don't use the mouse control and was added when the VR Hands were released), but it will reappear when you move the mouse once again. This is how it's set up. Can you verify that this is the case with you or are you never seeing the mouse pointer at all?

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Hi Jeff,


    Only have mouse pointer on startup and settings page which lets me chose plane etc. then disappears after starting flight so no input with clickable area in sim!


    Thanks for your interest.

  • Hi,

    OK decided to delete main.mcf and problem fixed ..... looks like that is the magic bullet to fix a lot of problems !

    I can now spend some time flying this sim.

    Thank you for your input guys.

    Cheers

  • I'm glad that you got it working again.

    Yes, the main.mcf file drives the setup configuration of Aerofly so it's a core file.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Jeff,

    It seems apparent the restoration of a clean main.mcf file is a reliable solution for a number of graphical issues. I wonder if consideration might be given to incorporating some automated means, from within Aerofly, to click a tab to "reset/rebuild main.mcf" or something of the sort. Not that it is hard to find the file and do it manually but it may be a convenience of help for many users and a way for folks to self troubleshoot. Just a suggestion to consider. One of the things I enjoy most about Aerofly is trouble free operation and no config tweaks.

  • That's not a bad idea actually, but like you said, it's fairly easy to find and delete. It's also a part of our support troubleshooting as there's many times that we inform the user to delete the main.mcf file.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Just another thing from my side I have the steam version and only having 20 hours flight time that was why I first posted on the steam forum prior to finding the ipacs site which is by far the site for tech info :)

  • Just another thing from my side I have the steam version and only having 20 hours flight time that was why I first posted on the steam forum prior to finding the ipacs site which is by far the site for tech info :)

    I was responding to you with the same problem on both forums, I simply told you to only post here since responses have already begun.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Hi everybody


    Well, in general it helps to delete the main.mcf. But then I tried to install the triple-monitor-view according to the Aerofly FS 2 Wiki. So I had to modify the main.mcf accordingly. The 180° view is now perfect, but the mouse pointer has disappeared again. Any idea how to get it back? Help ist most appreciated.


    Best regards

    Urs

  • Some additional remarks:


    Map (M) and flight information bar (I) do not show up, meanwhile location names (L) can be switched on and off. View direction can be varied with mouse, but not zoomed by the mouse wheel.


    Removing the triplemonitor definition from main.mcf brings the pointer and missing functions back, so it is not a question of saving perhaps in a wrong format.