Strange rudder/autopilot behaviour

  • Hi,

    everytime I disengage the autopilot in the Baron 58, the left rudder is automatically fully pressed for a second or so.

    At first I first suspected it is just an issue with my controller assignment but I double checked and the rudder is only assigned to my usb pedals, to nothing else.
    The issue also occurs when I disengage the autopilot in the VR cockpit directly, with my oculus touch hand, without pressing any real world buttons at all.


    Is this a known bug and is there a fix for this? Any tipps or ideas?

    In the meantime I have adapted by compensating with the right rudder everytime I disengage AP, but the plane is still jumping around a bit and I can't imagine this being intentional.

  • Thanks for checking.

    I fly in VR with a Cessna yoke and trimwheel from Saitek and the pedals of a Logitech DFP racing wheel as rudder pedals. I have installed vJoy and UJR to make this work.

    Button 1 of my yoke is assigned to autopilot "master", and pressing it engages and disengages the autopilot as expected. Except when the autopilot disengages, additionally the rudder moves to the left for about a second, and then returns to normal position. I have tried this in parking, it happens everytime.

    The other way I have disengaged the autopilot is by reaching forward with my oculus touch controller and touching the "AP" button on the virtual panel in the cockpit. To my surprise this also makes the rudder move to the left for a second. This led me to believe that it might not be just a controller assignment issue, because I'm not using any peripheral input except for oculus touch to replicate the issue. But I don't know how FS2 works exactly, so I might be wrong.

    There are for sure some unexpected things going on with the controller setup when you change assignments without deleting them first. For example when I first installed my rudder pedals they would also increase and decrease throttle despite this was definitely not shown in the configuration. I could fix that problem by deleting all assignments for throttle and reassigning them.
    It turned out that the original assignments were still working additionally even after I had remapped the axes that controlled throttle and rudder. After deleting my assignment for throttle, instead of being unassigned, it showed the previous assignment which just happened to be the axis of my rudder pedals.

    So far I had no luck with a similar approach for the rudder/AP situation, but maybe just resetting them to default will help. I'll try that next time before I fly.

  • Ok, after a restart I made a few tests, and I was hopefully able to resolve the problem now.

    Here is what happened:

    Starting up my PC and a fresh game in the baron, the issue does NOT occur at all.

    After taxing around for a minute, the issue occurs again.

    Engaging and disengaging the yaw damper when the autopilot is off does not reproduce the issue.

    The issue is persistent when switching to a Cessna 172. I didn't fly the Cessna with autopilit before so I hadn't noticed.

    I restarted the game and the issue was gone. After pushing my rudder pedal once, it was instantly back again.

    It seems input from my rudder pedals triggers the issue.

    There is nothing coming from the usb pedals themselves during the moment when the issue occurs though. My pedals initially send data on axes 3 and 4 (joystick ID 3) , and I have remapped them with UJM so that the game recognises them as a single x-axis of a virtual joystick (vJoy).

    In order to make FS2 recognize that the input is coming from vJoy and not the race pedal, I had to deactivate the racing wheel in the FS2 settings menu during the asssignment. I later reactivated the racing wheel controller, so I could use the shifting gear from the wheel as landing gear knob. (I know I'm a cheapskate with this lol)

    The next thing I tried is remapping the USP pedal input to axis Z of vJoy. And for the assignment in FS2 I really made sure this time the rudder assignment is properly deleted before assigning it again, to vJoy axis Z. I checked in the baron, and the strange rudder issue with the autopilot was gone, even after using my newly assigned rudder pedals during taxiing.

    Phew, that was tricky, lets hope it stays that way now :)

    I guess FS2 really needs to make sure old axis assignments are properly deleted when the user makes a custom assignment. It might also be possible that there is just something wrong when using vJoy axis X instead of Z. And I still don't understand how the rudder could triggered just from using oculus touch to deactivate AP, but oh well...

    • Official Post

    After I experienced the same bug in all of our aircraft I dug deeper and eventually located the issue. When I have two axes and deflect my secondary axis (twist handle) then after disconnecting the autopilot the rudder would fade from 0 to the secondary axis for a period of one second but then quickly change back to the first axis (rudder pedals).

    This is only noticeable when the there are two axes assigned for the rudder or aileron and the secondary axis is not centered at zero and the autopilot is disengaged.

    Anyway, I've found the bug, found a solution and hope that my fix solves it for good!

    Thank you perestain for bringing this to our attention.

  • Yes, that's exactly what was happening back then, a slow rudder increase to the left for one second and then a sudden return to the middle. It hasn't occured since to me but it's nice to hear you found and resolved it. It made some approaches a little more exciting than necessary, hehe :)