Problem with rudder controls in Aerofly 2

  • I have a problem with my hardware rudder controls in combination with Aerofly 2.


    I use the VKB T-Rudder Mk II as hardware rudder/tailrotor controls. I have been flying the R22 in Aerofly 2 without any problems when it just came out. Haven't flown for a few weeks, and all of a sudden the last time I fired up the sim I have a problem where the ruddercontrol has a sudden offset to the right, which makes flying impossible.

    While my hardware pedals are in a neutral position; in the sim there is about a 50% right pedal input.


    I have recalibrated my controls in windows; and I don't have this problem in other sims (I mainly fly X-plane and DCS).

    In aerofly I have reconfigured and calibrated all controls too, but the problem persists.


    Does anyone have a good idea?


    Thanks,


    AJ

  • Have you tried deleting the gc-map.mcf file located in your documents\Aerofly FS2 root folder? This will reset your calibrations and possible resolve your problem.

    You will need to reconfigure your controllers once you do this so I recommend to just move that file to your desktop (or anywhere outside of the Aerofly folders) that way if this doesn't fix your problem you can move it back into the folder.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Thanks for your quick reply Jeff,


    I tried it right away, but unfortunately it did not fix my problem.

    I just assigned the rudder axis to my old joystick (CH fighterstick), and the problem is gone.

    Is it possible there is a compatibility problem with the VKB-T-Rudder?

  • I just assigned the rudder axis to my old joystick (CH fighterstick), and the problem is gone.

    Is it possible there is a compatibility problem with the VKB-T-Rudder?

    It's possible there is a compatibility issue with your rudder as I don't believe that any of us have that specific controller to even test it. I will look more into it for you though

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • I do have the very similar pedals, MkIV, (the smoothest and most precise pedals I've ever had) and I did encounter e.g. a thrust reverser problem due to the pedals additional axis and buttons.

    While these additional axis where definitely not assigned, I had to select the 'remove all assignments' and then re-assign only the rudder axis in the controls menu to get the VKB pedals to work correctly.

  • Thanks for the replies so far; FL54 I already tried that, and like drhotwing1 already suggested: i also deleted the entire controls setup file and re-assigned all controls from start.

    The frustrating bit is that this problem was not there a month ago; my pedals were working perfectly. Also in other sims I don not have this problem.