can not change video resolution

  • I can not change the video resolution ... with RC 7 with a gtx 1080 Ti I never had problems but with rc8 it is impossible to change .. I also contacted the Ikarus support but they did not give me a solution to the problem .... we hope a patch will come out

  • I've a GTX 1060, I do not have any problems

    I change the résolution in settings / graphic settings menu at the fist screen of the simulator.


    RC Flight Simulator Ikarus :
    - EasyFly 4 full version | AeroFLy 5.7 | AeroFly RC7 | AeroFly RC8
    Radios :
    - Graupner MC-18 | Easy Commander | Jeti DC14
    Computer :
    - Windows 10 64bits | iCore7 860 | DDR3 8go | EVGA GTX 1060 nvidia | SSD M500 240go | DD 500go + 2To | 27" Samsung 2K 2560*1440 Or 55" SmartTV Samsung 55ES6540 Full HD 1980*1080
    Web Site : Textures for Aerofly
    Videos: https://www.youtube.com/user/MrJpriton/

  • With rc8 I only get the 2x settings options; 1920x1080 and Windowed. If I have selected 1929x1080 in non-VR mode this setting sticks when I restart it later. However when I startup in VR mode (w/oculus rift) it always starts up in windowed mode and I then need to go back to the main menu and re-select 1920x1080 in order to get a fullscreen mirrored view on my monitor and also be able to see full menus in VR. No real big deal for me. Overall I am really enjoying rc8 in VR.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • Similar problem here (Gfx card is an Nvidia RTX2080 and native screen resolution is 2560x1440):

    I can't seem to use any (!) fullscreen resolution. Whatever resolution I select, the screen resolution actually used seems to be much lower than the screen buffer, so I can only see a part of the actual screen area and the right and lower side of the screen are cut off. E.g. I can't even see how to exit the program since only like two and a half main menu entries are visible. Also the start button is almost fully outside the screen. This makes it impossible to change the resolution with the mouse (since the right arrow is invisible) and I have to use the keyboard instead.

    When I sometimes (!) still succeed to set a resolution, it's lost as soon as I exit/restart. Then I'm either back to windowed mode or have that weird distorted/cut off view in a wrong resolution. I tried any available resolution but all behave erratic. This even happens in 1024x768.

    -> I can actually only use RC8 in windowed mode.


    Note that RC7 works fine in 2560x1440 fullscreen mode. It shows the same issue in the initial loading screen though.


    Hard to understand how to mess this up this bad. RC8 looks 99% like RC7 anyway in every aspect and they still managed to screw up something as basic as the resolution selection that any freeware game got right in the last twenty years.

  • Please double check here: Is your Font scaling in Windows 10 settings something else than 100%? If yes, also check the contents of the 'tm.log' file if Aerofly RC 8 is running in windows compatibility mode. If that is the case, fullscreen modes don't work properly as Aerofly RC 8 gets wrong information from Windows 10.


    We are still investigating why Windows 10 is running Aerofly RC 8 in compatibility mode. For now, you can fix this by right clicking on the aerofly_rc_8.exe and then choose 'Properties'. Then choose 'Compatibility' and make sure Compatibility mode is disabled.

  • I solved this way: deleted the folder aerofly rc8 in documents,,, I restarted the game and I redid the activation ... now you can change the resolution

    I did this (support suggest I do it a couple of days ago) but in VR mode it always starts in windowed mode. I still can change this to 1920x1080 though but it does not stick. It does stick ok in non-vr mode though.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • Yes, only in VR. My tm log file still shows this app trying to use win8 compatibility mode. My rc8 exe properties does not have compatibility mode checked, it never has. I still need to follow a pretty restrictive procedure to get it to start in VR with my Oculus Rift. Please refer to my earlier thread on this.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • @TomC RLG: We have fixed it internally now, that if you have 'Render native view on screen' set, you can see the VR view in the glasses and the normal view on the screen. But you have to explicitly activate this option. We turned it off by default as it has a huge impact on performance in 4D sceneries.

    As for your other issue, please post the thread or describe in detail what's wrong.

  • I'm using a 125% scaling in Win10 as otherwise all the text etc. in every application is much too small.

    And while the Win8 compatibility is not active, this was actually a good hint.


    There is a setting in the compatibility tab (when right clicking on the exe) which allows to force the high DPI setting to be controlled by the application.

    It seems like when I enable this option (i.e. let the application override the high DPI setting), RC8 lets me select my native fullscreen resolution successfully.


    Still, this is weird. I would think there should be some DirectX (or whatever it's called nowadays) interface to get the raw resolution and not the fake one that application get through the default Windows API interfaces.

  • RC8 is explicitly designed for Windows 10 and should also run slightly better on Windows 10 due to the enhancements Microsoft has added to it. Again, we are trying to find a cause for the problem why Windows is running Aerofly in compatibility mode. It runs just fine on most customers machines, so please be patient a little more until we have found a fix for this.

  • It is not running in compatibility mode for me. It's obviously just confused by the high DPI setting. Then again, as this isn't an issue for any other game or fullscreen application on this planet, the Aerofly developers must obviously call the wrong interfaces to get the actual screen resolution.