Oculus Rift VR Startup Procedure

  • For now, the only way I can start up rc8 in VR with my Oculus Rift is to follow this procedure;


    - restart PC

    - start up Oculus desktop app without wearing goggles and when it opens, minimise it

    - start up rc8 (VR mode shortcut)

    - place headset on normally

    - wait for rc8 to load and start up

    - hit space bar to centre view and change settings and/or start flying


    The only setting I need to change every time is the graphics to 1920x1080 because it always defaults to Windowed and the problem is that if you want to change or modify aircraft you cannot see the whole menu in VR unless you are in full screen. Also I find it best to use the full screen view as opposed to the split screen view so you can sneak a peek at model modes and fps while you are flying in VR.


    If I try to start up rc8 in VR mode any other way, including if I have previously run other apps in the Oculus Home, the program crashes. so, if I have been using Oculus Home for other apps I seem to need to restart my PC (win10 1809 btw) and then follow the procedure I listed above. After I exit rc8 everything else works fine in Oculus Home and/or with steam or independent apps. A bit of a pain to do this every time but at least it works. Hopefully this will get sorted out in the near future. They probably need to work with Oculus to check that everything is compliant with current Oculus updates.


    Anyway, I hope this helps some of my fellow Oculus Rift VR flyers. Overall, I am really enjoying rc8 in VR.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • Yes, I get the same message in my tm log. The app appears to be running in win8 compatibility mode although it recognizes I have win10 installed.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • Today's small update did not change anything VR for me. I still need to follow this restrictive VR startup with my Rift or the program crashes. Still, when I do get it going in VR it's fantastic! Here's my latest log file if this helps. I've already sent this before to support but they have not got back to me with anything constructive yet.

    tm.log

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • TomC RLG : We first need to find out how to disable to compatibility mode in your case. Can you please try the following methods to disable the mode for aerofly RC 8:


    https://www.tenforums.com/tuto…gs-apps-windows-10-a.html


    You might want to check option three here. Somewhere in your Windows 10 settings is the option that aerofly RC 8 is supposed to run in Windows 8 mode. No idea why this is the case on your computer but please try some of the methods mentioned there.

  • OK, I tried all that but it does not seem to make any difference. I still get the same error message in my tm.log file that says rc8 is trying to run in win8 compatibility mode. This is the only game/app that has ever done this. tm.log

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • Here is another tm.log file to show what happens when I try to startup RC8 form my Oculus Home either from Oculus Home Desktop or Home Apps. Basically RC8 starts to load up ok then crashes. I then need to restart my PC and go through my 1st post's procedure to get RC8 to run in VR with my Oculus Rift. I don't know if this tm.log file will tell you anything but I thought I would include it anyway. You will see that it is still trying to run RC8 in Win8 compatibility mode.

    tm.log

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • Update 26/01/2019


    OK, the latest Aerofly RC8 8,00.07.01 update is now out there. Please check your update tab on your RC8 start up window, go to the webpage, and run the update.


    My Oculus Rift now starts up in VR perfectly by just opening the RC8 VR shortcut, letting it open the Oculus app, putting on your headset, then hitting the space bar to centre the VR view. It now recognises RC8 as Win10, not win8. Also, it now seems to remember my full screen option (1920x1080) and screen option showing non-native as opposed to split screen. Thanks RC8 dev guys! This is a great VR RC sim for sure imho.


    The only things I think worth mentioning is that if you have already used your Oculus Rift on another VR app (esp. with touch controllers) then you may need to exit the Oculus PC app and either go to your task manager/services and stop/start Ovr runtime services and/or restart your PC. No real big deal but it would be nice if you could start up RC8 from the Oculus Home 2.0 App pane like other non-Oculus apps. If you try to do this it will crash.


    The only other Oculus Rift tip I can give you for now to slightly improve RC8 performance is to disable the Oculus ASW. You can do this by simply hitting the ctrl+num1 keys while you pause (P) RC8. This is the numeric 1, not the top row 1 btw. Really does not make a lot of diff imho.


    I have played with an number of different Graphics options and your results may vary depending on your hardware. I have found that Graphics quality medium, changed vr scale (SS?) to 1.5, then changed to custom shadows to ultimate work best for me with my Oculus Rift in VR.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.