No VR hands appearing at all even at startup menu

  • I am brand new to Aerofly FS 2 and am trying it for the first time. I can run it in VR mode (either launching from Oculus with the -othervr option or from a desktop shortcut with the -othervr command line option).

    In Oculus Home, my left and right touch controllers are working fine, but in Aerofly, they haven't shown up at all yet, even in the startup menu. I've searched the forums and the 'net for suggestions, but haven't found anything. I DO have the "show virtual hands" option turned ON in settings.

    Thanks in advance!

  • Do you have any other controllers plugged into your USB ports? If so, unplug them and try this again. Do you now see the VR Hands?

    Also, are you using any other applications like Oculus tray tool? If so, please turn these off.


    Make sure that you have the latest video card drivers installed and it wouldn't hurt attaching your tm log to this thread so that we can take a look. You can find your tm log in your documents\Aerofly FS 2 root folder.


    This is definitely something on your side but we will figure it out.


    I did notice one thing in your post, you said you have the 'show virtual hands' turned on, we took that out of Aerofly and it now recognizes your controllers automatically. Are you using the Steam version or another? Make sure that you have the latest version of Aerofly here as well.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Hi Jeff, thanks for the reply!


    I unplugged my Saitek Pro Flight system (USB). The only other things I have on USB is an ext hard drive and wireless keyboard/mouse dongle. Still no luck.


    I checked in Task Manager for any Oculus apps that are running - there are no Oculus apps running, but I do have the following Oculus background services running:

    OVR Service Launcher

    OVRRedir.exe

    OVRServer_x64.exe


    One thing; when I launch the Windows shortcut (""C:\Users\walke\Desktop\Aerofly FS 2 Flight Simulator\bin64\aerofly_fs_2.exe" -othervr), the Oculusclient.exe runs automatically (3 instances).


    I do keep my graphics drivers (NVidia GeForce 1080) up to date regularly.


    By "Show virtual hands" I meant the option inside the VR settings menu itself that says "Show hand controllers during simulation."


    I am using the direct digital download version of Aerofly FS 2 that I purchased from Aerosoft.com several days ago. It is version 2.0.5 (20171102), purchased about 1 week ago.


    Here's my TM.log file:

    tm.log


    Thanks for the help!

  • Ah, there is your problem. You need to update your version of Aerofly.


    Here is the LINK


    Your version is very old. You should be at 2.4.3.15


    Perform the latest update and let me know if it's working.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Hi Jeff! Perfect, I now have hands - thank you! I looked for updates the other day, but I just didn't scroll down the Support page far enough... I just flew a pattern and all seems great - I need to study up a bit to figure out how to operate the C172 flaps with the VR controller - I had to land pretty hot =O

  • Make sure that you visit our WIKI to get a better understanding. Once you realize the gestures you will have a ball with it.

    Also, now that you have the latest version, be sure to check out the new R22 helicopter :)


    Also, since you are new to this and I see that you have the GTX 1080, you can crank up the graphics and VR (RSF) a bit if you haven't done so yet to get the most out of Aerofly.

    1) you can set your graphics settings to ULTRA with no problem at all

    2) you can set the 'Render Scale Factor' setting under Virtual Reality settings to 1.50 at least with no problems

    3) be sure to try our Vulkan mode with high altialiasing , it should be smoother for you

    4) our clouds system is not truly optimized for Aerofly at the present time, if you lower the clouds density a bit Aerofly will perform much better. We will work on weather down the road more.


    Be sure to ask questions on this forum if you need anything further, there are a lot of good people on here to help, as well as us (IPACS) directly.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff