AC3D Model does not use normal maps

  • Hello IPACs team,


    I pulling my hair trying to make my normal map work on my model with no solution for several days now.

    In AC3D, my material setting is like this


    My fuselage00_bump is exported correctly and renamed as fuselage00_normal in the aircraft folder, but nothing is bumped in the sim.

    All other materials (ambient, specular and reflection) work as intended.

    So what am I doing wrong or what is missing in my material data for the exporter to take in account my normal map? I'm lost.

    I have also tried to add : "<[uvscaling][normal][55]>" as I've seen this in the DR400 example with no luck.


    I use AC3D V8.0.8 and aircraft converter version 1.2.5 Aug 21 2018 Build 1581


    A little help would be greatly appreciated.

  • It is even not required to declare bump map in a3cd. It should work if bump map exists and map is correct. Is the map correct? Maybe you have normal map , but not bump map - they are different (you can use fuselage00_normal.bmp instead of fuselage00_bump.bmp)


    Please check if you have in model.tmc bump scaling set correctly, ie:

    <[file][][]

    <[convert_model_settings][][]

    <[float64][BumpMapScaling][1.0]>


    'uvscaling' is not required, it changes bump map size but not depth.

  • Thanks for your quick reply.

    Yes, my map is correct: I copied it to another aircraft and if works.

    I also tried to copy a working map from another aircraft to my model and it does not work. That's why I believe there is a problem with my model.


    Checked my model.tmc: BumpMapScaling is set to 1


    Do I need to specify the files in the Files list below?

    Code
    1. <[convert_texture_settings][element][4]
    2. <[int32][MaxTextureSize][4096]>
    3. <[float64][BumpMapScaling][1.0]>
    4. <[list_string8][Files][
    5. ]>
  • Hi Jan,

    It is set to 1 everywhere. Is that not correct?

    Code
    1. <[float64][BumpMapScaling][1]>


    Code
    1. <[convert_texture_settings][element][4]
    2. <[int32][MaxTextureSize][4096]>
    3. <[float64][BumpMapScaling][1.0]>
    4. <[list_string8][Files][
    5. ]>
    6. >
  • It's a 24bit bmp file. It looks like this.



    I don't think the image is the problem because when I copy it in another aircraft it works.

    I also tried to copy the default C172 "fuselage00_normal" in my aircraft folder ans it does not work. I'm pretty sure it's my model or an importer option that is not correct.

  • Hi Sylvain


    I'll be upfront here, I'm not a AC3D user...In the first post I do not see where you input a normal map. I see Diffuse, Ambient, etc but no bump/normal.


    Steve


    Edit... Is it possible to perform a render of your model from within AC3D , this would prove the bump is being applied and it then becomes a problem from FS2 conversion

  • Hi Sylvain


    Yep I noticed the dialog, do you have to write this in manual or is there a + box similar to diffuse...Also the name is ext01, don't see fuselage00.


    I would guess the model converter is looking for ext01 and not fuselage00. As I said. not a AC3D user so may be talking through my rear end


    Steve

  • Just out of curiosity... did you assign a bump map to the normal map channel?

    No, a normal map is defined in AC3D. Then I created a bump map (gray scale height map) and converted it to normal map.

    I think I read in the wiki that the exporter should transform bump maps to normal maps but for some reason it does not work at least with AC3D.