Selbst erstellte Modell-Konfigurationen funktionieren nicht mehr richtig

  • Hi,


    ich habe ein paar Modelle vor ein paar Monaten mit größeren Ausschlägen versehen oder habe den übertrieben kurzlebigen Smoke langanhaltender gemacht. Nach der Auswahl einer solchen selbst erstellten Konfiguration wird das Modell bei ca. -400m unter der Erde aufgestellt und fällt immer tiefer. Man schaut also nur auf den Boden und sieht kein Modell.


    Dann habe ich als Test eine komplett neue Konfiguration von der Edge 540t (Competition) gemacht, einfach nur die Heck-Ruderausschläge vergrößert und als neue Konfiguration gespeichert. Nun steht die Konfiguration nach dem Laden zwar auf dem Boden, aber der Propeller dreht in Zeitlupe, bis ich einmal Gas gegeben habe.


    Was stimmt da nicht? Wie bekomme ich meine mühsam gemachten Konfigurationen wieder in die normale Startposition?


    Aerofly Vers: 8.00.19.01

    Windows 10


    Viele Grüße

    Georg

  • Es gab eine signifikante Änderung an der Modellbeschreibungsdatei (tmc), um Aerofly für mehrere Sprachen kompatibel zu machen. Um deine alten Konfigurationen zu reparieren müsstest du die Dateien in den Verzeichnis korrigieren. Hierzu müssten alle .tmc Dateien deiner Konfigurationen auf den neuen Stand übertragen oder ersetzt werden.


    Die Modifikations-Dateien liegen in deinem Benutzerverzeichnis (Documente) im Ordner Aerofly RC 8 (o.Ä.) im Unterverzeichnis "aircraft_mod".

    Also z.b. Users\....\Aerofly RC 8\aircraft_mod\edge540t\edge540t__000.tmc


    1. Variante - Existierende tmc Dateien manuell reparieren. Dies Erfordert etwas Sorgfalt, ist aber durchaus noch machbar in überschaubarer Zeit

    1) Erstelle zunächst eine Sicherungskopie von dem aircraft_mod Ordner

    2) Mit einem Text-Editor kannst du deine tmc Dateien bearbeiten, dort muss die Dateistruktur auf das neue Format angepasst werden. Am besten öffnest du die .tmc von deiner neu erzeugten edge 540t competition und kopierst von dort aus die neuen Zeilen sinngemäß in die tmc Dateien deiner früheren mods.


    2. Variante - Pro Konfiguration eine neue tmc erzeugen, dann tmds überschreiben und Beschreibungen abgleichen.

    1) Erstelle zunächst eine Sicherungskopie von dem aircraft_mod Ordner und verschiebe den Ordner erstmal wo anders hin (raus aus dem Aerofly RC 8 Ordnerverzeichnis)

    2) Im Aerofly erzeuge jede Konfiguration neu, aber erstmal ohne wirkliche Änderungen vorzunehmen, Flugzeug laden, speichern unter anwählen

    3) überschreibe die neu erzeugten .tmd Dateien mit deinen ursprünglichen aus dem backup, aber nicht die tmc Dateien!

    4) jetzt sollten die Flieger wieder tun, es muss jetzt aber noch der Name vom Flugzeug und der Beschreibungstext für die Konfiguration neu angepasst werden, also:

    5.1) Entweder im Aerofly selbst Mod auswählen, gucken was da anders war, Namen neu ausdenken, über das Menü umbennen (ich meine das geht irgendwie)

    5.2) Oder manuell die tmc Dateien aus deinem Backup mit den neu erzeugten vergleichen und die Beschreibungstexte rüber kopieren (Wert des DescriptionText von jeder alten Datei in die neue übertragen)


    Wenn du es geschickt anstellst kannst du schon im Schritt 2 die Namen und die Beschreibung richtig festlegen und sparst dir Schritte 4) und 5), hier musst du nur aufpassen, dass die erste Konfiguration, die die am Ende die Datei __000.tmc erzeugt, auch den Namen von deiner ursprünglichen nummer 000 bekommt (und 001, etc. respektive)

  • Geog,

    wo hast du denn die Änderungen gemacht?

    Auch ich habe "smoke" geändert, an der Pilatus B4, auch die Reibung des Rumpfes ("friction").

    Aber so etwas mache ich nur an meiner eigenen Kopie in "Dokumente" und habe keinerlei Probleme.

    Gruss Jürgen

  • Danke Jan.


    Irgend etwas stimmt trotzdem nicht ganz. Ich hatte ja schon geschrieben, dass bei einer neu erstellten Edge 540t Konfiguration der Prop quasi still steht, bis man einmal Gas gegeben hat.


    Gerade habe ich meine Crack Fokker anpassen wollen. Ich habe also den Standard einfach unter einem neuen Namen gespeichert. Wird die neue Konfiguration (ohne irgendeine Änderung) geladen, zerschellt die Fokker sofort beim Aufsetzen (Szenerie Ayers Rock). Mit der Standard Konfiguration passiert das nicht.

  • Danke Jan.


    Irgend etwas stimmt trotzdem nicht ganz. Ich hatte ja schon geschrieben, dass bei einer neu erstellten Edge 540t Konfiguration der Prop quasi still steht, bis man einmal Gas gegeben hat.


    Gerade habe ich meine Crack Fokker anpassen wollen. Ich habe also den Standard einfach unter einem neuen Namen gespeichert. Wird die neue Konfiguration (ohne irgendeine Änderung) geladen, zerschellt die Fokker sofort beim Aufsetzen (Szenerie Ayers Rock). Mit der Standard Konfiguration passiert das nicht.

    Es kann sein, dass es intern einen Konflikt mit den Standardwerten gibt, z.B. dass nicht vorhandene Standardwerte beim Laden des Fliegers anders gesetzt sind als sie dem Abspeichern erzeugt werden...


    Kannst du uns eine genaue Abfolge schildern, wie wir das reproduzieren können? Muss man an der 540t z.b. irgendetwas geändert haben, damit dieses Problem auftritt?

  • Hi Jan,


    argh, ich kriege es jetzt selber nicht mehr bei der Edge 540t reproduziert.


    Aber eine neu erstellte Fokker zerspringt sofort nach dem Laden.

    1. Lade Szenerie Ayers Rock

    2. Lade Modell Crack Fokker (Standard)

    3. Modell speichern "Fokker Test"

    4. Modell laden "Fokker Test" --> Modell zerspringt in Einzelteile

  • Hallo Jan,


    ich habe hierzu eine interessante Ergänzung, damit ihr wieder einen Schritt weiter kommen könnt. ;-)


    4. Modell laden "Fokker Test"

    4 a. Ist als Steuergerät "InterLink Elite" ausgewählt, zerspringt das Modell sofort nach dem Laden.

    4 b. Ist als Steuergerät "Maus" eingestellt, sitzt das Modell unnatürlich tief im Boden, zerspringt aber nicht.


    Hier sind Screenshots von einer anderen Szene Eschenlohe. Nach dem Laden, - der nach den obigen Schritten erstellten Kopie und der Auswahl des Steuergeräts "Maus" -, sitzt das Modell recht tief im Boden und scheint größer dargestellt zu werden.


    Gruß

    Georg



  • Ich kann das Problem auf keine Art und Weise nachvollziehen.

    Hast du ev. die Grösse verändert? Das vertragen nicht alle Modelle.

    Mir fällt einzig das Hoheitszeichen auf. Da scheint etwas anders als bei mir zu sein?

    Oder habe ich die falsche Fokker gewählt?

    Gruss Jürgen

  • Hallo Jürgen,

    bitte nach Anleitung machen und die Crack Fokker auswählen. Das Modell wurde von mir nur neu gespeichert, ohne eine Änderung. Steht wie gesagt in meinen Steps. Dann brauchst Du evtl. noch eine Interlink Elite USB Funke, um den Fehler voll nachzustellen (Modell zerbricht dann bei mir).

    Gruß

    Georg

  • Es bleibt dabei. Keinerlei Probleme. Weder mit der Interface (IKARUS mit GR-16 Graupner Empfänger) noch in "Maus" -Mode (wer ums Himmelswillen steuert ein Modell mir der Maus?).

    Einzig auffallend ist dass das "geänderte" Modell als "crdr1" erscheint. Nicht wie alle anderen mit Namen.

    Gruss Jürgen