Oculus Rift-S does not work with RC8 in VR - With Workaround

  • I just got my nice new Oculus Rift-S today. It all setup fine and I am not having any problems with any games/apps except with RC8 in VR. It sometimes starts up but if I try to access the menu or re-centre the view RC8 crashes. Please see attached my last log file.


    tm.log


    Edit; I have found a temporary workaround. I need to take the batteries out of the Rift-S touch controllers then RC8 starts up and works fine in VR. This is a bit of a nuisance but it will have to do until there is a proper fix.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

    Edited once, last by TomC RLG: Found a temp workaround ().

  • Your welcome mate. The problem happens any time the touch controllers are either on or on standby. They need to be OFF or RC8 in VR crashes. This is also starting to be more of a problem with my original Rift cv1 as well because Oculus updates now have a very large delay before they go from standby to Off. The new Rift S goes into standby but never actually turns OFF until you shutdown your PC, disconnect your headset, and/or disable OculusRuntime services.


    RC8 is the only app I have that needs to have touch controllers OFF. Other apps that do not need the controllers (eg. RF8) are able to disregard them. Hopefully RC8 developers will be able to figure a way to do this as well in the near future.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • TomC RLG

    Changed the title of the thread from “Oculus Rift-S does not work with RC8 in VR” to “Oculus Rift-S does not work with RC8 in VR - With Workaround”.
  • Please give us some time to look into this issue. Aerofly FS 2 seems to run fine with the Rift S, so we need to check why Aerofly RC 8 has issues here. But this might require 2-3 weeks since we need to get a Rift S first.

  • Thanks. Pretty well the same problem with my original Rift cv1 if touch controllers are active or standby. I think if you can get rc8 to avoid crashing with them it may also solve it with Rift S. Anyway thanks again for looking into this.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • Ya, even with my Rift cv1 RC8 needs to be started before you have started up from the desktop shortcut before your Oculus App has been started up.

    Sometimes after you've used your Occulus app you can get around this by going into task manager services and turn off ovrservices, wait ~ 10 seconds then turn it on again. Then either exit your Oculus App and use the desktop shortcut and/or try starting it up with your Oculus Desktop App library.


    Like the Rift S, removing the touch controllers batteries also fixes this completely,


    BTW, you need to keep your headset off your face until you get the rc8 start up screen on your monitor, then put your headset on and press the space bar to centre your view. Works fine after that. A bit of a pita but worth it because RC8 is sooo good in VR!


    Hopefully this will get fixed in the near future.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.

  • Guys


    I have a new machine + Oculus Rift S. When I start, the game says its loading in VR but nothing happens. I can hear the aircraft sound in the headset but no video what so ever. I have removed batteries from hand controllers please help!!


    Mark.

  • With the latest RC8 update you should not need to remove your controller batteries.


    Best way to startup rc8 is to exit the Oculus desktop app, use your pc desktop shortcut for rc8 in VR. This will automatically launch your Oculus App, then it will load rc8 scenery and aircract, then it will show the Start screen. Put your headset back on and use your keyboard space bar to center it's view. Then use your mouse and select start.


    Once you have this working you should then be able to select rc8 from your Oculus apps panel. If you have problems, go back to the previous methiod. Also, make sure you have selected Unknown Sources on the top of the Settings/General tab. This is required for apps not bought from the Oculus Store.


    If you are having further problems then you may need to contact both rc8 support and Oculus support to get them to help you further. Good luck.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac gtx 1080 ti blower, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd. Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Oculus Rift cv1 w/2x sensors, and Asus VG248QE external 1080p 144hz gaming monitor. Now with new Vive Cosmos VR headset, looking good so far.