Anyone tried Aerofly FS2 under Steam Play Proton (Linux)

  • I recently made the switch away from Windows on my main PC, since gaming on Linux is really becoming a possibility, thanks to Proton. I am trying to install Aerofly FS2, but I don't want to download the full 120Gb just to see if it works with the Proton compatibility tool.


    On the steam library, there used to be a tab under the games properties, like on every other game that has DLC, where you can tick/untick which DLC you want to be active (and download). Sadly Aerofly FS2 does not seem to have this option under Linux?


    So I am asking here if anyone had luck running Aerofly under Linux with proton, before commiting to download 120GB of data.


    Ok. So after a steam update, the DLC tab appeared again. Great! I proceeded to install Aerofly FS2 with Proton 4.11


    Everything was working great so far, sounds, planes, scenery, settings, vulkan, till I tried to fly with my joystick. As soon as I connect the device, the game crashes without any error pop-up or message. If I try to launch the game with the joystick connected, same thing. I tried with a Logitech 3D Pro, a T16000 and even an xbox usb controller. Thats a shame! :(


    Any news on the native Linux version?

  • neucoas

    Changed the title of the thread from “Anyone tried Aerofly FS2 under Steam Play Proton” to “Anyone tried Aerofly FS2 under Steam Play Proton (Linux)”.