Throttle issue on downloaded aircraft

  • So, I use a Thrustmaster T16000M setup and run the game almost exclusively in VR. To add, I have not had this issue with any vanilla or DLC aircraft.

    However, when I download an aircraft or two and insert them into the files (Yes I did it correctly, I have double and triple checked), they all seem to have the same bug. I throttle up for takeoff, as you do, and as soon as I am airborne the throttle has a mind of its own in-game. My physical throttle is at 100% but in-game it goes down and up on its own. I pull a high-g turn and it throttles up. I level off and it throttles down to the point of an eventual crash into the ground. I have scoured google and I cannot find mention of this problem anywhere. Below are the two aircraft that I have tried it with thus far.…-version-from-2020-02-07/…oflyfs2/aerofly_fs_2_s211

    If you have any knowledge of this issue, please help. The community creates some amazing things and I would love to partake.

  • Allow me to reiterate. This issue only occurs on downloaded aircraft. Specifically the two I linked. It does not occur with other aircraft that come with the game. My controls remain as they have been and vanilla aircraft work just fine. I did indeed double check the controls just to be sure. I didn't know what else to troubleshoot.

  • I only have one axis assigned for throttle. Unless I read that wrong. o.o

    Edit: So you got me thinking. I do use another axis for throttle, but for helicopters. So I removed that binding from the helicopter controls and it works perfectly now. Well, I tested it during normal play, not in VR. I'll do that later. I can't see it being a big difference so I'd say this is solved, pending the VR test that may or may not be needed. Thank you!