Thrustmaster Hotas.X - bug in Aerofly FS2?

  • From scanning previous posts it looks like this is an unresolved issue: I have a Thrustmaster Hotas.X which works fine in other games and is even detected and works as expected in the FS2 controller configuration screens. However, when I start a flight sim it's nowhere to be found - the only controller options are mouse & keyboard. All drivers and game files are up to date and I've tried deleting all files under Documents\Aerofly FS 2\.., etc to refresh config settings, but still no fix. Am I missing the hidden option to "use joystick instead of mouse & keyboard", or is this a bug in Aerofly FS2?


    Thanks,

    JM

  • So I use the same controller. While I haven’t had that exact same problem. I have had some issues where during a flight parts of the controller are no longer detected, I. E. X axis. I would hit the red home button on the controller to deactivate it and then turn it back on and it seem to work just fine. Seems like there may be a small bug with it. Try turning the controller off using the red home off button on the controller and loading up the Sim and seeing if it detects it.