Vulkan finally works

  • Hi guys,

    I've always had a lot of problems with Vulkan, especially CTD.

    However, after some tests, I managed to finish my third flight in a row. I don't know exactly what I did differently that finally made me stable, so I'll quote below what I did recently, as well as share my Main and TM files if anyone wants to analyze:

    - I updated the ATI video driver (I don't think that was the main item in isolation);

    - I did a registry cleaning with CCleaner;

    - Uninstalled the high resolution texture pack (here's my main suspicion. I use a notebook and Aerofly is not on the SSD. Normal HD is very slow, so possibly big texture files cause problems;

    Have good flights,


  • i get black screen in my oculus using vulcan

    MSFS | X-Plane 11.5x | DCS 2.5.6 | P3Dv5 | War Thunder / Aerofly FS2

    Win10-x64 | ASUS Z390 Maximus VI | Intel i7-9700K @3.6GHz | Corsair Vengeance LPX 32 GB DDR4 | 6TB SSD Samsung 850 Pro | 2TB M2 PCI 4x | ASUS GTX 1080 ROG STRIX 8GB DDR5X | TM Hotas Warthog | Saitek Combat Pedals | Oculus Rift S

  • CTD after 5 min in Florida...

    Then repeatedly immediately. After a bit of flying with OpenGL, I tried again, this time setting frame limit to off. It then worked fine for the 15 minutes or so that I flew. It definitely feels better with my notebook than with OpenGL.

  • Vulkan now runs stable here. Full-HD, no Vsync nor anti-aliasing, low graphics settings. And gives a bit more fps than OpenGL. Exactly those frames that I need with my not-for-gaming-notebook.

    Tearing when looking around fast in the cockpit is significant though.

  • Non VR user, I tried Vulkan today for the first time in many months and it works fine 🤗

    It is giving me better FPS in built up areas too. The only minor problem so far is with the freeware Paris where it crashes back to steam. Everywhere else so far is brilliant.