Problems with A320 navigation and AP

  • Hi Aeroflyers and iPacs team,

    Today I tried a simple flight between Fresno and Monterey, but the a320 has behaved strangely with navigation and autopilot. It is frustrating because we have the ability to start Cold and Dark now, the performance with Vulkan is perfect, but on the other hand it is a little annoying and confusing to operate the current navigation engine.

    I believe that it would be interesting for Aerofly FS 2 to resume the previous navigation mode (that despite not having some features, it worked without bugs), and keep the other new features that are working well (cold and dark, the new helicopter, the 777 ECAM pages...). Even with great new features, a bugged feature so important can move away new users and make the experience frustrating.
    After the new navigation system works correctly, then make it available. I don't want to looks like a complainer, it's just a point of view.

    So, it's my report:

    Just after takeoff, the aircraft struggled to maintain NAV mode when the first turn ended. I had to cross the rote using HDG mode after three attempts to catch the NAV mode.
    I selected the FL200 but I was confused about the indications of TOC and TOD in the ND. The message DESACELERATE appeared during the climb, and far from TOD.

  • Same things with iPad too.

    I avoid SIDs because there’s often one where the A320 gets out of the NAV. Especially if there’s a kind of u-turn in it. I use my own departures.

    And T/D weirdness isn’t patched with the 20.20.21 (early November update) on iPad.

    With a personal top of descent, the descent profile seems to be patched. But not sure at this moment. I need more tests to be done...

  • Thank you for providing the screenshot of the full route, that helps a lot!

    I'll try to replicate the issue and see if I can fix the lateral steering issue.


    I'm still not sure why the VNAV is broken in the Steam version because it has been working for quite some time on my developer build. We must be missing something here. The fact that it works on the developer build gives me hope that we can fix this issue hopefully soon!

  • Eu ainda não tenho certeza porque o VNAV está quebrado na versão do Steam porque ele está funcionando há algum tempo na minha versão de desenvolvedor. Devemos estar faltando alguma coisa aqui. O fato de funcionar na versão do desenvolvedor me dá esperança de que possamos corrigir esse problema em breve!

    I will try to restore the files in the Steam and test again. Ty Jan!

  • I have the same difficulties. This is the reason for my post about the problems with using SID and STARS in Switzerland... !

    Important: It seems, that this problem is exactly the same with the LJ 45.

    Windows 10 Pro 64-Bit-Version, Intel Core i7 3770, 3,4 GHz, 16 GB RAM, NVIDIA Geforce 1050 ti

  • Hello everyone; I also have had a lot of AP's issues like cristianodesa with airliners since the last update from Steam. I finally found a solution by removing the file "main.mcf" and now it's better. Exception is, as said by Heideflieger in the post above, that AP with SID and STAR behaves strangely. As I noticed after take off, SID was correctly followed, but at the junction with the route it didn't take it in account following straight, completely ignoring the route. Seems to me to be that this new and good feature need to be reviewed. Still not criticizing the good job made by FS team, just trying to communicate my experience.


    I also noticed different other strange behavior on AP difficult to indicate everything as it's not the same every time and it will be interesting to know the point of view of FS 2team.

    I would like to add why there is not any ON/OFF button on the FMC.


    Thanks for reading Cheers

    tm.logtm.log

  • Ty for your suggestion, Babar66. I reset the Main file and remade the flight. Horizontal navigation went well. I'm not sure if it was due to the suggestion, as I believe I already reset the file a few times when I was testing Vulkan here. Thank you anyway.

    Unfortunately, vertical navigation is still strange. The suggested level was FL190 and the TOC appeared 92nm for the destination. And when I select a higher level, it seems to me that the simulator establishes a climb restriction.

    Let's wait because Jan and iPacs are definitely reviewing this.

  • cristianodesa Hello , I have several questions regarding various issues with navigation behavior with Aerofly FS2. Do you agree to exchange with me your experience and thought ?
    For example, speaking about the Cessna 172SP, I noticed that it was impossible to adjust the Altitude on the AP. It is stuck at 5000f, only VS is functional. And NAV is also not working.

    Do you have the same comment ?



    Thank you for your answer?

    CNTBB

  • Dear Jet-Pack (IPACS)

    I noticed something that might help to understand the descent profile calculation and why it is discontinued when passing waypoints.

    In this photo, I’ve just passed the BRK waypoint. Suddenly the curve around QUAIL waypoint changed from the red shape to the green shape. The number of Nm decreased suddenly because the new calculated way in green is quite shorter than the initial calculated red way. So suddenly the plane was quite above the descent profile.

    Multiplying this shortcut effect at every waypoint might help to explain or understand.

    Best regards.

    iPad Pro 11-inch iOS 14.2 AFS2020 20.20.21 A320

  • I forgot to mention it sometimes happens in the pc version too.

  • Thank you for investigating but there is a lot more going on behind the scenes than just what you see on the screens. We have a pretty good idea of what may be going on, let us verify what's actually happing before jumping to conclusions too quickly. We're on it, just please give us some time to investigate and debug.

  • Hi Babar,


    I was able to change the altitude normally on autopilot. Did you use the rotary knob for the selection?
    However, I was also unable to make the autopilot follow the navigation inserted in the flight plan (Navigation screen). :(

  • Hi Babar,


    I was able to change the altitude normally on autopilot. Did you use the rotary knob for the selection?
    However, I was also unable to make the autopilot follow the navigation inserted in the flight plan (Navigation screen). :(

    Thanks a lot, Yes you're right about ALT knob. But NAV is inop. If you have any question to share with me please do it. I will do the same . Thanks again.:thumbup: