ISSUE FIXED in Version 2.05.03.19 - Vulkan doesn't work with Oculus SDK in VR (black screen)

  • Hi Team,


    I posted this also on Steam forum but better to post here I guess :

    I was out for a long time and just re-downloaded the Sim few days ago. It worked fine on monitor with Vulkan selected, but had no chance to make it work with my Oculus CV1 on VR, I had a black screen in Headset and the sim appear right on my monitor.

    Switching to OpenGL fixed the problem, and also switching to the SteamVR version, but in both case I don't have the same quality and fluidity than with Vulkan and Oculus SDK in VR.

    I'm using the last NVidia drivers (457.30) and don't really want to downgrade it for numerous reason (support of recent games).


    If you can investigate this that will be great!


    Thanks!

  • Yeah it's never gonna get fixed (issue appeared back in March), the devs say it's not their problem :/.

    You have to switch to the 442.74 Nvidia drivers every time you wanna play Aerofly, completely destroying the selling point of fast load times for this game. Lame.


    But hey we got a new helicopter I guess...

  • Thanks for the quick answer! :)


    I reproduce it every time :


    Last NVidia drivers 457.30.

    GTX 1080

    Oculus CV1


    Be sure Vulkan is selected in game on 2D session (first steam choice), and exit the Sim. Now launch Oculus Home, Launch Steam and choose to launch the sim in "Oculus VR Mode" (second choice). Here I have a black screen on the headset, and Sim main menu fine on monitor.


    It work fine in Vulkan if I select "Launch the Sim in VR (Third choice, so with SteamVR)" or if I select OpenGL in game before launching the Sim "Oculus VR Mode" (second choice).


    So the native Oculus SDK version work only if the Sim run with OpenGL, not Vulkan.

  • YoLolo69

    Changed the title of the thread from “Vulkan don' work with Oculus VR (black screen)” to “Vulkan dont' work with Oculus SDK in VR (black screen)”.
  • Thanks for the response and it is good to know that on some systems vulkan works with Oculus CV1 without issues.


    It makes me wonder if it is possible that user added content (e.g. purchased add-ons/community created scenery and/or airports) may be a contributing factor to create this problem.


    I did test disabling my installation of RC ATC, which has a dubious vulkan dll in my installation but that did not allow vulkan to work natively with Oculus.


    I did not test removing all extra scenery and running the game vanilla style as that is a lot of effort. Before I would want to try that approach I would request some advice from the developers if there is merit in trying such an approach (as in there could be a possible conflict)


    Otherwise it seems to be an nvidia driver issue as my experience is similar to others...vulkan does work with earlier nvidia drivers (prior to and including 442.74 iirc)

  • Extra scenery and aircraft should be in the documents folder, maybe it is as simple as renaming that AFS2 folder temporarely?

    Regards,

    Peter Splinter


    i5-7400@3,5 GHz, 16GB RAM, GTX 1660 Super, Quest 2 and Lenovo Explorer VR, 'Vintage' Pro Flight Trainer, X52 Pro, VKB pedals

  • You gave me a great idea here and I was able to fairly easily test a 'vanilla' build with only official steam purchased addons included. All community based scenery was removed from the game for the test.


    However it was unsuccessful in getting vulkan to work in native oculus mode... so that rules out custom addons as the (sole) cause.

  • Obviously there is a conflict between Aerofly FS2 graphics output and newer NVidia drivers, I hope the IPACS team can fix this issue....
    For what I know using SteamVR for Oculus headsets gives a little less performance.

    You can verify your installation by right clicking on AFS2 in Steam and go to local files but I don't think that will be any help.

    Regards,

    Peter Splinter


    i5-7400@3,5 GHz, 16GB RAM, GTX 1660 Super, Quest 2 and Lenovo Explorer VR, 'Vintage' Pro Flight Trainer, X52 Pro, VKB pedals

    Edited once, last by PjotR22 ().

  • Other games using Vulkan work fine with last NVidia drivers so I guess something in the way IPACS implemented it in AFS2 turned incompatible. I saw you can regress in Nvidia drivers version to fix this, but I simply can't and don't want. Really hoping they will be able to reproduce and fix it.

  • Just chiming in here to say that I have seen the exact same thing for months with the Rift CV1, i7 8700K CPU, and 1080Ti graphics card. Does it with all recent versions of NVidia drivers as far as I'm aware. I haven't tried rolling back to older ones to fix it, but they'd have to be quite old given how long ago this first started happening on my system.


    Like the OP said, it only affects the Oculus build. Game launches, shows up on 2D monitor with the message about being in VR mode, but inside the VR HMD everything is black. Switching over to the SteamVR build works fine in Vulkan. OpenGL works fine in both.


    Also I should add, this might only be affecting the CV1 Rift. I think every post I've seen in this thread and previous ones with this issue, it's been the CV1, not the Rift S. So if the AeroFly devs are using the Rift S to say 'it works fine,' that's probably the problem.

  • We use highly optimized rendering techniques which the others may not use. For example: When the default unsigned integers may have 32 bits and all other programs use it we may use only 16 bit to cut the required graphics memory by half. The driver is supposed to support that optimization but if there is a bug in the driver code on some of its newer versions then everyone else doesn't notice it but our optimized rendering techniques will. And since nobody else reports that bug it requires some time until they fix their big or we find a workaround.


    This is just one example of what could be going on. I'm not saying it is necessarily "their fault" this time, this is just something that actually happened in the past. This time it could be something totally different and it could very well depend on the particular graphics card in use.


    Can one of you that has a black screen please upload their tm.log file after a black screen occurred as well as tell us exactly what graphics card they use (manufacturer as seen on the card). Then we can try to replicate this issue on a similar setup.

  • Can one of you that has a black screen please upload their tm.log file after a black screen occurred as well as tell us exactly what graphics card they use (manufacturer as seen on the card). Then we can try to replicate this issue on a similar setup.

    As requested... Note I removed all extra addons except for steam purchased ones before conducting this test and the tm.log file is attached.


    GFX card is Palit Geforce GTX1060 6gb StormX


    Driver is 457.30

  • Jet-Pack (IPACS)

    Changed the title of the thread from “Vulkan dont' work with Oculus SDK in VR (black screen)” to “Vulkan doesn't work with Oculus SDK in VR (black screen)”.
  • Great to see your devs are following the issue, thanks for that.

    GTX 1080 here, with drivers 457.30

    Here my tm.log, and if that can help for comparison reason I provide 6 of them. I deleted tm.log each time in case it's additive, I didn't tested that.

    Their names are implicit.:


    Also, checking fps on the mirror view with the GeForce FPS OSD, I found than:

    - Monitor OpenGL show 152fps

    - Monitor & Vulkan (high AA) show 160fps


    - SteamVR & OpenGL show 45fps (ASW OFF)

    - SteamVR & Vulkan (High AA) show 59fps


    - Oculus VR & OpenGL show 44fps (ASW OFF)

    - OculusVR & Vulkan (high AA) show 61fps (ASW OFF) Headset on Black Screen due to the problem.


    The game work fine on the monitor mirror view when using Oculus SDK and Vulkan, just the render in headset is off.


    Hope it help!

  • Thanks for that! I remember that the last time I wanted to find out whether OpenGL or Vulkan is faster, I couldn't find the info.

  • Thank you all for your input here. We are a little puzzled. We just tested Aerofly FS with the Oculus Rift CV1 and the Oculus Rift S under Vulkan and OpenGL and it runs just fine. We just can't reproduce the issue on our side?!


    Our test system has Windows 10, Nvidia driver 457.51 and a Geforce GTX 2060.


    We have really no idea what is causing this problem.


    If possible could you post a main.mcf configuration file here as well, maybe it's a setting within Aerofly FS that is causing issues?

  • I did test disabling my installation of RC ATC, which has a dubious vulkan dll in my installation but that did not allow vulkan to work natively with Oculus.

    Hello Astute,

    AFS2 RC ATC does not install any components of Vulkan. Vulkan components are part of your video card driver installation.

    The AFS2 RC ATC installer places three files in the AFS2 external_dll folder:

    1. afs2_rc_atc.dll
    2. afs2_rc_atc_vk_layer.json
    3. metar_stations.dat

    In addition, the configuration tool and documentation are installed to (by default) 'C:\Program Files\Aerofly FS2 RC ATC'.

    Lastly, if the target system does not have msstdfmt.dll installed (part of Visual Basic - required by Radar Contact but not installed by its installer), it is installed to 'C:\Windows\SysWOW64' (by default).

    Regards,

    Karl

  • This just reminded me... I think at one point I did discover that Vulkan started working again with a certain combination of graphics settings in the graphics quality options, which were less than maximums. If I have some time this evening I'll poke around and see if I can find it again, and post my log and main files.