No VR Settings when Oculus Rift S is connected

  • I just got the Oculus Rift S. It’s setup, added Aerofly to the Oculus library. When I start from Steam I click “Start in Oculus VR” it says loading for a few seconds then nothing happens. If I click “Start in Steam VR, Aerofly loads but isn’t in VR, and there are no VR settings in Graphics Settings page. I reinstalled the Oculus software, and deleted the main.mcf in Aerofly.


    Todd

  • Normally you must be able to use AFS2 on Oculus Rift S with the native Oculus SDK, so without using SteamVR at all. You will have a better and smoother experience if you can find why you cannot launch AFS2 using the Oculus VR choice (and in all case choose the Vulkan rendering in graphics option if you didn't yet, far better than OpenGL ;) )

  • Normally you must be able to use AFS2 on Oculus Rift S with the native Oculus SDK, so without using SteamVR at all. You will have a better and smoother experience if you can find why you cannot launch AFS2 using the Oculus VR choice (and in all case choose the Vulkan rendering in graphics option if you didn't yet, far better than OpenGL ;) )

    I’m still trying to figure out why AFS2 doesn’t run from the Oculus Software. It’s amazing how realistic AFS2 looks in VR. I will switch to Vulcan.

  • @moxeetwo: Could you please post your 'tm.log' file here so we can check why Aerofly FS 2 doesn't work from the Oculus side? This file is located in 'Documents/Aerofly FS 2/'. Please also tell us how you start Aerofly FS 2 with your Oculus? You should either use the special run option from the program group or click the button 'Restart in VR' directly from within Aerofly FS 2.

  • @moxeetwo: Could you please post your 'tm.log' file here so we can check why Aerofly FS 2 doesn't work from the Oculus side? This file is located in 'Documents/Aerofly FS 2/'. Please also tell us how you start Aerofly FS 2 with your Oculus? You should either use the special run option from the program group or click the button 'Restart in VR' directly from within Aerofly FS 2.

    I'm not sure if this is the correct way to start Aerofly in VR. I start Oculus, open Steam, start Aerofly , click "Launch Aerofly FS 2 in Oculus VR Mode" This wil start Aerofly in VR mode. I have attached the tm.log



    tm.log

  • moxeetwo: You can start Aerofly FS in this way, but it's not necessary. You can run Aerofly FS directly and then choose the 'Restart in VR mode' or use the entry 'Aerofly FS 2 Oculus VR' start mode from the Aerofly FS program group. Steam is not really required for Aerofly FS to run with Oculus support.

  • moxeetwo: You can start Aerofly FS in this way, but it's not necessary. You can run Aerofly FS directly and then choose the 'Restart in VR mode' or use the entry 'Aerofly FS 2 Oculus VR' start mode from the Aerofly FS program group. Steam is not really required for Aerofly FS to run with Oculus support.

    Mmm, interesting...


    I would like to avoid launching Steam to use Aerofly FS2 with or without VR, and I don't have any AFS2 program group created. So I created 2 shortcut which point directly the executable, with the parameter -othervr for the Oculus version.


    When I use those shortcut, steam start anyway (boooo!), and for the VR version even complain it have additional option (-othervr) and ask if I want to cancel or continue, not really user friendly ;)


    I also can't find a "restart in VR mode" choice when I land in AFS2 on monitor (but have no reason to use it anyway so not a big deal).


    So for now I use the same path than moxeetwo, I start Oculus, open Steam, start Aerofly , click "Launch Aerofly FS 2 in Oculus VR Mode".


    So we have a way to start AFS2 directly without loading Steam for us Oculus users (and/or flat version)?

  • To start Aerofly FS in Oculus native mode use the -oculusvr parameter. This should first attempt Oculus native support and if that fails it tries Steam VR.

    Ok we have a small misunderstanding, I though we were talking about avoiding Steam itself, not SteamVR, so I guess we can't (probably for drm reason, fair enough) ;)


    BTW if I click on Steam at the choice "Run AFS2 with Oculus VR" I can see the parameter '-othervr" is used on the executable, versus "-openvr" if I chose "Launch in VR" wich use SteamVR.


    "-oculusvr" work too on the executable, but as I said it launch Steam, and then ask for permission to launch with an unknow parameter, then launch in oculus VR mode.


    Never mind and sorry, I kind of hijacked this post...