VR Responsiveness

  • Hi all,


    Preamble:

    I recently purchased AFS2 and I want to thank the developers for doing a superb job of remaining cognisant of performance whilst creating this simulator. The UI is straightforward, I calibrated my Pro Flight Trainer Puma in under a minute and found myself sitting in the R22 within 5 minutes of downloading.


    VR Response:

    In Oculus VR mode (I use a Quest 2), I’m noticing that the responsiveness of my head movements is incredibly fast. I can visualise every tiny movement of my head which can feel a little overwhelming!


    I was wondering if there was a way to dampen this motion out so my headset isn’t so responsive to every tiny movement as it can be quite difficult to focus on the instruments. I currently have to fly with my head dead still to focus otherwise I lose focus.


    Is there any way to reduce this effect? I can’t really say this is a problem, is like it’s actually ‘over performing’ in a way!


    Many thanks!


    Craig.

  • In Oculus VR mode (I use a Quest 2), I’m noticing that the responsiveness of my head movements is incredibly fast. I can visualise every tiny movement of my head which can feel a little overwhelming!

    Hmm it is a rarity to hear about downsides to incredibly fast responsiveness !!


    I know nothing about Oculus but it sounds like it's in the vicinity of Asynchronous Time Warp. I wonder if FS2 supplies the required depth buffer for ATW 2.0 with Positional Time Warp? My thinking either it's super latency reduction that you're not enjoying or maybe it's fall-back to rotational based ATW 1.0 and you could even be experiencing higher latency & less accurate positional interpolation ?


    So video is scanned out at a rate of ~ 120 lines a millisecond, scan lines to the right have a greater latency than lines to the left. This is where the depth buffer & greater positional accuracy may be useful. or too useful but I doubt it.


    Oculus Compositor may state which version ATW is running or maybe I'm barking up another one of those trees.

  • To be honest it's kinda hard to fully understand what you mean mate. I cannot say for sure but it sounds like when you turn your head too quickly the image in front of you blurs a bit, until you slow down or stop. The same thing probably happens when you apply fast yaw (rudder) to the outside world with your head still. If this is the case then it's certainly not over performing, nor is that ever likely going to be the case with VR, lol!


    The cause and cure are dependant on you PC system and your settings. I wish people would add PC specs to these kind of threads.


    In general, I would guess (all I can do) that your framerates are a bit too low for the headset refresh rate you've chosen to use. While it depends on how strong your PC is, I suggest that with your Quest 2 and Link that you initially avoid using OTT or ODB. Go into your Oculus desktop app and with your Q2 connected with Link go to device settings for your Q2, graphics quality, and select 72Ghz refresh rate and Auto rendering (1.0) to start off with. Then try FS2 in VR again and check how things look. Press ctrl+F1 to toggle fps readings (will only be shown on your monitor, so just peek to see this).


    If your PC is strong enough so you can maintain at least 72fps with this 72Hz refresh rate then things should look pretty good and smooth. If you still have headroom, try increasing your Q2 refresh rate to 80Hz (not much improvement going to 90Hz with flight sims imho). If you still have headroom try increasing your Oculus desktop rendering to 1.3x and/or go to your FS VR settings and increase SS (top slider) a little bit at a time.


    If your PC is not strong enough to maintain 72fps in VR set to 72Hz refresh rate then you will need to use OTT and use a game profile to set asw = 45fps forced (= 36fps if you have Q2 refresh to 72Hz, 40fps set to 80Hz) and this will also disable asw (which I think works best with low level heli flying, otherwise you get too many wavy artifacts).


    Anyway, give this a go and let us know how you make out. Good luck and cheers.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac rtx 3090, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd, corsair gold 750w psu, Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Vive Pro w/etsty gear VR lens mod, and Quest 1+2 (w/Link and wireless w/VD and Air Link). Asus VG248QE external 1080p 144hz gaming monitor.

  • Hi there, thank you both so much for your responses!


    This is quite a difficult one to explain however the best way to describe it is that I can visualise every tiny movement. Even moving my headset within extremely small ranges the visual output feels a little excessive.


    PC Specs:

    RTX 3070 8GB

    i7 9700k unlocked/ no OC

    32GB RAM DDR4 @ 2666

    All stored on a 1TB SSD.


    I’ll explore the methods you have shared and get back to you with some results!


    Many thanks.


    Craig

  • For me ... it sounds like ..

    your head swing / pan ... 3 degree left ... and the VR Hardware shows for your eyes 10 dgree left ... like this ?

  • Craig, VR is not for everyone, esp. if you are prone to epilepsy, lol! Just kidding. Maybe you just need to climatize to VR a bit more and maybe make check your headset fit/placement. Maybe it's too loose?

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac rtx 3090, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd, corsair gold 750w psu, Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Vive Pro w/etsty gear VR lens mod, and Quest 1+2 (w/Link and wireless w/VD and Air Link). Asus VG248QE external 1080p 144hz gaming monitor.

    Edited once, last by TomC RLG ().

  • I have one VR game ( diving with fishes ) where I only need 15 min ... before my dinner comes to the wrong way out :)

  • Do you have Vulkan enabled in the sim, or are you using OpenGL? If you're using Vulkan, try changing it to OpenGL and restart the sim. Let us know if it improves things. There is a bug with Quest2 + Link when running Vulkan in AeroFly which makes head movements very ...weird.

  • This solved the problem! Thank you very much - do we have an idea of when Vulkan will work with Q2 with Link?


    Many thanks!

    Glad that fixed it! I'm not sure if this bug is even on IPACS' radar. It only seems to affect Oculus Quest headsets running via Link. I've mentioned it in a couple of threads here now, but ultimately they're going to need to test it with an Oculus Quest headset too in order to replicate it and fix it.


    There's another thread about the same problem here: RE: Vulkan not working with Nvidia drivers 461.40

  • admin  Jet-Pack (IPACS) Hi, just want to bring to your attention that there is still a bug with Vulkan when using Oculus Quest devices with their pc-link cable. It's what the user in this thread was having an issue with, and it has been commented on in several other posts here with people not knowing what the real issue is.


    The effect is this: if you are running with Vulkan enabled, launched into the native Oculus VR build (*not* steamVR), then the rendered scene is VERY laggy with head movements. Any normal-speed head movements cause an effect where the world rendering is extremely delayed, and as a result the outside view gets dragged along with your head motion. Instead of the cockpit and scenery remaining fixed while you move your head, they move with your head at a variable rate.


    I tried to record this on the 2D mirror, but it only shows up in the headset. The mirrored desktop view looks completely normal.


    If you change back to openGL rendering, the issue goes away completely, and the app is its normal extremely-fluid performance at 90fps.


    I was one of the users who used to have the problem of the Vulkan Oculus build going straight to a black screen, until your update a few months ago fixed that issue. However I'm wondering if this is still somehow related.


    My system is a 1080Ti GPU, i7 8700k CPU, and MSI Z370 Gaming Pro Carbon AC motherboard. I wondered if this was an Nvidia driver bug with my older 1080Ti card, but the user above has an RTX3070, so it's affecting newer cards as well.