Vukan API causes Radeon driver timeout on RX 5700 Xt

  • When I try to use the Vulkan API in FS2 it causes a CTD because of a Radeon driver timeout. This happens only in FS2 and both using Quest 2 and non-VR.


    Using Vulkan in XP 11, Half-Life: Alyx and Red Dead Redemption 2 causes no errors.


    I can get Vulkan to work if I revert to Radeon 20.9.2, but any driver newer than this causes FS2 to crash. I use a Ryzen 5600X and RX 5700 XT, and Vulkan runs so much better on my system that it really sucks to use OpenGL in VR. Unfortunately 20.9.2 is getting so old that it causes instability in other games so I kind of had to update to the newest drivers.


    I've tried using DDU and AMDCleanupUtility several times with no luck.


    Anybody else still having problems with the Vulkan API?

  • Yes, I do. Although I have an ASUS notebook with integrated AMD RX Vega Chip, so I was always thinking this might be a special configuration almost below minimum system requirements. Nevertheless, iPacs managed to iron out some issues I had.


    But still, with newer graphics drivers, Vulkan crashes. This is especially annoying since Asus published new OEM graphics drivers which I cannot seem to prevent from reinstalling. So, every week I have to install an older driver from AMD directly (the mentioned 20.9.2) to enjoy Aerofly under Vulkan. But every week the new OEM driver is downloaded again, and I have to reinstall an older driver. Quite annoying.


    Now that you have the same issue with a standalone Radeon graphics card, which should be far more common than my setup, maybe iPacs can have a look at that and solve the Radeon/Vulkan issue.

  • I use the ORBX Insbruck and Netherlands scenerypack, and France VFR - Paris-Ile-de-France.


    When I start a flight in the EC135 and fly any direction the driver timeout happens after 30 seconds to 10 min flightime.


    I also use an AMD 5600X CPU and B550 Mobo, so perhaps thats also relevant to the bug?


    I currently use radeon 21.6.1, but also tried 21.6.2.

    • Official Post

    @dontim: Could you please tell us your exact GPU model and the amount of memory it has? Also in Aerofly FS what are your quality settings there? At what point do you observe a crash, is it in Innsbruck already? Both ORBX Netherland and VFR France do need a lot of memory, so it's highly likely that the crash occurs due to memory issues, but we need more information.

  • System info:


    Computer: MSI MS-7C56

    CPU: AMD Ryzen 5 5600X (Vermeer, VMR-B0)

    3700 MHz (37.00x100.0) @ 3674 MHz (36.75x100.0)

    Motherboard: MSI MPG B550 GAMING PLUS (MS-7C56)

    BIOS: 1.70, 06/23/2021

    Chipset: AMD B550 (Promontory PROM19 C)

    Memory: 16384 MBytes @ 1599 MHz, 16-18-18-36

    - 8192 MB PC25600 DDR4 SDRAM - Corsair CMK16GX4M2B3200C16

    - 8192 MB PC25600 DDR4 SDRAM - Corsair CMK16GX4M2B3200C16

    Graphics: Powercolor RX 5700 XT Red Devil/Dragon

    AMD Radeon RX 5700 XT, 8192 MB GDDR6 SDRAM

    Drive: TOSHIBA HDWD130, 2930.3 GB, Serial ATA 6Gb/s @ 6Gb/s

    Drive: INTEL SSDPEKNW010T8, 1000.2 GB, NVMe

    Sound: ATI/AMD Navi1x - High Definition Audio Controller

    Sound: AMD Family 17h/19h - HD Audio Controller

    Network: Intel Wi-Fi 6 AX200 160MHz

    Network: RealTek Semiconductor RTL8168/8111 PCI-E Gigabit Ethernet NIC

    OS: Microsoft Windows 10 Professional (x64) Build 19043.1202 (21H1)


    Crash happens when using both high and ultra graphics settings. I can make a performance log using the radeon software if that might help?


    Tried running a small test yesterday with the EC135 running idle at the helopad in Insbruck for 10 min and no CTD. Then took off and flew west for 5 min at 2000 feet. Then initiated a left turn to east and the game crashed.

  • On my end, I`m pretty sure it`s the 2GB VRAM of my integrated GPU that causes the Vulkan issues, as you suggested.

    Nevertheless, with the old drivers it runs well, with newer or current ones, Vulkan crashes. I limit myself to the stock sceneries or official paid ones, but not Orbx, since I have the impressum that the stock sceneries are more optimized.


    I`m currently flying in the Colorado region, and with the newest drivers, I can fly to and from airports, but not from others.


    Like, I managed to fly in Vulkan from Aspen to Gunnison Crested a couple of days ago. Today, I can`t spawn at Gunnison with Vulkan (CTD), OpenGL runs. Sometimes it helps to load the setting in OpenGL, go back to the menu and switch to Vulkan, but this did not work today.


    Settings:

    • 1600x900 60Hz, frame rate limit off (I get around 40-50 best anyway)
    • no HQ anti-aliasing
    • texture, terrain mesh and terrain image quality set to medium, rest to low
    • Asus ZenBook UM433 / 16 GB RAM / 1 TB SSD / AMD Ryzen 7 3700U / 2.3 GhZ / AMD Radeon RX Vega 10 integrated GPU

    Again, with the OEM drivers that came with the NB, Vulkan worked, and also with 20.9.2 AMD drivers. Unfortunately, with an updated OEM driver and newer drivers from AMD directly, Vulkan crashes randomly.