Rolling back to a previous version

  • I'm trying to roll back to a previous version of the game. I used the steam console method through the "download_depot 434030 434032 1453587901762303020" command to get a december 22 2020 build, unfortunately the result is an error message "manifest not available".


    Can someone shed some light on the issue or maybe send me the bin64 folder for a pre jan-21 version?


    Thanks

  • Steam console no longer supports downloading older files. You need a free, 3rd party app for that now. google depotdownloader

    Ok so I downloaded an earlier version of the bin64 folder, the issue is still there. if I try to run both the executables and the content from december I get an error message and Steam forces me to go online and update the game.


    Honestly this sucks, everything ran perfectly fine in december and now with this navigation stutters it's completely broken and useless.


    Also thank you so much to the support team completely ghosting me, not even asking for the tm.log or at least pointing me in the right direction explaining what happens behind the scenes when we activate a flight plan.

    Top notch 60game customer service.

    • Official Post

    The log file is not necessarily going to help us in this case because the stuttering is probably caused by updates in the navigation menu or route navigation code. When you enable the debug overlay with ctrl+f1 what framerate does it show in the lower left corner. Can you please grab a screenshot of the navigation menu with that overlay active?


    Thanks!

  • The log file is not necessarily going to help us in this case because the stuttering is probably caused by updates in the navigation menu or route navigation code. When you enable the debug overlay with ctrl+f1 what framerate does it show in the lower left corner. Can you please grab a screenshot of the navigation menu with that overlay active?


    Thanks!

    The stutter does not happen in the navigation menu, it happens in game whenever a route is active, even if I manually input the data in the FMC.

    • Official Post

    Does it start lagging right away when you enter an origin and destination or does it get worse when waypoints are added? Or is it limited to certain pages, e.g. when browsing the arrivals and departures for an airport, etc.?

    Does it affect all aircraft once the route is created or just some (e.g. just airliners)?

  • Post by rairic ().

    This post was deleted by the author themselves ().
  • Does it start lagging right away when you enter an origin and destination or does it get worse when waypoints are added? Or is it limited to certain pages, e.g. when browsing the arrivals and departures for an airport, etc.?

    Does it affect all aircraft once the route is created or just some (e.g. just airliners)?

    the framerate becomes unstable as soon as I add anything to the route, even just a departure runway. This happens in both GA aircraft and Airliners


    You can see the difference in frametimes between the a320 parked at KLAS with and without an active flight plan in the attached graphs.


    Active flight plan:


    No active flight plan:

  • I forgot to mention that this frame instability is independent of frame rate, even with no FPS cap I get around 220 FPS without a flight plan and 218 down to 210 fluctuating FPS with an active flight plan.

    I don't get any abnormal readings in terms of GPU, CPU or disk usage so the issue has to be related to the navigation system trying to do something weird and generating lag spikes.

    • Official Post

    Hmm.... that doesn't look great.


    How many user generated airports or sceneries do you use by the way?

    Maybe it would be good to check the tm.log file after all. Could you please upload your tm.log file from the user documents Aerofly FS 2 folder for us (either make it a .txt or attach it in a zip file). Thank you!

  • Hmm.... that doesn't look great.


    How many user generated airports or sceneries do you use by the way?

    Maybe it would be good to check the tm.log file after all. Could you please upload your tm.log file from the user documents Aerofly FS 2 folder for us (either make it a .txt or attach it in a zip file). Thank you!

    Thank you for looking into this,

    I used to have a couple of custom scenery files and I made some modifications to a few aircraft tmd files but this tm.log is from a fresh vanilla installation.

    • Official Post

    We've tried to reproduce this issue with the current Steam version but are unable to see any lag spikes on several devices.

    I've created a route from KEDW to KLAX and loaded the C172 at the runway threshold and there was no stutter even on my relatively weak laptop.
    Can you please tell us a bit more about where you fly and share a screenshot of the navigation menu?

    Are the issues still there if you change from Vulkan to OpenGl or vice versa?


    What kind of drive is Aerofly FS installed on?

    Have you tried to disable your anti-virus software as a test?

  • So, I ended up wiping the disk and resetting Win10. The problem is pretty much gone, must have been something bad cached in somewhere.


    Thank you for taking the time to look into this! ;)