EC 135 and Komodo Twin EC 135 Throttle

  • I am having issues getting the fadec to work with the new Komodo twin throttle.


    I have set the fadec to on but the throttle still stays in manual mode and I have to manually adjust the throttle or it overspeeds the RPM or I get rotor droop.


    Any idea how to get the throttle to match the ground idle ( start) and flight idle settings ?


    What would be really good is a way to adjust the actual throw of the throttle outputs so we can set them in the proper range as the current calibration does not seem to be doing that.


    I would also add my son has the new Puma X2 twin throttle and is having extactly the same issue.

    • Official Post

    The EC135 has a twist grip on the collective lever that has a detent at 50% of the full range. If the twist grip is not in the detent then it is used for manual throttle control.


    When you chose to assign a throttle input then you need to place it at 50% before engine start and leave it there for the entirety of the flight until after engine shut down unless you want to practice auto-rotations.

    If you enable the flight information at the top (press "i" to toggle it) then you can see the throttle input (at least for number 1). It should be at 50%. There is a significant deadzone around that 50% range and in our tests it was quite reliable.

  • The EC135 has a twist grip on the collective lever that has a detent at 50% of the full range. If the twist grip is not in the detent then it is used for manual throttle control.


    When you chose to assign a throttle input then you need to place it at 50% before engine start and leave it there for the entirety of the flight until after engine shut down unless you want to practice auto-rotations.

    If you enable the flight information at the top (press "i" to toggle it) then you can see the throttle input (at least for number 1). It should be at 50%. There is a significant deadzone around that 50% range and in our tests it was quite reliable.

    Thankyou I will try that, thanks for your quick response.

  • The EC135 has a twist grip on the collective lever that has a detent at 50% of the full range. If the twist grip is not in the detent then it is used for manual throttle control.


    When you chose to assign a throttle input then you need to place it at 50% before engine start and leave it there for the entirety of the flight until after engine shut down unless you want to practice auto-rotations.

    If you enable the flight information at the top (press "i" to toggle it) then you can see the throttle input (at least for number 1). It should be at 50%. There is a significant deadzone around that 50% range and in our tests it was quite reliable.

    Thanks so I set it at the flight detent at 50% and it was then working fine.


    if you override the Fadec with the twist grip is there any way to reset the Fadec as even if you move the twist grip back to the Detent you are then on manual throttle unless you rest the whole flight? Thanks