Landing gear mapping

    • Official Post

    The default assignment should already work, so as a last resort you can always go back to the defaults in the menu.

    To assign the gear lever try this.

    Delete all assignments for the landing gear. Physically move your lever in the up position. Then click the middle area to assign a new command, move your lever down and keep it there. After a second delay Aerofly FS interprets the constant on signal as 'gear down while button pressed' and you should be all set.

    Please note that the A320 gear lever cannot be raised on the ground. Like many other airliners it has a physical lock in the cockpit that prevents gear retraction whilst on the ground.

  • Nope, didn't work regardless. I'm at a loss, No worries, I'll just leave it as is. I don't need to look at it, I just reach over, flip it and keep landing, and notice the green lights come on the console knowing their down. I got everything mapped out and don't want to start from scratch and remap stuff. Its only the landing gear, I can live with it. We tried right....thank you sir. ;)

  • For me on the Mac, in such cases it is sufficient to simply reassign the corresponding function.

    Tschüss, Michael (🍎🚁)


    - MacBook Pro (16", 2021); Chip: Apple M1 Max; actual macOS || Thrustmaster TCA AIRBUS EDITION: 1x Sidestick, 2x Quadrant, 2x Quadrant Add-On || Pro-Flight-Trainer PUMA X

    - iPad (12,9", 4th Generation); actual iOS || nimbus steelseries

  • Can you please describe what it is currently doing or not doing? It's unclear to us what we should do to fix this? It works great on all the test devices that we have. What operating system do you use?

    When the gear switch on the throttle quadrant is up, the gear is actually down and when the gear switch on the throttle quadrant is down, the gear is actually up. It's in reverse and I'm using WIN10 HOME. I did install the drivers from the TM website but they seem to be defunct. Its possible they might be causing the issue.

    UPDATE: Uninstalled the TM drivers, rebooted PC, gear switch still operating in reverse. :/

  • Aerofly does not indicate in which position the gear is, i.e. your hardware does not know it and vice versa Aerofly does not know in which position the switch is. That's the reason why there is only the key G available for gear up and down. You need to bring the switch on your device to the wanted position before you load the aircraft.

    Hence, if you load an aircraft on ground, move the switch to the down position, if you start in the air, move it to up.



    i7-6700K @ 4.0 GHz, Geforce GTX 1080, 32MB RAM, 500GB SSD M.2, 1TB SSD M.2, 2TB SSD M.2, 1TB HD, 32" Monitor 4K, Oculus Rift

    Edited once, last by TomB ().

    • Official Post

    The throttle quadrant is different and it does not matter where the lever is before loading the aircraft. It does however matter which way you move it and keep it when you are assigning the switch. Both assignment directions are possible.

    Please try to assign it as I described above. first move the switch up, then click to assign, move it down and keep it down. Then gear down should be assigned correctly.

  • jetpack, I have tried that several times as you have asked, it doesn't work, its still the same. As I said I'm not overly concerned about it at this point now. As long as the gear goes up and down, that's what matters. I can live with it. We tried, it didn't work.......moving forward....lets go fly. lol ;)

    UPDATE: I fixed it. Don't ask...its working properly now. :rolleyes: :thumbup: