Double Screenshots

  • I have been flying the new release - it is very good - over the weekend, and find that every time I take a screenshot, I now get two files, the usual *.bmp, plus a *.png.

    I have searched the mcf files for screenshot, bmp, and png but I could not find where the command causing this duplication is located. How can I fix this? I don't need png's, they are just wasting a lot of storage. ;(

    Thanks in advance.
    MikeW

  • Oh. I have to check this. Before I made an automatic script that takes the freshly created screenshot to move it in an easy to access folder. So. It means that PNGs remain and use storage

    MacBook Pro | M1 Pro | Thrustmaster Airbus Captain Edition
    X-Plane 12 | ToLiSS A321/neo/LR/XLR A320neo | BetterPushback | X-ATC Chatter | FlyWithLua
    iPad | SimBrief/Navigraph | WebFMC

  • I checked on macOS: no PNG image associated to the BMP screenshot.

    4.03.01.09 (20230523)

    MacBook Pro | M1 Pro | Thrustmaster Airbus Captain Edition
    X-Plane 12 | ToLiSS A321/neo/LR/XLR A320neo | BetterPushback | X-ATC Chatter | FlyWithLua
    iPad | SimBrief/Navigraph | WebFMC

  • I checked on macOS: no PNG image associated to the BMP screenshot.

    4.03.01.09 (20230523)

    This is in 4.03.01.10 on a Win10 PC. Don't think I took any screenies while I was using the Beta, but I will have a look. Thanks for your response :thumbup:

    Just checked - first observed yesterday, and I deleted them. Still have today's png's. No png's before that, or ever.

    Edited once, last by emfrat: Update Post (May 29, 2023 at 9:32 AM).

  • Yes there was a bug in the Windows version so it is a xx.10 instead of xx.09.

    It was for developers in the case the xx.10 would have inserted the PNG bug.

    MacBook Pro | M1 Pro | Thrustmaster Airbus Captain Edition
    X-Plane 12 | ToLiSS A321/neo/LR/XLR A320neo | BetterPushback | X-ATC Chatter | FlyWithLua
    iPad | SimBrief/Navigraph | WebFMC

  • No worries, I live in Oz so I wasn't expecting any response from the European timezone before tomorrow - but thanks very much for taking an interest. And at least I alerted you (and maybe others) to a possibility that might have affected your setup.

    ATB

    MikeW

  • The more I look into this, the more I am convinced that the problem is collateral damage from a recent Windows 10 update. The tmlog says AFS4 is saving a bitmap (.bmp) file and when I look in the screenshots folder, the image is there. But there is also a png of the same image. Something is copying/saving the AFS4 bmp as a png. I am not doing it, AFS4 is not doing it, Steam is not doing it, which only leaves Windows 10.

    In mid-April when trying the new airport conversions, I found that Print Screen would not work ( the keyboard had Prt Scrn as a Function on the Insert key, and no combination of Ctrl, Fn, Win Key and Shift would give me an image). Win10 kept popping up messages about installing the Snipping Tool. So I tried an older keyboard which has a dedicated Prnt Scrn key, and that worked, in AFS4 before the Beta.

    I did not try any screenshots in the Beta, but when I upgraded to the Release version, I discovered the png duplicates beside the bmp images.

    If you hear of an earthquake in Seattle, that will probably just be me gently persuading a certain software company to stop tampering with my machines. X( MikeW

  • That has nothing to do with Windows updates. I guess the screenshots are now saved as bmp and png. Do you have the developer options enabled?

    On macOS I still only have BMP files and not both BMP + PNG.

    But the macOS version is xx.09 instead of xx.10 on Windows.

    MacBook Pro | M1 Pro | Thrustmaster Airbus Captain Edition
    X-Plane 12 | ToLiSS A321/neo/LR/XLR A320neo | BetterPushback | X-ATC Chatter | FlyWithLua
    iPad | SimBrief/Navigraph | WebFMC

  • That has nothing to do with Windows updates. I guess the screenshots are now saved as bmp and png. Do you have the developer options enabled?

    Hello Jan - Thankyou for replying .I do not knowingly have developer mode enabled. This is what it says at the very bottom of the main.mcf:

    405 >

    <[bool][debug_show_log][false]>

    <[bool][debug_show_fps][false]>

    <[settings_developer][developer_settings][]

    <[bool][Enabled][false]>

    <[string8][DeepDeveloperMode][]>

    <[string8][SpecialDeveloperMode][]>

    <[float64][TimeLapse][1]>

    <[float64][IntegrationDeltaTime][0.001]>

    <[bool][ShowMonitoring][false]>

    <[vector4_float32][MonitoringPosition][0.0020000000949949 0.0020000000949949 0.400000005960464 0.300000011920929]>

    <[bool][PauseInDebugView][true]>

    >

    419 >

    Since AFS2 I have used reversed default screenshot settings, so that S gives me a screenshot without and Shift+S shows the overlays. both as bmp files. That has worked perfectly for years, until now. Apparently, using Win Key + Print Screen will create a png file. Possibly within AFS4 using the S key is generating two requests, which is why the tmlog only reports saving a bmp?

    MikeW

  • It's the same on my end, so it's intended behavior. Perhaps we can make the screenshot file extension optional in the future.

    Thanks Jan - I do most of my simming in NZ and post screenies in the NZFF Forum. I take what AFS4 gives me, and post-process to meet NZFF requirements, using Irfan View, before posting to Postimage as jpgs. So bmp or png does not matter, but there is no point in having pngs as well as bmps to start with.

    Many thanks for your help

    ATB, MikeW