Video issue after Mac RC7 update to 7.3.1

  • Hello,


    Today I've updated my Mac version of RC7 to the latest version 7.3.1.
    Now I have a video issue, it isn't as smooth as it was.
    There is a horizontal distortion in the picture when it is changing quickly.
    I've tried different settings (lowest video setting and window mode and different sceneries) without succes.
    Framerate stays 60.
    Before the update this never happened.
    Please help.


    Regards,


    iMac 27" 3,2 GHz Intel Core i5
    8 GB 1600 MHz DDR3
    NVIDIA GeForce GT 755M 1024 MB
    OSX 10.9.5 Mavericks

  • I am seeing the exact same thing.


    It's a horizontal tearing of the video. For me it happens on all airplanes and scenes.


    My spec's are:
    27" iMac
    2.9 GHz Intel Core i5
    24 GB DDR3
    NVIDIA GeForce GTX 660M 512 MB
    OS X Yosemite
    V 10.10.1


    Thanks,

  • It occurs on all sceneries, however less with the 4D's, and with all aircraft and in the lower part of the screen.
    The tearing gets worse when the video is changing faster (for example a fast fly past).
    I made a flight recording and when I pause the playback the distortion is gone.
    So I can't take a still picture of it :(
    I tried to make a screen capture movie of it with Camtasia but its not recorded :(


    TIA,
    Regards

  • I'm experiencing the same thing on both my Imac and my Macbook (Mavericks).
    I've contacted the support directly last week, and they send my request to the development team.


    Quote

    DanCooper
    I tried to make a screen capture movie of it with Camtasia but its not recorded


    The only way I found to show the problem was to take photos of my screen, because when I made screen captures, the "bug" didn't appear on the picture, I also recorded a flight with my camera where we can see the tearing of the screen.


    Hope they'll find why we're experiencing this ;).


    Macbook :
    2.9 GHz Intel Core i7
    8 Go 1600Mhz DDR3
    Mac OS X 10.9.5 ( Mavericks )
    Intel HD Graphics 4000 1024 Mo


    Imac :
    2.7 GHz Intel Core i5
    8 Go 1333Mhz DDR3
    Mac OS X 10.9.5 ( Mavericks )
    AMD Radeon HD 6770M 512 Mo

  • We were able to reproduce this issue "once". The strange thing is, that on the machine we used, the tearing effect all the sudden disappeared so we were no longer able to have a look at it.


    Our current assumption is, that it has to do with Mac OS X not syncing correctly to the monitor refresh rate.


    We will try to pin down the problem, but its still unclear whats causing this.

  • I have the exact issue on a Mac Pro.



    Processor 3.33 GHz 6-Core Intel Xeon


    Memory 24 GB 1333 MHz DDR3 ECC


    Graphics ATI Radeon HD 5870 1024 MB


    Software OS X 10.9.4



    Previously Aerofly RC7 ran perfectly on Ultra settings.



    Also:


    We will try to pin down the problem, but its still unclear whats causing this.


    I'm no software engineer, but since all things have remained equal hardware-wise, I suppose that if you compare the code from the previous version to the code of the updated version, you can see what has been added, what has been removed, and what has been altered.


    This should give you a good starting point from where to begin identifying what is causing the issue.


    Am I mistaken?

  • I'm also having the same problem on MacPro 3.1 8-core, on Mountain Lion 10.8.5.


    Have an AMD Radeon 5870 1Gb, which I thought might have been the issue with this, but on reading this thread, the problem seems to be with all configurations of Mac OSX.


    I've a newer Nvidia GeForce GTX 680 2Gb about to replace the Radeon this month (I want to get into the Cuda Core era of cards for Premiere & After Effects CC work), so I'd bet that'll probably not solve the issue either, but I'll report back if I see any differences using the Nvidia drivers, which unlike AMD Radeon can be loaded directly from Nvidia's software on Macs.


    Like the other guys, the problem with the video tearing on AeroFly RC7 v7.31 happens when you're doing fast, horizontal fly-bys with photographic backgrounds. It doesn't happen when you've the aircraft flying towards or away from the camera (in general).



    MacPro 3.1 - 8-core 2.8Ghz
    32Gb DDR2 FB-DIMM 800 MHz
    Nvidia GTX 680 2Gb
    OSX 10.85 Mountain Lion
    4 x BenQ GL2460 monitors at HD Res.

  • We are working on this issue, but it is a rather bizarre problem, that, on our side, occurs randomly. So we are not yet sure, how to fix it. We had a look at a previous version, but can't actually see a difference. Anyway, we are currently investigating it and will probably release a new version this month.

  • I also just upgraded and consistently getting the same video tearing vsync/vblank issue as the others are reporting since the upgrade to 7.3.1.


    I have a late 2012 27" iMac
    3.4 Ghx Intel Core i7
    16GB 1600 MHz DDR3
    NVIDIA GeForce GTX 680MX 2048 MB


    Running OS X Mavericks 10.9.2 with no plans of upgrading to Yosemite.


    I'm getting the video issue in 4D and or Panorama. It doesn't matter if it's in Low or Ultra graphics with/without smoke sun flares etc. It does seem to be worse when there is a lot of fast movement. Sitting still on the ground stationary there is less of an issue. Windowed or Full screen doesn't matter. I was in 2560 x 1440, then switched down to 1600 x 900 and the problem still exists. The issue is most noticeable in a horizontal band extending from the left edge of the screen to the right edge, roughly 25mm in height just above the heli blades. Hope this helps.


    Thanks,


    Greg Huntoon
    Muskegon, MI USA

  • We are currently preparing a new version for the Mac App Store. If Apple approves it, it will be online in around 1-2 weeks.


    We are still not clear whats causing this tearing, but its something we seem to have no influence on. It shows up randomly even though we basically use sample code from Apple. Anyway we rewrote our rendering loop and made some changes, so users can enable/disable VSYNC again. Lets hope this fix does correct the issue.

  • Hi, I'm also using Aerofly 5 and with VSYNC off the tearing is also visible like Aerofly RC 7! The tearing is much less but its there. In the scenery Venice Florida it is best visible (see the white fences and make a quick fly by). So introducing the VSYNC button again could solve the problem?


    Regards

  • I installed the new version 7.3.3 that became available via the apps store today and for me the video tearing is gone. I flew with some of the same aircraft and scenes that were giving me issues before the upgrade and haven't seen the problem again.


    MohawkTO

  • I've installed it, and it seems that the tearing disappeared for me too, when I activate the VSYNC.
    I haven't tested every sceneries and planes, but I think that the "bug" is fixed now, and it's much better without the tearing, thank's IPACS ;) !