vsync gives stutter + solution

  • When the vsync is on in-game it gives stutters, especially with a lot of cumulus clouds. Without vsync I have 120+ fps with off course some tearing of the screen. Even with cumulus clouds at highest I don't get any stutter. So my pc has no problems with the game. It is the vsync.

    The solution that I have found is to use a framerate capper (I use rivatunerstatisticsserver) in combination with vsyns. I played around with this for a while and found out that when I use vsync and set the cap for fps on 60 I get smooth game play without any stutter even on ultra with all the clouds in the sky possible.

  • Adaptive vsync in graphics cards allows free graphics card frame rates below the screen's natural frame rate and blocks any frame rate from happening higher than the screen's native frame rate. It is on the graphics card menu and I turn off vsync in FS 2. It is a cheaper alternative to NVIDEA g-sync.

  • Hi! First of all thank you very much Virtual Glider cause your tips works and works great ! Rivatuner (part of msi afterburner i downloaded) do the job : caping framerate makes stutter with full cumulus disappear when using ingame vsync, even if monitoring the game shows no higher framerate than 60 without caping. In my experience i have to limit framerate to 62, cause less than that makes tearing appear (my screen : asus vs278q - my rig : i5 4460 16 gb gtx 970)
    But when flying over big city like San Francisco or Vegas with full cumulus makes tearing appear with vsync on and framerate limited to 62 - in my experience the best result i obtain is by activating vsync in nvidia panel / shutting down ingame vsync / and caping framerate to 60.
    In this case i have no tearing at all and stutter limited to minimal.
    Cheers and thanks again !
    Oh! and a question : do you have the same "problem" than me in the way you can't activate "on screen dispay" in rivatuner cause it makes the game crash ?

  • Confirmed, Vsync works fine until clouds are invoked. I hope Ipacs takes a look at this ASAP.

    Devons rig

    Intel Core i5-13600K - Core i5 13th Gen 14-Core (6P+8E) @ 5.5Ghz / G.SKILL Trident Z5 RGB Series 32GB RAM DDR5 6000 / GIGABYTE GeForce RTX 4070Ti GAMING OC 12G / Sound Blaster Z / Oculus Quest 2 VR Headset / Klipsch® Promedia 2.1 Computer Speakers / ASUS ROG SWIFT PG279Q ‑ 27" IPS LED Monitor ‑ QHD / 6x Samsung SSD/NVME's various sizes / Windows 11 Pro 64-bit / GIGABYTE Z790 AORUS ELITE AX LGA 1700 ATX Motherboard DDR5

  • Hi, another thing i recently discovered : forcing triple buffering in nvidia control panel boost the performances ingame.
    Actually i run : vsync and triple buffering in nvidia control panel, 60 fps limit in Rivatuner, no ingame vsync - the result is, with ultra options and full clouds and flying over san Francisco, a good 60 fps with really few stutters and near imperceptible few fps drop. (before that fps drop was really noticeable in this "worst case" situation for performances)
    In nvidia control panel, global settings of 3D settings, i also put "1 screen performance mode" and "max performances" in management of powering mode (don't know if it's the right traduction from french....) that may have also an impact.