(Auto-)Rudder problem after latest update

  • Aerofly FS2 was working very nicely with my setup (Saitek rudder, Warthog HOTAS), now updated after a week of absence, betas activated. Update included Jul 22 and Jul 27 updates.


    Since that update it looks like some kind of faulty autorudder function is kicking in. I get a full rudder input immediately after lift-off, making some aircraft almost uncontrollable. My rudder is working on the ground, but unable to override that input in the air. To reproduce, just take off and try to fly a circle.


    I did:
    - assure autopilot is off
    - check my controls, tested rudder on other flightsim
    - reset to default settings and re-entered control settings
    - removed all wind/weather (used higher wind setting before)
    - tested several aircraft
    - restarted aerofly FS2 several times


    The behaviour is definitely new after that latest update. The description said:
    "- Fixed rudder assist / autorudder turned off "
    ...so that's my suspect. Does anybody have an idea how to turn on/off that rudder assist function? Or any other idea/help?


    Kind regards

  • I found out about the controller set-up change after going off the runway!, no manual rudder. Must do proper pre-flight checks in the early release phase, it is a bit like in real life, having maintenance done without being told. No more kick the tires and light the fires.

  • Dear IPACS-Team, thank you! I just like to confirm it's solved for me as well.


    Here is just another new observation, I'm adding it to the same thread as it "feels" related and might be solved as quickly:
    The FPV (flight path vector) in the general HUD view is way off. It's somewhere around -25 deg, invisible most of the time. It looks good however in the F-18's HUD.