Export Failure with Kingman Airport Tutorial

  • Hey all,

    I just went through the tutorial, exported the files from 3DS Max (2014), saved the originals from the pack into a folder, exported my own, then when I run the scenery content converter, it turns on for a second, then its gone. Maybe half a second. When I look in the folder where it should be, the Kingman airport folder appears in the 'places' folder, but nothing is inside the folder.

    I then put all of my exports into a folder, pulled out the factory tutorial files (TGI files, TSC) and tried exporting, same thing. Blip, gone, no files.

    Has anyone tried the Kingman export?

    This is my content_converter_config.tmc

    Is there something I might be missing? I tried both the BAT and the content_converter_config.tmc, both blip. No files.

  • Hey Jan,

    I looked around for the tm.log, found it in the converter folder for scenery.

    Amazingly, it says there was no content_converter_config.tmc in the package. There is. Unless its supposed to be outside of the kingman folder.

    Here is what the config says. This is stock.

    and this is what it says on the tm.log:

    The content_converter_config.tmc is in the kingman folder.

  • I'm not as up to date with the scenery sdk but according to the wiki: https://www.aerofly.com/aerofly_fs_2/d…g_the_converter
    You should right click on the 'content_converter_config.tmc' file (inside the kingman folder) and then select the context menu entry 'Run with Aerofly FS 2 Content Converter'... Otherwise the converter wouldn't know what to convert and throws the log error seen above.

  • Hey Jan,

    I did that. I also tried the BAT file starter.

    With the scenery content compiler, you do not right click on the folder, you right click on the config inside the folder. The aircraft converter is 'right click on the folder and select option to fun aircraft converter' (I know you know, but for others that might be reading this).


  • Hello all,

    I just tried to export the Oceanside airport that also comes with the SDK, and that too is not exporting. I am using the stock files that came with the SDK, not exported from Max.

    Same Error; 'Content_Converter_Config.tmc not found'

    Could the top of the TMC config be missing something? It did create a Oceanside scenery folder in the proper location, but with nothing in it. So it did make the folder. But nothing else is done. And this is with starting it by right clicking on the config.tmc and running the content converter, and also by clicking on the BAT file, which does the same thing. Instant blip, then nothing. Folder is generated in 'places' folder in My Documents......., but no files.

    This is the TMC file that is for Oceanside;

  • lionheart,
    I doubt that anything I add here will help, but here goes (sorry for your frustration - everything works for me)
    - by looking at your files, I don't see any real changes except the following:

    1) in C:\Users\username\Documents\Aerofly FS 2 Aircraft Converter there is a file called config.tmc and I had to add a line for user folder or desktop folder - forgot which:
    <[string8][UserFolder][C:/Users/username/Documents/Aerofly FS 2/]>
    <[string8][DesktopFolder][C:\Users\username\Documents/Aerofly FS 2/aircraft]>

    I thought this was needed just for aircraft content though - have you made that change ? (NOTE: username = Your own username, of course)

    2) I also thought that maybe you should just use the default for the new folder entry:
    <[string8][base_output_folder][]> // if this is empty it defaults to "C:/Users/USERNAME/Documents/Aerofly FS 2/"

    but I see that didn't help with kokb_oceanside:

    3) Hope you have the latest SDK (Feb 14,2017) (Probably you do if you have kokb_oceanside. Maybe go to the Control Panel ->Programs and uninstall both the Aircraft and Content Converter, unzip the SDK(maybe download it again??), reinstall the Aircraft and Content Converter, add that change to config.tmc in the Aircraft Converter directory, delete any scenery\places\kokb_oceanside folder and try again - ONLY use the convert_kokb_oceanside.bat approach

    4) Make sure you are using Notepad++ not just notepad

    Keep trying and keep us posted! Get KOKB_Oceanside to work first


  • Hey Dave,

    Many thanks for your input.

    The scenery content system is separate from the aircraft content system. My aircraft system is running proper, though I cannot get my plane to export presently.

    But with the contect converter, its just not even working. It creates the folder but no parts in it. It flashes on and off. Done. The tm.log states it has on config.

    I checked the config, its there, so is the BAT, both run, both stall, flash on and off.

    I have my user folder setup, and it knows where to put the new scenery folder as that is created during the flash event, but nothing else.


  • Hello Bill,

    I tried to replicate your problem and run the conversion of kokb_oceanside. Just with the stock data as you did. Rightclick the content_converter_config.tmc in the data folder: Everything fine, no errors in the tm.log. Also the TMC file you posted is exactly the same to mine.

    I remember there was a problem with an early SDK package. Please try to download it again. Perhaps you still use this outdated version?

  • I also recommend team viewer for this sort of thing. It's very effective for sharing someone's screen and taking control of their mouse and keyboard - when allowed of course. Security is strong and its a free download for non commercial use. Much better than Skype.

  • Roger that. I didnt know it could screenshare. I'll look into getting it.

    Actually, the free trial should be long enough for you guys to clear this up........

    Devons rig

    Intel Core i5-13600K - Core i5 13th Gen 14-Core (6P+8E) @ 5.5Ghz / G.SKILL Trident Z5 RGB Series 32GB RAM DDR5 6000 / GIGABYTE GeForce RTX 4070Ti GAMING OC 12G / Sound Blaster Z / Oculus Quest 2 VR Headset / Klipsch® Promedia 2.1 Computer Speakers / ASUS ROG SWIFT PG279Q ‑ 27" IPS LED Monitor ‑ QHD / 6x Samsung SSD/NVME's various sizes / Windows 11 Pro 64-bit / GIGABYTE Z790 AORUS ELITE AX LGA 1700 ATX Motherboard DDR5

  • Since reinstalling the SDK / Scenery Converter, I no longer get a tm.log error, but I still get no airport. I was just looking at my log and found that the error is gone, but when I click the convert, the exporter still runs for a half second, like a flash, and only the kingman folder is produced in the 'My Documents.......places' folder. I deleted the kingman folder and ran it again, it shows up fine.

    I was reading in the ReadMe in the DLL sample folder, it states I must have Microsoft Visual Studio 2015 to run an outside dll, (if I am reading that correctly). So do you think I need Microsoft Visual to run the scenery converter also? Is there a way to see if I have that on my computer? (Sorry I am so computer illiterate at times. I only build models).


  • Hey Jan,

    I have the file 'content_converter_config.tmc' in the folder. Do I rename it? I didnt read that it should be renamed.

    If I run the BAT file, it does the same thing; flash start of DOS window, 1/2 second, no files generated.

    Here is the data on the content_converter_config.tmc;


    <[string8][base_output_folder][]> // if this is empty it defaults to "C:/Users/USERNAME/Documents/Aerofly FS 2/"


    <[list_string8][file_types][tsc tgi jpg bmp tif png ]>


    From what I understand, I start the BAT file or the content_converter_config.tmc file inside the kingman scenery folder. There is no config in the scenery converter folder (the converter files that are in a separate folder). Only DLL files.

    I have tried putting in my location for the target, the default location for files to go to. That did nothing. Also, I know the converter knows where they go because it creates a new 'kingman' folder where it should be, so that is running fine.

    I think it needs a name/target to run through the converter.... For instance, it has no input.. only ./
    Shouldnt it have a input file name, like kigm_kingman?

  • Hi Bill,

    No, the input is the local directory from where you execute the converter or start the batch.

    Lets recap, have you completed these steps?

    • Aerofly FS 2 content converter has been installed (after installing the SDK)
    • there is a folder with the exported 3D model (.tgi) and textures in tif or bmp format 2^n size,
    • the name of the folder "YOUR_AIRPORT" has no spaces, no special characters
    • the folder name is identical to the file name of the YOUR_AIRPORT.tgi file that the converter takes in
    • *the content_converter_config.tmc has the output_folder property set to scenery/places/YOUR_AIRPORT/
    • the base_output_folder property in the content_converter_config.tmc is empty (default)
    • the convert_....bat file content has not been edited (still says
      "%ProgramFiles%\Aerofly FS 2 Content Converter\aerofly_fs_2_content_converter.exe" content_converter_config.tmc

      as a command)

    • the folder C:\Users\...\Documents\Aerofly FS 2\scenery\places exists and it is not protected by and read/write permissions (otherwise maybe try launch the batch file as administrator)

    *I'm guessing you have missed that option or didn't we mention it?

    If yes I have no idea where the mistake could be. If the tm.log does not throw an arrow like "content_converter_config.tmc" not found, then the converter should have the needed files.