Having trouble with the new geoconvert tool; Please Read

  • Ich vertsehe nur Bahnhof...

    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • okay in Deutsch...smile...

    Wenn ich ein Gebiet von der Größe 50NM mal 50NM mit dem Geotool generieren lasse, dann nehme ich zwischendurch

    aus dem Verzeichniss die generierten Dateien heraus und speichere diese direkt im Scenery Ordner ab.

    Hier die ttc Files.

    Nach einer Weile mach ich das wieder.

    Nur das dann Windows sagt, das diese ttc Files schon existieren würden im Scenery Ordner !

    Ich mach das ...wegen der Größe der Dateien...nur um beim hin und her kopieren später, schneller zu sein.

    Alles auf einmal kopieren ist ja schon ne Menge bei 50NM mal 50NM.

    In soweit auch wirklich wahr, kann ja die vorhandene ttc Datei belassen und die neue wird mit neuem Namen rein kopiert.

    Somit existieren dann zwei identische ttc Files im Scenery Ordner, nur das Sie unterschidelich bennant wurden.

    Beispiel: Map13_58228_aa3.ttc und der zweite dann Map13_58228_aa3(2).ttc

    Kommt jetzt Windows nicht mit den ttc Files klar, weil Win meint es wären Schriftdateien?

    Oder ist das ne fälschliche Meldung von Win ?

    Denn, egal ob ich alles generieren lasse, von 9-13 oder nur die 13ener Level, die anzahl zB. für Level 13 bleibt gleich. 1260 Dateien.

    Des weiteren, wieso macht GEO Tool eigentlich die BMP Files doppelt ?

    Da schreibt das Tool die BMP Files vom FSET Tool gleich nochmal in sein eigenes Verzeichniss obwohl die bei FSEt doch schon vorhanden.

    Was für eine Platzverschwendung !

    Und die BMP Files sind absolut identisch..... und genau die brauchen unheimlich viel Platz auf der Platte.

    Und dann belegt Geo auch noch den kpl. Ram hier 16 GB vom System.

    Kann man das irgendwie begrenzen?!?!



  • If I'm understanding this correctly you can't run different levels separately for the same project. You need to add the levels that you want in your scenery prior to running the converter. You also can't run bits and pieces of the same area at different times unless you completely make different folders for each area.

    To summarize here, once you run the geoconvert tool for an area you have to run the entire area unless you make each run separate, which means they go into different folders for each area.


    1) define an area and add your levels to the project file

    2) run the geoconvert tool for that area

    3) place the results of the completed job into its own folder

    4) place the folder into your documents\aerofly fs 2\scenery \images folder

    If you follow these steps you won't have duplicates.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.



  • Hi everyone, new user here.

    I'm Having trouble with geoconvert. It's not writing anything under scenery/

    My geoconvert folder copied here:

    Please help.


    Hi Tomek, I took a quick look at your files. I think it's a combination of a couple things:

    (1) In your .tmc file, you have mask files globally disabled with the line at the top:

    <[bool] [write_images_with_mask][false]>

    I'm pretty sure this overrides whatever comes below it in terms of enabling or disabling masks.

    (2) Your downloaded imagery from FSET doesn't completely cover an AeroFly tile of any level up to level 13, and since mask tiles are disabled, geoconvert won't write any output at all.

    To further explain, AeroFly has its world map sliced into a grid, and the size of the grid cells get smaller with each increasing 'level' (level 9 is a large grid cell, level 15 is a small grid cell). If your source imagery doesn't completely cover one of these grid cells when you try to convert it, no output will be written unless masks are enabled. If masks are enabled, it will write a partial tile and a second mask file that goes along with it, which 'blocks out' that part of the tile in AeroFly.

    It's a good idea to disable masks when using geoconvert as much as you possibly can. The reason is that masked tiles will make it hard to ever add more scenery around your converted area unless you manually go in and delete the masked tiles later, which can be quite a hassle. This is because those areas that get 'blocked out' by the masked tiles will be permanently blocked out until the mask is deleted. This means you also have to regenerate the file that went with the mask too, or you'll have black stripes appearing in AeroFly.

    The best way to address this is to start with a downloaded imagery area which is already snapped to AeroFly's grid. Then you won't have to worry about enabling mask tiles and you know that your FSET imagery will fully fill AeroFly's grid cells. There are two tools we've created to be able to do this here, one which shows you the cells in Google Earth and another that uses Excel which will calculate the coordinates for your directly and you can copy/paste them into FSET. You can find both tools here:

    Excel tool Image tile coordinates

    Google Earth tool Image tile coordinates

    And there is some more explanation/discussion about this in this thread, starting here and read through to the last page:

    Scenery Loading Distance

  • qwerty42, thank you very much. I loaded a bigger area, changed the mentioned variable and it worked. Love the result!

    btw. the Extra model is closest to reality I have found. I tried P3D and X-Plane but they won't do anything outside of normal flight envelope (snap rolls, flat spins, etc.) Great job FS2 team! Thank you so much.

  • In testing GeoConvert 1.4.3 with AeroScenery I frequently see the following issues

    1) The UI will not show any progress even though files are being written. It appears stuck at 0.000% / Level 1 of 2 / Tiles 0 of 16 etc

    2) If (1) occurs it will complete all tasks, then show num tiles 0 of 0, not the green success text. It will then (according to the log) start processing everything again but doesn't write anything (according to the file timestamps).

    3) If (1) didn't occur it will sometimes complete all tasks then go back to the beginning and start overwriting everything again

    4) The number of tiles shown in the UI is usually wrong. The actual number being output is shown in the log.

    (Log and tmc file attached. You can see on line 96 of the log how it started again)

    Also, in case anyone from IPACS reads this, there are two features that would help with AeroScenery

    1) A TMC file setting to make GeoConvert exit when done

    2) A TMC file settings to make GeoConvert also output the log to std out and write a log entry for each tile written

  • Most common reason is entering coordinates in the wrong order. We use lon/lat which is east/north. But if you use Google maps for example it gives you lat/lon. So you need to flip the coordinates around. Only then will the area line up with the images and the geoconvert should create images.

    You should also take a look at AeroScenery.