Posts by Republic DC-9

    Thanks for the post Ken. Nice end result.


    My "end of year" aim is that AeroScenery will do all of this within the one app (plus higher resolution elevation data too).

    Hi Nick - will the USGS source option be incorporated as well?


    And not sure if it’s already on your list, but some way of keeping the stock AFS2 water except close to the shorelines would be nice...I always end up with “white” water where the Orthoimagery doesn’t include water, or maybe there is already a way around that issue.


    A great tool you’ve developed, thank you!


    Steve

    Me too, John.


    I’ve not even tried the helicopter yet but was inspired by all the work done by others in the area of cultivation/autogen and that those efforts are beginning to be shared.


    It look me some doing and lots of help from Rodeo and others on this forum, but I just shared my own contribution to this effort.


    Orbx led the way with add ons and I hope other developers and users will come to realize just how smooth this sim is and develop other add ons (including planes) for it.


    Steve

    Never mind, I got it!


    I had to remove the ICAO line for the airport from your .tsc file, now I have a lot of autogen and it looks nice.


    Once question though - my autogen only contains major buildings from OpenStreetMap, not a lot of buildings like houses etc. like in the San Francisco package? Is there a better source for creating the .toc file that would create more buildings?


    Thanks,


    Steve

    Your file works GREAT!!! Autogen everywhere I wanted!


    Thank you!


    One small problem though - my KSNA airport itself is gone? No little green airport dot on the location map at the start screen, and no airport buildings even though the area is surrounded by autogen?


    Thanks again for your help...we're almost there and I'm learning a lot!


    I really want to help populate the AFS2 world with autogen like you did for San Francisco - such a huge addition.


    Steve

    Hi guys - sorry was traveling - created a .tsc file based on your .tsc file as follows Kai - still not working.


    Coordinates are approximate (Are they important)?


    Both .toc file and .tsc file are named ktsc_1.tsc and ktsc_1.toc, the runway.mdb file is in place and building_textures folder is in place, all within a folder with path as follows...


    C:\Users\colby\OneDrive\Documents\Aerofly FS 2\scenery\places\US\KSNA Area


    Thanks again all...if you spot any errors let me know please - really want this to work so I can begin help creating sceneries that can be shared with others so we all can have more autogen.


    Steve



    <[file][][]

    <[tmsimulator_scenery_place][][]

    <[string8][type][airport]>

    <[string8][sname][.]>

    <[string8][lname][.]>

    <[string8][icao][ksna_area]>

    <[string8][country][us]>

    <[string8][coordinate_system][lonlat]>

    <[vector2_float64][position][33.7 117.5]>

    <[float64][height][0]>

    <[float64][size][50000]>

    <[vector2_float64][tower_position][33.7 117.5]>

    <[float64][tower_height][5]>

    <[bool][autoheight][true]>

    <[string8][autoheight_method][]>

    <[list_tmsimulator_scenery_object][objects][]

    <[tmsimulator_scenery_object][element][0]

    <[string8][type][object]>

    <[string8][geometry][runway]>

    <[vector3_float64][position][33.7 117.5]>

    <[float64][orientation][0]>

    <[int32][autoheight_override][-1]>

    >

    >

    <[list_tmsimulator_scenery_object_animated][objects_animated][]

    >

    <[list_tmsimulator_runway][runways][]

    >

    <[list_tmsimulator_startposition][start_positions][]

    >

    <[list_tmsimulator_parking_position][parking_positions][]

    >

    <[list_tmsimulator_view_position][view_positions][]

    >

    <[list_tmsimulator_scenery_cultivation][cultivation_files][]

    <[tmsimulator_scenery_cultivation][element][0]

    <[string8][filename][ksna_1]>

    <[string8][building_textures_folder][building_textures/]>

    <[bool][auto_height][true]>

    >

    <[tmsimulator_scenery_cultivation][element][1]

    <[string8][filename][ksna_1]>

    <[string8][building_textures_folder][building_textures/]>

    <[bool][auto_height][true]>

    >

    <[tmsimulator_scenery_cultivation][element][2]

    <[string8][filename][ksna_1]>

    <[string8][building_textures_folder][building_textures/]>

    <[bool][auto_height][true]>

    >

    <[tmsimulator_scenery_cultivation][element][3]

    <[string8][filename][ksna_1]>

    <[string8][building_textures_folder][building_textures/]>

    <[bool][auto_height][true]>

    >

    >

    >

    >

    Hi Guys -


    I managed to successfully (I think) create a .toc file for a small area around KSNA airport using Rodeo's workflow, but my autogen is not showing up.


    The following are in my Aerofly FS2/scenery/places/US folder -


    building_textures folder in place.


    runway.tmb file is in place.


    My newly created .toc is in place.


    And a modified .tsc file is in place.


    I'm very suspicious that my .tsc file (which I modified from another scenery) isn't correct? Somewhere I've missed the part of the workflow where the .tsc file is created, I think.


    Where should that come from, and what modifications need to be made in terms of adding latitude, longitude, etc. and where do those numbers come from?


    I'm not doing an airport scenery per se, I'm trying to learn the workflow to create autogen AROUND airports (or anywhere else).


    Thank you for any help - am very anxious to learn this process.


    Steve


    Modified .tsc file code is below...among other issues I'll bet my incorrect longitude and latitude are an issue?


    <[file][][]
    <[tmsimulator_scenery_place][][]
    <[string8][type][]>
    <[string8][sname][KSNA]>
    <[string8][lname][KS]>
    <[string8][icao][]>
    <[string8][country][]>
    <[string8][coordinate_system][lonlat]>
    <[vector2_float64][position][-118.4374 33.6842]>
    <[float64][height][0]>
    <[float64][size][5000]>
    <[vector2_float64][tower_position][0 0]>
    <[float64][tower_height][0]>
    <[bool][autoheight][true]>
    <[string8][autoheight_method][]>
    <[list_tmsimulator_scenery_object][objects][]
    >
    <[list_tmsimulator_scenery_object_animated][objects_animated][]
    >
    <[list_tmsimulator_runway][runways][]
    >
    <[list_tmsimulator_helipad][helipads][]
    >
    <[list_tmsimulator_startposition][start_positions][]
    >
    <[list_tmsimulator_parking_position][parking_positions][]
    >
    <[list_tmsimulator_view_position][view_positions][]
    >
    <[list_tmsimulator_scenery_object][objects][]
    <[tmsimulator_scenery_object][element][0]
    <[string8][type][ground]>
    <[string8][geometry][runway]>
    <[vector3_float64][position][153.11 -24.40 -10]>
    <[float64][orientation][0]>
    <[int32][autoheight_override][-1]>
    >
    >
    <[list_tmsimulator_scenery_cultivation][cultivation_files][]

    <[tmsimulator_scenery_cultivation][element][0]

    <[string8][filename][map]>

    <[boo1][auto_height][true]>

    >

    >

    >

    >

    I also tried the following modified .tsc file, to see if that worked (it didn't)…


    <[file][][]
    <[tmsimulator_scenery_place][][]
    <[string8][type][]>
    <[string8][sname][KSNA]>
    <[string8][lname][KSNA]>
    <[string8][icao][]>
    <[string8][country][]>
    <[string8][coordinate_system][lonlat]>
    <[vector2_float64][position][-118.4374 33.6842]>
    <[float64][height][0]>
    <[float64][size][5000]>
    <[vector2_float64][tower_position][0 0]>
    <[float64][tower_height][0]>
    <[bool][autoheight][true]>
    <[string8][autoheight_method][]>
    <[list_tmsimulator_scenery_object][objects][]
    >
    <[list_tmsimulator_scenery_object_animated][objects_animated][]
    >
    <[list_tmsimulator_runway][runways][]
    >
    <[list_tmsimulator_helipad][helipads][]
    >
    <[list_tmsimulator_startposition][start_positions][]
    >
    <[list_tmsimulator_parking_position][parking_positions][]
    >
    <[list_tmsimulator_view_position][view_positions][]
    >
    <[list_tmsimulator_scenery_cultivation][cultivation_files][]
    <[tmsimulator_scenery_cultivation][element][0]
    <[string8][filename][KSNA]>
    <[string8][building_textures_folder][]>
    <[bool][auto_height][true]>
    >
    >
    >
    >

    I've had Aerofly FS2 for over a year now - but rarely use it, even with Orbx add ons that run like silk on the platform.


    I've started playing with "AeroScenery" and generated a very nice looking Anacortes, WA area tile - except for the water.


    I'm still lost in "Ortho4XP" world, it seems, with water masks and dynamic water (for now at least).


    How does one deal with these "white" areas, where there is evidently not water in the pictures so it shows white?


    Does one go into each .png, and then hand-color the water before generating the .ttc files?


    Do you stop the process before the .ttcs are made, or re-do the process partway through, etc?


    I see files that say "mask" but something didn't work - or the tool is still limited at this point (no offense - it clearly has SO much potential - flying at like 200 FPS over scenery THIS crisp is insane and I'm keenly interested to learn more about AFS2 after all this time).


    Maybe I'm missing workflow someplace - am mostly eager to do Wisconsin, but it, too, has Lake Michigan bordering it so I'll have to deal with "Water".


    Thanks,


    Steve

    I am really starting to love AFS2 - so SMOOTH, so bright, so crisp!


    Two questions...


    1) For some reason, the nice 085 Benton, CA airport included in the Orbx Redding package is missing even though most California airports are included.


    What tools/workflow would I use to make one and share it (unless someone good at this can quickly whip one up?)


    2) There is plenty of tree autogen, is there a way to create cultivated autogen buildings for large areas?


    Thanks,


    Steve

    Some good news!


    I uninstalled my Steam program (along with AFS2 accidentally) then re-installed Steam then AFS2 and I'm back up and running!


    Still need to re-install Orbx sceneries and download the (thank you!) complimentary Utah, Colorado, Q400 etc.


    But good so far!


    Phew...thanks for your help, I shall use Steam to create backups, just in case this happens again.


    Steve

    Is anything else acting up on you?


    Try to unplug all USB devices that you have plugged in and run Aerofly. See if it opens.

    I thought of that too...no dice...black screen.


    My only other Steam game, a pinball sim, launched fine.


    Tried uninstalling the 2 Orbx add ons thru FTX Central...no change.


    Then I was trying to reinstall the Steam client and I inadvertently uninstalled all my AFS2 stuff! (Facepalm!).


    So I'll be ready to try more fixes in 12-15 hours. :)


    What's weird is there were no other changes I made to the PC except an Orbx libraries update thru FTX Central AND Windows 10 did an update of some kind between the last successful launch and now? P3Dv4 and XP11 are working ok somthe PC and graphics card are working OK.


    Thanks,


    Steve

    Hi Jeff -


    My driver is Nvidia 388.59 12/7/17 version and I had the problem before and after updating the driver.


    All graphics cards settings are set to the default values for Steam.


    My TM is attached as a .txt file here....


    Thanks!


    Steve

    Files

    • tm.log.txt

      (15.18 kB, downloaded 115 times, last: )

    I was loving my new simulator...the HD pack, Colorado, Utah, the 2 Orbx sceneries.


    But I tried to launch today and the screen goes black...a small Geforce Experience logo appears in the upper right then disappears, then that's it...all black..can't launch.


    I updated my Nvidia driver just in case...no luck...tried launching from Steam and the .exe, same result. :(. No error messages just....all black.


    No changes made to the PC etc. but it said it was doing a Steam update before the first fsiled launch.


    Help please...I miss it already.


    Thanks,


    Steve


    I76700 4.0 Ghz, GTX 1070 8GB, 16MB RAM, Windows 10

    Files

    • tm - Copy.txt

      (15.09 kB, downloaded 128 times, last: )