Objekts in a row .... form wavy stairs. :( ( objekts from 3ds max )

  • Hi!


    I have a problem:


    I have build any objekts via spacingtool along a spline in 3ds max in a row in the same height.


    In Aerofly they are now building stairs in waveform - but why? X(


    Scriptproblem? :/


    I have no errormessages! ?(

    3,9 Ghz, RTX 2080 Ti, 32 GB RAM, Oculus Rift CV1, PIMAX 8K X, RotoVR, HOTAS and Flight Rudder Pedals, Win10, 3ds max

  • Schnuffelduffel

    Changed the title of the thread from “Objekts in a row .... form wavy stairs. :( ( windows objekts from 3ds max )” to “Objekts in a row .... form wavy stairs. :( ( objekts from 3ds max )”.
  • Could you please show pictures to illustrate your issue ?


    I would suspect individual autoheight calculation issue for your series of objects. If that's the case there are 2 methods :

    1) either merge your series of objects into 1 single object, i.e. 1 single autoheight calculation

    2) or set autoheight_override = 0 in your tsc file and manually adjust the Z coordinate of object placement to the absolute ground altitude in meters (use the dev cam with CTRL+F1 to estimate it)


    Cheers


    Antoine

    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • This was the problem ( not the original object ;) - no spoiler! ) :



    1) either merge your series of objects into 1 single object, i.e. 1 single autoheight calculation


    Yes, that was my first though too, but i became first a little trouble whith textures ( problem fixed ) and i have it now attached to the main object. Now it's ok. :)


    Btw., another question: My object has a normal Textur in a simple diffuse slot. But in Aerofly she's looking like a little selfilluminatet - is that correct - should it be so? :/

    3,9 Ghz, RTX 2080 Ti, 32 GB RAM, Oculus Rift CV1, PIMAX 8K X, RotoVR, HOTAS and Flight Rudder Pedals, Win10, 3ds max

  • I'm not entirely sure but I think If an object in Aerofly doesn't have a specular texture it will have a "standard" specularity which makes it look shiny. You could try to create a completely black texture and use it as a specular map and see if the shinyness is gone.

  • You could try to create a completely black texture and use it as a specular map

    If i try this, MCX say: "Your main texture have no geometrie" - and this is wrong error message and in Aerofly i see the object only in black color. If i control all settings in 3ds max and render it: All settings and ID-Channels are correct and was corect rendered. If i clear the black-specular.map again, i have no problems...:/?(

    3,9 Ghz, RTX 2080 Ti, 32 GB RAM, Oculus Rift CV1, PIMAX 8K X, RotoVR, HOTAS and Flight Rudder Pedals, Win10, 3ds max

  • Each time I used a specular texture on an object, I had to add a specular alpha counterpart otherwise the converter would fail to work.


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 3.20GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.