Dual Rates Not Acknowledged

  • Hi All,


    I'm just a newbie to aerofly RC8 and I'm hoping you can point me in the right direction. I've installed aerofly RC8 on my 2019 iMac. That went great.


    Before running it I got my Spektrum DX6 talking to the iMac with the Spektrum WS2000 USB dongle. Held down the bind button on the dongle, inserted it into the iMac USB port, held down the bind button on the DX6 and turned it on. Easy Peasy - they talk to each other.


    Then I started up aerofly RC8 and went through the setting up of the DX6. All seemed to go OK. Picked the Addiction for the A/C and off we go. Again all went well but I noticed that the program doesn't seem to be picking up the dual-rates. On the DX6 I set it up with 50%, 75%, and 100% throws on all three axes to see how it would fly. But all it seems to do is be the same throws no matter what the dual rate is set to.


    Please help to point me in a direction to get the rates honored by aerofly RC8.


    Many Thanks,

    Bob

  • Personally I skip all dual rates and just apply Expo to all my controller surfaces with advanced controller settings. Applying 30% expo is about equal to 50% rates around centre stick but still allows full travel at full stick positions.


    Your ws2000 dongle only supports 8 channels so you may need to make some changes in your dx6 Tx in order to honour some switches/axsis commands. Maybe have a look/google ws2000 setups with Realflight RC sim. These should be similar to what you may need to do with RC8.


    I use a usb Spektrum Interlink dx controller with my win10 pc and this works very well with rc8. Not sure if it would work with a mac or not though. I have used a ws1000 dongle (older version of ws2000 but no real difference) in the past with my dx18 tx but found this a pita to setup and use.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac rtx 3090, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd, corsair gold 750w psu, Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Vive Pro w/etsty gear VR lens mod, and Quest 1+2 (w/Link and wireless w/VD and Air Link). Asus VG248QE external 1080p 144hz gaming monitor.

  • Personally I skip all dual rates and just apply Expo to all my controller surfaces with advanced controller settings. Applying 30% expo is about equal to 50% rates around centre stick but still allows full travel at full stick positions.


    Your ws2000 dongle only supports 8 channels so you may need to make some changes in your dx6 Tx in order to honour some switches/axsis commands. Maybe have a look/google ws2000 setups with Realflight RC sim. These should be similar to what you may need to do with RC8.


    I use a usb Spektrum Interlink dx controller with my win10 pc and this works very well with rc8. Not sure if it would work with a mac or not though. I have used a ws1000 dongle (older version of ws2000 but no real difference) in the past with my dx18 tx but found this a pita to setup and use.

    Hi Tom,


    Finally solved the problem. The correct and EASY solution is as follows:


    1. Setup ALL dual-rates and expo(s) on your TX before "aerofly RC8" ever gets to see it.


    2. Set all (Aileron, Elevator, Rudder) surfaces to 100% throw on your TX (expo doesn't matter) before "aerofly RC8" ever gets to see the TX.


    3. Now when you "Calibrate" your TX you will be showing it 100% throws for all surfaces. Do NOT show it your Flight Modes or Rate(s) switch.


    You are now doing all your dual-rates and expos from your TX, and NOT by "aerofly RC8".


    Works great!

    Bob