Reverse Thrust not Working

  • Hey everyone,


    I have been using Aerofly FS 2 for years, and it's been an excellent simulator and way ahead of its time. However, in the past few weeks, I have come across a bug that has made it pretty much impossible to enjoy flying. When I land and try to deploy thrust reversers, they don't move at all; in any airplane. I use a Honeycomb Bravo throttle quadrant, and when I assign "thrust reversers" in the settings menu and assign a button, it seems to activate. The key lights up when I click it, which makes no sense as to why it does not work in the sim. I use a pro-flight yoke, and I read a forum post from a few years back that says to disable and re-enable the yoke in the settings, which should fix the issue. I disabled the pro-flight yoke and tried to use reversers, and it worked! However, re-enabling pro-flight yoke disabled reverse thrust again. I've also tried assigning thrust reversers to a keyboard key, which did not fix anything either.


    Any help would be appreciated!


    Adan