Stick X possible weird bug

  • Hello,

    I have a friend that i give remote support and he also have this AFS4 with a TM T. Flight Stick X, he used some buttons (on the base of the stick on the left side) to open and close flaps and also close and open Airbrakes. They are only assigned to that functions and don't have duplications, so NO multiple assigns to the same functions neither use the TwinJet neither QuadJet assigning.


    -The flaps are fully open if i press and hold the button. If i do a short press they move a bit and then auto return to close. They are always trying to be closed automatically.

    (Copilot is off and all flight assistance are also off)

    -Spoilers I open with a button on joystick, BUT close not works neither with a button neither with SHIFT-B (that i also assigned)

    So, Its a incompatability with this stick?

    Thanks in advance

  • We tried with A320 and B737 on the ground with zero speed and all turned on on runway. Its a weird thing because in my PC with a TM Warthog i not had that, and all works perfectly, but him, and i double checked all the settings, have that issue and i was puzzled why. After multiple tests i could only figured as a kind of incompatability with that stick.

    I restarted the AFS4, checked all flaps settings on essential, twin, quad, aircraft, ...... no axis assigned, no, multiple buttons on the Flaps open/close, reassigned the buttons, no assistances selected, .... All equal to my PC, the only thing different was the stick himself, mine is a Warthog, him with a Stick X.

    Edited once, last by stavka (July 12, 2022 at 6:06 AM).

  • We assigned for example the Engines Reverse to another joystick button and it worked well. When we press and hold it did the reverser full, when we released it removes the reverse.

    The Flaps with TM T Flight Stick X looks and acts like that with flaps. I need to press and hold the Flaps Out to flaps open and it opens it fully, If i released it it closes the flap, If i do a brief push it slightly open it and immediately close the flaps (not goes to the next opened step as should).

  • Wait!

    not exist an option on the controllers detected where you can define if the controller act like a joystick or act like a gamepad?

    Maybe that controller where detected as a gamepad and it enabled that behavior.

    Today, later, i will have access to my friends’s pc and will explore that. I will report here the findings.

  • Dear Jan,

    its all fixed and working correctly. How?

    I goes to that controllers settings, but no, it was as joystick and not as gamepad. So as a last hope, I goes to Flaps, removed all keys associated by default (F and Shift-F) and then put again the same joystick buttons on the Flaps In/Out slots more closed to the center axis bar. Then, I tested and all ok. I did the same with airbrake, removed all the keys and only inserted the 2 buttons of this joystick. Now its all ok!

    Best regards