Not saving IP-Address. Not connecting to SkyDemon

  • When I enter a IP address into the broadcast field the value would not save...


    It is always repalced by some (default) IP when I return to the settings menu. Why is that?


    Also I cannot connect to SkyDemon running on the same machine


    SD shows connected but does not receive position data.


    Even if I change the IP to the correct IP of my machine (by editing the main.mcf file) it would not show position data


    Here is my tm.log:


    103.85-tm_ext_net: initializing connection 'flightinfo_broadcast' ipaddress='192.168.1.255' target_port=49002 receive_port=49002

    103.85-tmsysnet_udp: ERROR: (bind failed (10013=An attempt was made to access a socket in a way forbidden by its access permissions.))

    103.85-tmcollision: ERROR: (failed to open connection. error='An attempt was made to access a socket in a way forbidden by its access permissions.')


    Regards


    Robert

    ok.. it seems this is a R22 Forum now...

  • Hi aero_robert,


    I had the same issues recently, as "workaround" you can manually edit your main.mcf file with the desired IP adress. EDIT, ok, now I see you already did it and added your tm.log... No idea, then...



    Previous reply, probably not related :

    After this step, SD seemed not to receive my aircraft position, but actually SD does get your position, however with some 30+ seconds delay, which makes it useless.


    I tried out several things but refrained from posting here my issue since it's obviously a SkyDemon issue :

    1) after quitting AFS2, my position keeps updating in SD for some 30 seconds before to loose the signal

    2) several users have been complaining on SD forum since may 2018 about a 30+ seconds position delay when connecting to X-Plane, but SD team apparently never officially took aknowledge of the issue.


    Last SD update claims to fix a dramatic app slow down and I noticed a significant improvement with the delay reduced to a couple of seconds, still not perfect...


    Connecting our real flight app to our favorite sim is a very important point to me since it's the best way to safely test new features and get/keep familiar with your app in flight situations before to sit in the real cockpit.


    Sorry not to be more helpful.


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 4.00GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

    Edited 2 times, last by Trespassers ().

  • Thank you Antoine,


    I dont think ithe issue is on SkyDemon


    If I connect to Aerofly via my local Network (iPad to PC) SD receives Data and works as expected.

    If I connect to x-plane 11 it also works as expected. (even when connecting from SD running on the same machine as x-plane)


    There must be a problem in Aerofly's code to fail the connection when client (SD) and Server (AF2) runnning on the same machine.


    Furthermore there is a bug where AF2's IP-settings do not get saved to the main.mcf file.


    Regards


    Robert

  • Furthermore there is a bug where AF2's IP-settings do not get saved to the main.mcf file.

    Yes definitely.


    Quote

    If I connect to Aerofly via my local Network (iPad to PC) SD receives Data and works as expected.

    Does SD update you position without any delay in this configuration ? I know it's not your issue, but since it's mine I would be interested if this works properly for some people...


    Thanks and good luck with your conflict, hope IPACs cans help you


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 4.00GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • Yes, as I said it works as expected (via local-network and with x-plane 11). Position is constantly updated without delays.

  • Yes, as I said it works as expected (via local-network and with x-plane 11). Position is constantly updated without delays.

    We will try to replicate this to see if it's anything on our end, however, I just tested this and it works as intended.

    Please don't use X-Plane as a comparison here as we are not the same.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • No and that may not work. SkyDemon may need to update the application to work like that.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff