VR crashing SteamVR + HP Reverb G2

  • Hi


    I got a new PC last weekend since then I am trying to get AF2 back to life. While all the other sims are back to work as normal, AFS2 keeps crashing.

    In fact it works flawless without VR. As soon as I start the VR version, SteamVR launches for my HP Reverb G2. AFS2 is not making use of OpenXR obviously. Once I launch the flight, steamVR freezes. I still can hear the engine running, but the display I gone. After a few moments the systems closes or we end up in a bluescreen.


    All other apps appear to be running correctly in VR. Looks like a very isolated issue


    DxDiag is attached

    Files

    MSFS | X-Plane 11.5x | DCS 2.5.7 | War Thunder | Aerofly FS4


    Win11-x64 | Lenovo Legion T7 34LMZ5 | Intel i7-10700K @3.6GHz | Kingston FuryX RGB 32GB DDR4 PC3200 | 6TB SSD Samsung 850 Pro | 3TB M2 PCI 4x | Gigabyte RTX 3070 Ti Vision OC | TM Hotas Warthog | Saitek Combat Pedals | Reverb G2

  • Worked - Thank you!

    MSFS | X-Plane 11.5x | DCS 2.5.7 | War Thunder | Aerofly FS4


    Win11-x64 | Lenovo Legion T7 34LMZ5 | Intel i7-10700K @3.6GHz | Kingston FuryX RGB 32GB DDR4 PC3200 | 6TB SSD Samsung 850 Pro | 3TB M2 PCI 4x | Gigabyte RTX 3070 Ti Vision OC | TM Hotas Warthog | Saitek Combat Pedals | Reverb G2

  • Have you tried disabling Vulkan? I've got a Quest 2 and it also crashes every time if Vulkan is enabled. It's fine when disabled. No idea why, as Vulkan worked fine for my old Rift S.


    I know it's not he same as a G2, but might be worth a shot.

    psionmark Sorry, a bit off topic, but I have no problems with my Quest 2 (Link or Air Link) using Vulkan as long as I startup fs2 with SteamVR. I just startup SteamVR and select fs2 from the SteamVR void library panels. You are right that the Q2 with native oculus still does not work with Vulkan but I still get much better VR performance running it through SteamVR with Vulkan than native oculus with OpenGL. Up to you to see what works best I guess.


    MartinM It's been a while since I used WMR but I believe there now is an option to bypass the cliff house and startup with SteamVR. Just avoid the SteamVR home and use the void. You need to make sure your SteamVR for wmr and graphic drivers are up to date as well, which I'm sure you already know. If you get it all working fine with OpenGL maybe then try switching the settings back to Vulkan. Most other reverb g2 users do not seem to have problems running Vulkan and find that it performs better than OpenGL. Good luck sorting this out mate and cheers.

    Custom built gaming desktop; Win10 pro, i9 9900k (water cooled) oc to 5ghz, zotac rtx 3090, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd, corsair gold 750w psu, Asus ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Vive Pro w/etsty gear VR lens mod, and Quest 2 wireless with Air Link. Asus VG248QE external 1080p 144hz gaming monitor.

  • psionmark Sorry, a bit off topic, but I have no problems with my Quest 2 (Link or Air Link) using Vulkan as long as I startup fs2 with SteamVR. I just startup SteamVR and select fs2 from the SteamVR void library panels. You are right that the Q2 with native oculus still does not work with Vulkan but I still get much better VR performance running it through SteamVR with Vulkan than native oculus with OpenGL. Up to you to see what works best I guess.

    Ah thanks for the tip, I'll give that a go. I've always just started the sim directly, rather than through Steam (I have the non-Steam version), but I'll try this out. To be fair, performance even on non-Vulkan is pretty good with my hardware, so I'm not overly concerned, but I'll certainly give it a go. Extra performance is always nice :)

  • MartinM It's been a while since I used WMR but I believe there now is an option to bypass the cliff house and startup with SteamVR. Just avoid the SteamVR home and use the void. You need to make sure your SteamVR for wmr and graphic drivers are up to date as well, which I'm sure you already know. If you get it all working fine with OpenGL maybe then try switching the settings back to Vulkan. Most other reverb g2 users do not seem to have problems running Vulkan and find that it performs better than OpenGL. Good luck sorting this out mate and cheers.

    Thanks Tom. Yes, i do not start SteamVR Home. I just launch SteamVR for Mixed Reality. I have the latest NVIDIA Driver installed. Switching to Vulkan freezes or worst case gives a BSoD.


    High hopes on AFS4 now 😉

    MSFS | X-Plane 11.5x | DCS 2.5.7 | War Thunder | Aerofly FS4


    Win11-x64 | Lenovo Legion T7 34LMZ5 | Intel i7-10700K @3.6GHz | Kingston FuryX RGB 32GB DDR4 PC3200 | 6TB SSD Samsung 850 Pro | 3TB M2 PCI 4x | Gigabyte RTX 3070 Ti Vision OC | TM Hotas Warthog | Saitek Combat Pedals | Reverb G2