Can Hybrid drives slow FS2? Help please.

  • Help


    I get 100% frozen frames with the Aerofly sound continuing in the background and ctrl/alt/delete and task manager exit gives me a working PC. The only changes from a previously working Aerofly is that (1) it is 11 months since I had used PC FS2 and (2) it is installed on a new 2TB hybrid drive.


    My CPU is an overclocked Pentium G3258 which 'CPU-Z' confirms is running at 4.2 GHz although it seems to throttle down to 800 MHz when idle (relevant?). My graphics card is an Asus GTX950 OC Strix which I have used with a variety of built in and custom performance settings. When I check the GPU performance display after a freeze the GPU has been running at about 25% of maximum. The drivers are new, issued on 24/4/18. Windows 10 with all the smart monitoring turned off is in use.


    Previously any crashes were from running FS2 at 120GHz or unlocked with adaptive VSync and the post crash GPU performance had hit (fatal?) 100%. The output is 1080. Now with unlocked and adaptive Vsync, most of the time the control menus are sluggish and the frame rates are between 10 and 15 fps but occasionally I get 60 fps on a fresh PC boot but it is still prone to freeze. The graphics card fan never cuts in and the temperatures are basically room temperature. I always did a computer restart after a freeze.

    My only other installed game is Eurotruck Simulator2 which runs fine, it is installed on a SSD.


    I have tried a variety of bottleneck solutions such a CPU virtualization in BIOS (I checked compatibility) and manual Nvidea control panel overrides but nothing helps. The freezes were apparent from the initial installation (about 2 weeks ago) and could be triggered by adjusting the Dash 8 nav radios or running into JFK at dawn with marginal visibility in a more basic aeroplane.


    My graphics card has 2 GB of memory, has FS2 outgrown more basic cards during my time out or could the hybrid drive solid state management be slowing me down? I ran the Steam file check which was OK.


    Any ideas please?

  • Can you please verify that Aerofly runs with your GTX950 card and not on the processor's graphics chip if it has one?

    Did you modify any other settings for the graphics card? (e.g. in nvidia settings or something) try to turn off any settings, set everything to default or off and maybe think about deleting the main.mcf in your user documents to start aerofly with a fresh configuration. (joystick settings won't be affected by this)

    Aerofly doesn't really need a powerful processor. Overclocking is not necessary, try running aerofly without it, too.

  • I'm pluged into the graphics card, does that guarantee the card is the only graphics providerin use? I tried it this morning and everything seems fine but I haven't gone extreme yet. This is what the PC was at just after I exited FS2. I'll check the bios to make sure that the CPU graphics are not being used.

  • The problem is most likely your CPU. You only have an entry level CPU with just a dual core and fairly low Cache memory. If Aerofly loads new stuff in the background you will likely hit the limitation of your dual core CPU.


    Also, it is strongly recommended to not tweak anything on your system, e.g. remove those tools that allow you to adjust some system settings, with Windows 10 this is not required at all and will likely mess up your system. Also, restore all your BIOS settings to default and also do not overclock. In most cases this does not help at all.


    When running Aerofly, ensure no other program is active in the background, especially your 'tweak tools' or other things like Skype, Browsers and so on.

  • Thanks 'Admin' and Jan, I'd been looking at an i5 K. Using the unlocked Pentium was more of a fun hobby thing than a realistic expectation of miraculous performance on the cheap.

    It is funny how it ran everything on ultra at 120 fps 11 months ago. The first big upgrade in scenery just after the FS2 release did reduce its smoothness.

    I checked that the integrated graphics is disabled and found that the first page of the bios had it running on power saver. I changed it to 'Asus optomised' and it selected 3.6GHz which seemed to run OK but I still get freezes even if the fps is normal. Stock 3.2 GHz did not really improve things.

    Deleting the main.mcf file did not help.

    Again many thanks.

  • Many many thanks, I turned off the graphics card overclock and ran the CPU at stock speed and everything was stable. I was able to set the graphics on ultra everything except trees and it looked stunning!, absolutely beautiful. The FPS was only 15 but I changed the CPU clock up to a very modest 3.9 GHz and I have 60 fps again with adaptive vsync :-)

    The graphics card is running at 80% now and everything looks unstressed, thanks a million.