Strange "freeze" issue - SOLVED

  • Hi guys,

    I've been using AFS2 for quite some time but since the last update I experience a strange issue. The simulator "freezes" mid-flight, and I have to shut down the AFS2 process altogether - otherwise it just hangs.

    I tried verifying the files through Steam, but it didn't find any issues. Then out of curiosity I also installed AFS2 on another PC - it produced the same issue. I had a look at the log file but there was nothing useful there. I attached a screenshot showing the frozen sim and the resource usage at that time. I also attached the logfile. Any ideas where should I look for further troubleshooting? Anyone else with this issue?

    My PC specs are: HP Elite 180a, 12GB RAM, GTX750, Samsung 1TB SSD

    Thanks in advance


  • With the new Win 10 build, I seem to be seeing the LNAV paths all over the place, and usually in yellow. I figure I need to restart or reset something.

    No real freezes when using VR .. I have not used an external controller for quite a while.

    HTC Vive Cosmos Elite

    Win 11

  • Hi guys,

    Happy to report that I found the culprit, and to be honest I would've never in a 1000 years thought this could be it. So, whenever AFS2 froze I checked the Event Logs. There was this one curious item that keep popping up at the time of the simulator crash: the Application Experience Service started. So, I Googled up on this and found that there are two scheduled events that control this silly think. I disabled them both in Task Scheduler and Viola! no more freezes. Here is the screenshot of the two Tasks (AitAgent and ProgramData Updater) disabled:

    This might be some useful info for the Devs as this never happened before the last update - not sure what the connection is though.



  • Well where are the event logs, do they need to be setup, is it anything to do with an Aero log file?, sorry I'm not that software savvy. My PC doesn't run Aero the way it did last year, I had a year off with surgery and medication so I might have changed something in the little time that I was at it, the medication hit my memory a bit. I used to be able to fly and use navaids over New York but it freezes now.

    Thanks for the reply Dan, just a few pointers would be a great start.


    After the Nth request I got a password reset for Geforce Experience which I think was installed after my last FS2 usage. It had running instant video replay and enabled video recording and live streaming (!) and had some other background processes all of which I turned off. My frame rates went through the roof, now it's 120 to 200+ fps, but I still get occasional (after up to 40+ minutes) freezes.

    It seems to run remarkably smooth with all the graphics settings at minimum and with the main FS2/Aero exe set at 'above normal' priority in task manager.

    Adjusting nav radios seems to cause most of my freezes, I think only the Learjet had full working nav radios a year ago.

    It ran perfectly last year so I can't help thinking it is some software or setting issue rather than the inadequacies my humble 2 core Pentium G3258 running at various clocks up to 4.2 GHz. I have a 2 GB GTX950.

    Edited 2 times, last by Overloaded (May 31, 2018 at 2:04 AM).

  • Both the Event Viewer and Task Scheduler are native part of Windows 7. You can access them by clicking on Start menu and right click on Computer. Select Manage from the pop-up menu:

    You'll see both Event Finder and Task manager on the top-right.

    From here you can disable those tasks as per the screenshot in my previous post.

  • For completeness can I close my freeze issue, my windows page file was windows managed on a 15 year old sata hard disk! Since moving it onto SSD and manually allocating between 20 and 30 GB I have been running in and out of JFK at dusk in low visibility with the graphics turned high or ultra and have been twiddling the nav buttons in the 737 at will for over two hours. Early yet to say I'm fixed but .....

    I presume it would be a waste of the solid state element to put a page file on my new Aero' only hybrid drive?

  • A bit more on AintAgent. On your risk:)

    "ForgetMeNot: Turn off Windows Compatibility Appraiser

    10 Jul 2015

    One of the advantages of infrastructure as code is that we now have complete control of the states of a computer.

    This consequently means that I can measure performance between two known states and I only have to look at the difference between states to figure out what went wrong.

    Well, in theory. Microsoft and the Microsoft Updates keep pulling the carpet under your feet.

    In this case, one of the patch Tuesdays in February introduced KB 2952664 which adds the "Microsoft Compatibility Appraiser" to ostensibly ease transition to Windows 10. Unfortunately that drives up CPU usage and brings computers (and much worse, VMs) to their knees.

    The whole process is a collection of tasks running regularly, whether a user is logged on or not and more importantly whether you opt-in for the MS customer experience program or not.

    It's all very fishy.

    Turns out VMWare has a knowledge base article for the tasks that need to be excised.

    The following commandlines solve (or at least appear to solve) the problem:

    schtasks /Delete /F /TN "\Microsoft\Windows\Application Experience\AitAgent"
    schtasks /Delete /F /TN "\Microsoft\Windows\Application Experience\Microsoft Compatibility Appraiser "
    schtasks /Delete /F /TN "\Microsoft\Windows\Application Experience\ProgramDataUpdater"
    schtasks /Delete /F /TN "\Microsoft\Windows\Customer Experience Improvement Program\Consolidator"
    schtasks /Delete /F /TN "\Microsoft\Windows\Customer Experience Improvement Program\KernelCEIPTask"
    schtasks /Delete /F /TN "\Microsoft\Windows\Customer Experience Improvement Program\Use CEIP"