Airbus Throttle does not work with Thrustmaster TCA Quadrant Airbus Edition

  • In the new AF FS 4, the throttles in the Airbus no longer work with the Thrustmaster TCA Quadrant Airbus Edition. I can move and calibrate the throttles in the settings, but they have no function in the Airbus. The drivers are up to date, the device is calibrated and works in the AF FS 2 without problems. Do others also have the problem and what can be the cause?

    • Official Post

    Did you assign one of the throttles to the default throttle input or both? Please assign only one for the default throttle.

    Then, in the controls settings you can assign multiple thrust levers for twin engine propeller and jet as well as quad-jets. If you don't assign anything in a category aerofly will fallback from quad-jet to twin-jet and twin-jet/twin-prop to default throttle assignments.

  • Vielen Dank für die Hinweise. Ich kann jetzt die Throttle im Airbus bewegen, allerdings gehen sie von Idle direkt auf die letzte Stufe MAN TOGA ohne die Zwischenstufen zu rasten. Danach gehen sie nicht wieder zurück. Erst wenn ich auf Reverse gehe, kann ich sie auf Idle zurücksetzen. Wie gesagt, im AF FS 2 funktioniert alles wie erwartet und ohne Probleme.


    Thank you for the tips. I can now move the throttles in the Airbus, however they go from Idle directly to the last stage MAN TOGA without latching the intermediate stages. They do not go back after that. Only when I go to Reverse can I reset them to Idle. As I said, in AF FS 2 everything works as expected and without problems.

    • Official Post

    Hi Jürgen,


    Go to the controls settings, devices and temporarily disable the throttle quadrant. Then go to through the different control menus and remove all assignments that are still active for the throttle axis, i.e. remove the default throttle slider assignment from your stick base. Then re-enable the throttle quadrant and test it.

  • Is what I said in an other post. With Thrusmaster HOTAS and A320, even after calibration, throttle move from Idle to TOGA, multiple times during taxi. Need to push and replace control in Idle again and again to stabilize the response for a long time. Wasn't problematic under AFS2.

    So will try too to delete all the assignments as suggested by Jet-Pack. But installing AFS4 (with AFS2 already installed ?) can visibly be surprising for a couple of settings.

    Sim and french Private Helicopter and Airplane licence

    Conf: AMD 5800x3D 32G Nvidia RTX3080 FE / Hardware cockpit with G1000 Simionic PFD MFD, OEXAM EC135 Cyclic, OEXAM Collective and pedals. Hotas Thrusmaster / WMR HP Reverb G2

  • Hi Jürgen,


    Go to the controls settings, devices and temporarily disable the throttle quadrant. Then go to through the different control menus and remove all assignments that are still active for the throttle axis, i.e. remove the default throttle slider assignment from your stick base. Then re-enable the throttle quadrant and test it.

    Unfortunately, this did not bring any improvement. The throttle axes on the Thrustmaster TCA Quadrant Airbus still do not work correctly.

  • It seems to affect all aircraft. When I move the throttle forward one step (CL in the Airbus), the throttle in the simulator moves very slowly to this position and then continues to MAN TOGA or full throttle. Only when the throttle is set to reverse on the TCA quadrant does the throttle in the simulator go back to reverse or idle.

    I have deleted all other assignments of the throttle axes before and set other control units to OFF. Unfortunately all this did not help.

    Other control units (T.A320 Pilot, GoFlight TPM) work as expected. Only the TCA Quadrant is causing the problems.

  • I have a thrustmaster HOTAS Warthog. I did a flight from GCTS to GCLA yesterday. Throttle were working fine.

    MSFS | X-Plane 11.5x | DCS 2.5.7 | War Thunder | Aerofly FS4


    Win11-x64 | Lenovo Legion T7 34LMZ5 | Intel i7-10700K @3.6GHz | Kingston FuryX RGB 32GB DDR4 PC3200 | 6TB SSD Samsung 850 Pro | 3TB M2 PCI 4x | Gigabyte RTX 3070 Ti Vision OC | TM Hotas Warthog | Saitek Combat Pedals | Reverb G2

  • Also Working fine now with Hotas Warthog after deleting all settings preconfigured by AFS4

    Sim and french Private Helicopter and Airplane licence

    Conf: AMD 5800x3D 32G Nvidia RTX3080 FE / Hardware cockpit with G1000 Simionic PFD MFD, OEXAM EC135 Cyclic, OEXAM Collective and pedals. Hotas Thrusmaster / WMR HP Reverb G2