Vulkan broken in Oculus VR

  • Your issue may solely be that you are using a very old HMU (Oculus Rift DK2)

    Let us take a look at this internally and we will get back to you with an answer.

    Don't think that age got anything to do with it since I'm using Rift S

    This problem have been going on for some time.

    There is another thread about it so there is many others having this issue

    Black screen in VR (Vulcan)



    i7-7700 CPU

    GTX 1080 ti

    16 GB RAM

    WIN10

    Oculus Rift S


    tm.log

  • Since we can't recreate this problem we need specific things from those who are having the problem so that we can try to find the problem. And yes, using a 'development' DK2 can make a big difference. We all have Rift S's to test with and see none of these problems. The question is what is different between our configuration and what is theirs. Keep in mind that the OP changed the title three times already which makes it very difficult to pinpoint what the problem really is.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Since we can't recreate this problem we need specific things from those who are having the problem so that we can try to find the problem. And yes, using a 'development' DK2 can make a big difference. We all have Rift S's to test with and see none of these problems. The question is what is different between our configuration and what is theirs. Keep in mind that the OP changed the title three times already which makes it very difficult to pinpoint what the problem really is.

    Well I appreciate that it's finally being looked into. There's a theory that it's a Nvidia driver problem. Hope you can figure it out. Thank you

  • Sorry about the title changes, I thought it would help as we're looking at a layered issue trying to get to the root of it.


    I looked at the thread Thruster posted (Thanks buddy :thumbup:) and I can confirm that rolling back the drivers to the GeForce 442.74 release fixes the Vulkan issue on my system; so it does look to be related to the latest 445.87 drivers.

  • Sorry about the title changes, I thought it would help as we're looking at a layered issue trying to get to the root of it.


    I looked at the thread Thruster posted (Thanks buddy :thumbup:) and I can confirm that rolling back the drivers to the GeForce 442.74 release fixes the Vulkan issue on my system; so it does look to be related to the latest 445.87 drivers.

    We are beginning to think the same thing here. If this is the case unfortunately we won't be able to fix this issue as it has nothing really to do with our code. Whatever device that is connected through the Oculus SDK should work if it's working properly in other applications that run in vulkan.


    We will continue to keep our eyes open on our end at this situation but right now we have to pull away to work on other stuff as we already spent some time on this.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • We are beginning to think the same thing here. If this is the case unfortunately we won't be able to fix this issue as it has nothing really to do with our code. Whatever device that is connected through the Oculus SDK should work if it's working properly in other applications that run in vulkan.


    We will continue to keep our eyes open on our end at this situation but right now we have to pull away to work on other stuff as we already spent some time on this.

    Hello. Sad I cannot run it too using Rift S + latest geforce drivers + Vukan i get a black screen. However it works well with the other API so I do not really get what I am missing by not being able to use vulkan instead :)

  • Hello. Sad I cannot run it too using Rift S + latest geforce drivers + Vukan i get a black screen. However it works well with the other API so I do not really get what I am missing by not being able to use vulkan instead :)

    I have an Oculus Rift S with the latest NVidia drivers and Aerofly runs fine in Vulkan mode. Make sure that you are using drivers installed directly from NVidia (or GeForce Experience) and not let Windows install the drivers for your GPU. Also, if you are using a laptop with an integrated GPU (like Intel) with Nvidia GPU make sure that Aerofly is using the correct GPU.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • I have an Oculus Rift S with the latest NVidia drivers and Aerofly runs fine in Vulkan mode. Make sure that you are using drivers installed directly from NVidia (or GeForce Experience) and not let Windows install the drivers for your GPU. Also, if you are using a laptop with an integrated GPU (like Intel) with Nvidia GPU make sure that Aerofly is using the correct GPU.

    Ok I will. Thank you.