Vulkan broken in Oculus VR

  • So I logged into Steam today and i can't start AFS2 on my Oculus Rift DK2 anymore. I know it's old but It works fine with every other VR application (War Thunder, IL2...) and up until 3 months ago (last time I checked) it worked great with AFS2 (over 300 hrs on it).

    if I Try to start it in Oculus VR I get the "AFS2 does not support your currently active headset" message, if I click "OK" the game starts in VR mode with Oculus Home but the Headset screen is dead. I can start it in Steam VR mode but the performance/ tracking is awful and it makes it unplayable.


    Can somebody please help ? I'm heartbroken, first my airline career is destroyed by COVID19 and now I can't even fly my favorite flight sim :(


    Maybe it's an update issue, is there a way to downgrade the game to a compatible version?



    Thanks for taking the time <3


    EDIT (May 7th):


    I Fixed the issue by deleting the main.mcf config file in the Documents/ Aerofly FS2 folder.

    I still get the error message but if I press "OK" it works perfectly fine! No need to downgrade. ^^


    EDIT (May 16th):


    Vulkan is causing the blackout issue on Oculus headsets.

    The error message was fixed via steam update.

    The sim works just fine in OpenGL mode, waiting for a Vulkan fix.


    EDIT (May 17th):


    The Vulkan issue seems to be related to the 445.87 GeForce drivers.

    Rolling back to 442.74 fixes the issue at the moment but it's not a definitive solution.

  • Yes I did, got quite the neck pain after :D. HMD is dead as disco, pitch black and no output.


    I just tried to downgrade the game to the jan 30 executable (100% worked fine) via the Steam console with the:

    download_depot 434030 434032 5110625937057247326 command...


    the result is:

    Depot download failed : Manifest not available


    I can only download the latest manifest (may 6) with this procedure.


    Can someone in the dev team share the Jan 30 exe?


    thanks

  • I FIXED IT !!!!


    I deleted main.mcf in the documents/ Aerofly Fs2 folder and let the game rebuild a new one.


    Still gives me the error but if I press "ok" everything works just fine.


    What a relief :whistling:


    Thanks for the help!


    Might be useful to keep the thread up if anybody else has this issue, your call.

  • rairic

    Changed the title of the thread from “"Aerofly FS 2 does not support your currently active headset"” to “FIXED "Aerofly FS 2 does not support your currently active headset" with Rift DK2”.
  • great ;)

  • This appears to be a bug that we will look into

    If you add the parameter '-othervr' to the desktop shortcut and run it from there you should not get the error.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Same thing happens with my Rift S. So it's not the age of your headset that is the problem. Steam VR isn't a suitable substitute. For now, pressing the OK button is the best solution. But it would sure be nice to see it fixed. This hasn't always been a problem. An update along the way appears to have broken it.

  • I would argue that it is NOT fixed at all. Having a band-aid is not the same as a fix.

    Please explain the process that you do to get the error. Are you running the latest version of Aerofly FS2 and Steam?

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Please explain the process that you do to get the error. Are you running the latest version of Aerofly FS2 and Steam?

    There is not much of a process. Just open the game with Oculus and Steam says that Aerofly doesn't support the current headset. Press ok and it starts anyway but with Vulkan enabled the screen in the Oculus goes black. Aerofly, steam and graphic card are updated to latest version

  • Can you please provide us with your TM log?

    I actually seen this happen as well but after a Steam update the problem went away. If it's still happening to you guys then we need to look to see what the problem is.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Can you please provide us with your TM log?

    I actually seen this happen as well but after a Steam update the problem went away. If it's still happening to you guys then we need to look to see what the problem is.

    You are right. That problem is apparently fixed. My bad. I just didn't notice because I thought that the problem was connected to the fact that Vulkan doesn't work with Oculus and it still don't 😢

  • rairic

    Changed the title of the thread from “FIXED "Aerofly FS 2 does not support your currently active headset" with Rift DK2” to “"Aerofly FS 2 does not support your currently active headset" with Rift DK2 and Vulkan”.
  • rairic

    Changed the title of the thread from “"Aerofly FS 2 does not support your currently active headset" with Rift DK2 and Vulkan” to “Vulkan broken in Oculus VR”.
  • Can confirm, no error message but Vulkan is still broken in VR. On the other hand OpenGL seems to be working much better than before, I wasn't able to hold good performance @ 1.5 ss / Ultra without Vulkan before but now I can.

    What are your system specs. Also, please provide us with your TM log located in the Documents/Aerofly FS2 root folder

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • Your issue may solely be that you are using a very old HMU (Oculus Rift DK2)

    Let us take a look at this internally and we will get back to you with an answer.

    IPACS Development Team Member

    I'm just a cook, I don't own the restaurant.
    On behalf of Torsten, Marc, and the rest of the IPACS team, we would all like to thank you for your continued support.


    Regards,


    Jeff

  • I've always had '-othervr' added to start up. But I still got the error. But it was after a steam update. Since then I've had another little steam update and it's gone. Also I fly with Vulkan on with the oculus rift dk2 with no problems. What problems are others having?