Recurrent problem with modelcoverterx

  • Hello, I try to import models with modelconverterx (creations with Blender or existants files) but I often have the same problem of destructurised building.

    I always use BMP textures with alpha removed, resize to power of 2, minimize drawcalls when it's necessary.


    No problem here


    But with an other building...

    or this :


    What am I forgetting or what am I not doing right ?


    Thank's for your help.

  • Hi,


    I have the very same issue on some buildings, and I think the answer might be found in Jet-Pack's reply here (not tested yet)


    3D model not displaying correctly in Aerofly FS2


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 4.00GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • Thank's, I've just try it but no more success unfortunatly.


    And I can't understant why I have no problem with two buildings (the tower and the building below) and problems appear with a third, one that uses the same textures

  • Thank's, I've just try it but no more success unfortunatly.


    And I can't understant why I have no problem with two buildings (the tower and the building below) and problems appear with a third, one that uses the same textures

    How did you do it?

    I think there's an option in 3DSMax to merge the origins of multiple geometries into 1 common. This is something that can be checked when trying to rotate your object : each geometry rotates around its own centerpoint instead of seeing the complete object rotating as a block. Of course you won't notice it by translating objects.

    There must be a similar option in Blender or AC3D.

    I don't think there's a feature in MCX to do it


    At least, it is something I noticed on some occasions, and I would expect, as Jet-Pack wrote, that once all geometries share the same centerpoint that the resulting 3D object TMB behaves as a block. Again, I've not yet tested but I know in which building I want to do it next...


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 4.00GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • Have you tried rotating your object? If it rotates as a block it should be ok...

    Config : i7 6900K - 20MB currently set at 4.00GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.

  • Check whether the faces are "reversed". I can't really see what your problem is on your pict, but it seem like some ghosting surfaces. We have that a lot when we convert from sketchup.

    From sketchup the process is basically three fold (we haven't fully figured out why, but it seems to work like that now):

    Make sure that there is no reverse face showing

    Use texture on both sides of all faces (I think that is only a sketchup thing, i.e. only for sketchup models)

    Convert with alpha off (although that part would need more testing as sometimes we want a transparent texture, but anyway)

  • Check whether the faces are "reversed". I can't really see what your problem is on your pict, but it seem like some ghosting surfaces. We have that a lot when we convert from sketchup.

    From sketchup the process is basically three fold (we haven't fully figured out why, but it seems to work like that now):

    Make sure that there is no reverse face showing

    Use texture on both sides of all faces (I think that is only a sketchup thing, i.e. only for sketchup models)

    Convert with alpha off (although that part would need more testing as sometimes we want a transparent texture, but anyway)

    This model is homemade with Blender. I don't find the option to have textures on both of all faces...


    But I not sure that is the solution, because I see that if I use only one or two textures there is no problem :


    And if I use three the problems begin :

    or


    It's like modelconverterx can not convert correctly object with more than two textures...

  • This is most people's problem. Try to Compress all three images to one main image. Then you will have no problems. Example: When reducing/minimizing drawcalls choose texture size of 4096x4096 or reduce size of each image to perhaps 512x512. Not at computer but I think you get the idea of what I mean in MCX. Feel free to send a zip of your Dae file and textures and I can show you. Good luck

  • And I can't understant why I have no problem with two buildings (the tower and the building below) and problems appear with a third, one that uses the same textures

    Hello Didier,


    My experience:

    Using autoheight on, FS2 calculates for every used texture in an object his own a kind of "center of gravity", that is different from the center-point of the model (!). This cause the level-issue with the different textures if the terrain is not flat.


    Question:
    Do you have only one object and are you using autoheight on?


    Using only one texture (after reducing the textures/drawcalls witch MCX) or with autoheight off (absolute height-method) you won't have the issue.


    An other solution for fixed-placed-buildings is to compile several objects with the same center-coordinates (so it fits) individually and to adapt the level manually for each object or even single compiled texture.


    Finally - that may be very challenging - it's also possible to make "symmetric" resp. "balanced" objects, where every used texture has the same "center of gravity" by using resp. underlaying not visible parts of the object with this texture to "balance it out".


    Regards,

    Christophe

  • ZoSoChile (sorry, don't remember your name ;)) : If I can’t do it with all this, I’ll send you my file

    :thumbup::D:thumbup: I'm almost 100 percent positive this will work because I've had this same model issue many months back. I see three other forum users claim it is autoheight issue? Perhaps it is, and this is another workaround solution.


  • Hello Didier,


    <[tmsimulator_scenery_object][element][8]

    <[string8][type][object]>

    <[string8][geometry][LSGBsp2007]>

    <[vector3_float64][position][6.984387 46.259110 399.9]> ---> absolute altitude 399.9 meters

    <[float64][orientation][-1]>

    <[int32][autoheight_override][0]> ---> 0 = autoheight Off

    >

    <[tmsimulator_scenery_object][element][9]

    <[string8][type][object]>

    <[string8][geometry][lsgb_t]>

    <[vector3_float64][position][6.988578 46.256478 0.2]> ---> relative ground-level + 0.2 meters

    <[float64][orientation][25]>

    <[int32][autoheight_override][-1]> ---> -1 = autoheight On


    It seam also to have the [autoheight_override-value] [1]. --->Does somebody now the meaning/effect of it?


    Regards,

    Christophe

  • It seam also to have the [autoheight_override-value] [1]. --->Does somebody now the meaning/effect of it?

    There are two settings :

    autoheight (true or false) which is a global switch for the tsc file

    autoheight_override (0 or 1) which is linked to an object. The value -1 gives the same result as 1, I haven't noticed a difference.


    Example with [autoheight][true] and [autoheight_override][0], note that I have given an offset of 35m, which is approximately the local ground altitude AMSL.


    If I set [autoheight][false], then whatever the autoheight_override value my object is placed at absolute altitude, i.e. 35m AMSL



    If I set [autoheight][true], and [autoheight_override][0], then I override the autoheight algorithm and my object is still placed at absolute altitude (35m AMSL).


    If I set [autoheight][true], and [autoheight_override][1], then autoheight computes the local ground altitude and my object is placed at relative altitude (35m AGL).


    [autoheight_override][-1] gives the same results as [autoheight_override][1]


    In other words :

    [autoheight][true] + [autoheight_override][-1 or 1] = autoheight is on and the Z coordinate works as an offset to local ground

    [autoheight][true] + [autoheight_override][0] = autoheight is off and the Z coordinate works as an offset to sea level

    [autoheight][false] = autoheight is off and the Z coordinate works as an offset to sea level


    Cheers

    Antoine

    Config : i7 6900K - 20MB currently set at 4.00GHz, Cooling Noctua NH-U14S, Motherboard ASUS Rampage V Extreme U3.1, RAM HyperX Savage Black Edition 16GB DDR4 3000 MHz, Graphic Card Gigabyte GeForce GTX 1080 8GB, Power supply Corsair RM Series 850W, Windows 10 64 bit.