Aerofly FS 2 Steam Previous Alpha Builds

  • First time poster. Just wanted to state that this is such a great sim to fly in. My home town of PHX looks amazing!

    As I have been testing the alpha, even with the most recent update, the A320 still does not fly a route. The minute you turn on auto pilot or co pilot, the altitude is set at 100' and the plane just slowly flies itself into the ground after a brief left turn. This was noted with the very first route that I plugged in from KPHX R26 to KFLG R21 using CHILY3 departure. FD also does not indicate course either. When flying completely off course, the FD still shows a perfect cross instead of directing which way to turn to return to the route. Additionally, are you able to look into the taxi thrust issue as well? It takes up to 30% N1 to even get the plane moving and when put back to idle the plane slows down quickly. Taxiing felt much better in the current version of the sim. Lastly, is there any way to get a push back feature?? I fly mostly the A320 in the southwest and would love to position my plane at the gate to make it a little more realistic. This really should be a basic function of a sim that includes passenger airliners. No tug animation is needed (would be nice though), but at least a way to select push back and guide the plane where it needs to be to taxi out.

    **Update** At first I thought this might be a problem with the new departures/arrivals SIDS/STARS, so I just made a route to KPHX to KFLAG using the old method of runway to runway direct. This had promising results as the plane started to clime out and begin the right turn North for Flagstaff, setting altitude to 20,000 ft. After a minute of turning right going completely off course, then making a left turn, altitude was set to 100' and we started the decent to the ground. Which flight did you guys test the A320 on? Maybe I can see if that works for me.

    Thank you for your continued work on this big update! Keep up the great work! :thumbup:

    Edited once, last by AZFlyGuy1 (August 4, 2020 at 9:45 PM).

  • I tried the A320 with the latest update today.

    1. Now I do see the F-PLN in the MCDU but where I expect to see SPD/Alt I seem to see distance and I cannot seem to find how to change that.

    2. Departing airport on a straight course from R26 to a fix....MCDU does not seem to trigger at that waypoint and keeps flying straight.

    3. The altitude for the flight seems to be fixed at FL320. How am I supposed to change that? I tried using the Init page but the entry is simply rejected out of hand.

    Flight Plan Route:

    Edited once, last by dvc1716 (August 5, 2020 at 1:35 PM).

  • There is one more request I was wondering about. When you look over the wings on the A320 and 777 the interior sound is playing. On the 747-400 and 737-500 it plays the exterior sounds. Any way to code the view of the wings to play interior sounds on these two planes?

    • Fixed C90GTx airspeed indicator now receives data again

    The advanced autopilot (A320, B777, LJ45, etc. - not the C172, B58 autopilot) should now be able to fly the entire route laterally without any issues.

    Please test this as well with longer routes as we can't test every possible combination.

    C90GTx ASI working - thanks!

    The JF Turbo Arrow GNS 530 seems to follow the Nav course fine (KMRY->KPSP via several waypoints), except it still won't fly the SID, so I didn't try the arrival either.

    However, I note that the GPS displays "28L", which was the takeoff runway, where the next waypoint should be.

    It also appears that the ETE field is now indicating the time to the final destination, not the time to the next waypoint, as it did before. After checking the Garmin manual, I believe it should be time to the next waypoint. The manual defines ETE as the estimated time to the "destination waypoint", but it consistently uses "destination waypoint" to mean the next waypoint in the flight plan, rather than the final destination.

    And while I'm being ridiculously picky, the arrow between MQO and the next waypoint should not have a "D" in it, as the next waypoint is a standard waypoint, not a direct-to destination :)

    But other than that, it's an almost perfect facsimile!

  • Damn! The Turbo Arrow flew this route perfectly from KMRY for over 3 hours all the way to the right base turn for KPSP (next waypoint after PSP), and then turned the wrong way! It did a small "S" turn- turning left and then right onto the heading shown in the screenshot below. I continued on AP for a few more minutes, but she just kept going in a straight line.

    Here is the cockpit view with the a/c in the location shown on the Nav screen above. AP is on, and coupled to the GNS 530. GPS DTK is 078, TRK is 123 - both are incorrect!

    Edited once, last by aroos (August 5, 2020 at 8:18 AM).

  • However, I note that the GPS displays "28L", which was the takeoff runway, where the next waypoint should be.

    I’ve found that trying to bend a route back on itself at Palm Springs makes the route go crazy and sometimes it will go back to the route start. The RNAV approach which curves clockwise from the west (BALDI) all the way to point up to 31 always fails near the end.

    The FS2 route must not be able to cross itself without crashing.

    There are uncorrected sim errors in that area too, the DME at THERMAL VORTAC gives a distance from 5 miles underground.

    Edited once, last by Overloaded (August 5, 2020 at 4:06 AM).

  • Thanks for the efforts, iPacs.

    I flew today with the A320. It behaved a little better, but I noticed a few things:

    - TOD is not calculated by the MCDU and is not shown in the ND.

    - I started the descent where I estimated to be close to TOD. At that moment, it seems that navigation was lost because of this. The distance to the destination was stucked, it stopped decreasing even though I was approaching the destination (in the MCDU and in the upper display of Aerofly).

    - In one of the waypoints (VOR SWR), the aircraft went straight, did not make the turn. I needed to use HDG heading and when I was close to the route line, the aircraft started a wrong turn o left. (I finished AF2 just after)

    - While the aircraft was following the route, it was a little out to the right.

    - I don't know if it was because my delay to activate NAV mode after takeoff, the AP didn't make the first turn. I activated the HDG mode to intercept the radial at an angle of 45º. The aircraft correctly entered NAV mode, turned slightly but "gave up" and returned to HDG mode. I tried again on the other side and it worked this time.

    PS: The flightplanner missed a summary of the total flight distance.

  • I'm seeing a substantial performance loss in the alpha compared to the release version when Vulkan High Quality AA is enabled.

    With the aircraft at the standard takeoff location for 31L at Orbx Palm Springs (KPSP), I am getting only 16 fps with the alpha, compared to 46 fps for the release version (i.e. with alpha channel disabled in Steam). See attached images, alpha first, frame counter lower left. In both cases I rebooted the PC immediately before doing the measurement to ensure a consistent environment. Graphics settings: 1920x1280, Vulkan, High quality AA ON, graphics quality HIGH except shadows and trees MEDIUM. Graphics card NVIDIA MX150 with 2GB graphics RAM.

    Turning high quality AA OFF increased the frame rate in the alpha to 60 fps, which is a much greater increase than normal. An increase from 46 to 60 would be about right, not an increase from 16 to 60. So I suspect there is some performance issue with the Vulkan high-quality AA in the alpha, especially in high resolution scenery. I also tested on RWY 10R at Orbx Monterey, and saw a similar result (20 fps with HQ AA ON, 57 fps, with HQ AA OFF) as did Orbx LOWI (night) which gave 15 fps and 54 fps. However RWY 07L at LAX (default scenery) gave a much smaller difference: 22 fps (HQ AA OFF) and 31 fps (HQ AA ON).

  • The GPS legs displayed seem stuck on incorrect or inappropriate waypoints. It does not leave a route start waypoint.

    115049 Finals for runway 08 at Salinas. F08 to 28L (the Monterey take off runway) is displayed.

    115407 The to Salinas route map. 28L departure.

    120405 A circular route map. The GPS and autopilot followed it perfectly.

    120902 Mid route point W2205 to 08 displayed on the Salinas take off runway. Nonsensical leg label

    121302 Take off, rolling on runway 08 to 08 labelled leg is now displayed. 08 will not go away.

    122402 Stuck leg label 08 to 08 is displayed but the next leg is magenta on the map and is running.

    122521 Route and autopilot follows a circular route perfectly but leg label is wrong cugvu to 08 instead of cugvu to w0917

    122831 Leg labels keep showing to 08. Note this aircraft heading allows the visible rogue bearing line back to the destination (08?) to be seen (from the aircraft symbol to the mid-upper left, adjacent to the end of the 114.90 nav radio field).

    124016 final leg labelled F02 to 08. The autopilot disconnected on the final leg. It made a recovery after a few seconds but disconncted again.

    Perhaps the Palm Springs route and Thermal DME trouble is linked with the local below sea level terrain? Some Jackie Cochran airport fittings hover in mid-air.

    Edited 3 times, last by Overloaded (August 6, 2020 at 10:17 AM).

  • I flew the King Air from KMRY to KPSP following the same route as #168. Again it followed the route until the base turn, then turned the wrong direction. Here are a couple of pics at the point where it should be turning right onto the base leg, in case they are helpful in diagnosing the fault.