FS 4 Flaps

  • Congrats to the team on the release of FS 4.


    I am experiencing a problem with flap operation on the C-172 and King Air when starting at the end of the runway in ready to fly configuration. The flaps are preconfigured fully down, but I cannot seem to retract them either on the ground or once airborne using the keyboard shortcut (which I left to the default SHIFT-F) or the controller button I configured, or even by manually adjusting the flap control in the aircraft using my mouse. When I'm in the control setup screen, the flap controls are shown as working.


    I'm an experienced FS 2 user and have never had this problem. What am I missing?

    • Official Post

    Did you calibrate your flap axis? Or are you just using buttons?

  • I am just using buttons. But I found the reason: If you define the same buttons for flaps up and down in multiengine aircraft as well then you have issues. I deleted those (cosistent) definitions and now the buttons work as expected for the F18.


    Regards,

    Ludger

  • I am just using buttons. But I found the reason: If you define the same buttons for flaps up and down in multiengine aircraft as well then you have issues. I deleted those (cosistent) definitions and now the buttons work as expected for the F18.


    Regards,

    Ludger

    Yes, I realized that too - looks like a bug when you assign certain function in multiengine and standard

    MSFS | X-Plane 11.5x | DCS 2.5.7 | War Thunder | Aerofly FS4


    Win11-x64 | Lenovo Legion T7 34LMZ5 | Intel i7-10700K @3.6GHz | Kingston FuryX RGB 32GB DDR4 PC3200 | 6TB SSD Samsung 850 Pro | 3TB M2 PCI 4x | Gigabyte RTX 3070 Ti Vision OC | TM Hotas Warthog | Saitek Combat Pedals | Reverb G2

  • I too have found that some settings under "Controls" can interfere between the "Essential", "General" and "Multi Engine" sections. I will test this later.

    Tschüss, Michael (🍎🚁)


    Configurations:

    -- MacBook Pro (16", 2021); Chip: Apple M1 Max; macOS 12.1

    -- iPad (12,9", 4th Generation); iOS 15.2

    • Official Post

    I too have found that some settings under "Controls" can interfere between the "Essential", "General" and "Multi Engine" sections. I will test this later.

    We're currently working on this system and user feedback with issues is much appreciated. The more details the easier it is for us to fix it.

  • My devices are according to the display "Input Devices": "T.A320 Pilot", "TCA Q-Eng 1&2", "TCA Q-Eng 3&4" and "T-Pendular-Rudder". Before the test, all functions of all devices have been operated once. The devices are assigned to the various constellations in "Multi engine".

    • Display "Controls"/"General"/"Airplane":
      -- In "Throttle" only 1 thrust lever is shown, while in "Trust Reverse" two reverse levers "Rev 1, Rev 2" are shown.
    • T.A320 Pilot:
      -- The "Pop 0 Up" button is always automatically active at startup and must be deactivated by touching it once.
    • TCA Q-Eng 1&2:
      -- The functions "Ry", "Rx", "AB off" and "Spider 0" are not activated.
    • TCA Q-Eng 3&4:
      -- The functions "Ry", "Rx" and "Spider 0" are not controlled.
      -- The functions "Eng N" and "AB off" as in TCA Q-Eng 1&2 do not exist.
      -- The functions "Rev1" and "Rev2" do not exist.
    • LearJet:
      -- The TCA lever for Revers1 controls Revers2 as well, the TCA lever for Revers2 does not work.
    • Q400:
      -- The simulation levers for "Propeller speed 1" and "Propeller speed 2" are not taken over by the TCA levers until the simulation levers are first dragged back by mouse and then the TCA levers are moved.
      -- "Eng1" and "Eng2" override the TCA levers with the two positions "0 %" and "100 %".
    • Baron 58 / King Air:
      -- The simulation levers for "Propeller speed 1" and "Propeller speed 2" are not taken over by the TCA levers until the simulation levers are first dragged back by mouse and then the TCA levers are moved.
    • A380:
      -- The switches "Eng3" and "Eng4" do not work.
      -- The "Reverse" display in the header bar shows reverse from thrust lever1, although only 2 and 3 can reverse.
    • B747:
      -- The switches "Eng3" and "Eng4" do not work.

    Tschüss, Michael (🍎🚁)


    Configurations:

    -- MacBook Pro (16", 2021); Chip: Apple M1 Max; macOS 12.1

    -- iPad (12,9", 4th Generation); iOS 15.2